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FAX BACK
Mitsubishi has a world wide reputation for its efforts in continually developing and pushing back
the frontiers of industrial automation. What is sometimes overlooked by the user is the care
and attention to detail that is taken with the documentation. However, to continue this process
of improvement, the comments of the Mitsubishi users are always welcomed. This page has
been designed for you, the reader, to fill in your comments and fax them back to us. We look
forward to hearing from you.
Fax numbers:

Your name: ...................................................

Mitsubishi Electric....

.....................................................................

America

(01) 847-478-2253

Your company: .............................................

Australia

(02) 638-7072

.....................................................................

Germany

(0 21 02) 4 86-1 12

Your location:................................................

Spain

(34) 93-589-1579

.....................................................................

United Kingdom

(01707) 278-695

Please tick the box of your choice
What condition did the manual arrive in?

!Good

!Minor damage

Will you be using a folder to store the manual? !Yes

!No

What do you think to the manual presentation?!Tidy

!Unfriendly

Are the explanations understandable?

!Yes

!Not too bad

!Unusable

!Unusable

Which explanation was most difficult to understand: ..................................................................
....................................................................................................................................................
Are there any diagrams which are not clear?

!Yes

!No

If so,which: ..................................................................................................................................
What do you think to the manual layout?

!Good

!Not too bad

!Unhelpful

If there one thing you would like to see improved, what is it? .....................................................
....................................................................................................................................................
....................................................................................................................................................
Could you find the information you required easily using the index and/or the contents, if
possible please identify your experience: ...................................................................................
....................................................................................................................................................
....................................................................................................................................................
....................................................................................................................................................
....................................................................................................................................................
Do you have any comments in general about the Mitsubishi manuals? .....................................
....................................................................................................................................................
....................................................................................................................................................
....................................................................................................................................................
....................................................................................................................................................
Thank you for taking the time to fill out this questionnaire. We hope you found both the product
and this manual easy to use.
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INTRODUCTION
The method to set up the software and the flow of the lessons are explained in this section.
Please read to improve the effectiveness of the later lessons.
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Introduction 1

Introduction
The FX-TRN-BEG PLC Training Software creates a virtual manufacturing cell within in your
personal computer that enables the user to study PLC programming any time or place a
personal computer is available. The manufacturing cell and machines are shown in 3-D
graphic simulations that provide an enjoyable visual element to the PLC training. Watch the
programs that you create control the machines inside the virtual arena!
The structured lesson plans let the user decide at what level to begin the exercises. Clear
objectives are given for each exercise along with programming tips and examples to aid in the
learning process. The large number of exercises provide complete beginners and slightly more
advanced users with challenges appropriate to each skill level. Proceed through the exercises
at the speed that is right for you.
The software setup and the flow of the lessons are explained in Chapter 2. Please read
Chapter 2 to improve the effectiveness of the later lessons.
The 3-D graphic simulations will be controlled by the user program.
The software package includes the following items.

SW0D5C-FXTRN-BEG-E
CD-ROM for system installation:
1 piece

FX-TRN-BEG-E
package

FX-TRN-BEG-E
USER'S
MANUAL

This manual
• Introduction to the software
• Exercise list which supplements the
guidance display on your computer
• Operation of ladder tools
• Specifications of virtual PLC and
virtual machines

Please make sure
all components are
included.
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2.

Outline of the Lesson Plan
Follow the Lesson Plan Flowchar t below to better understand the setup of the PLC
programming lessons.

2.1

Outline
The chart below shows the overall flow of the training software.
Setup of software

• Install the data from the CD-ROM (☞ 2.2).

Startup of software

Starting

• Register as a User (☞ 2.3).

Menu display

• Select a category in the main menu
(☞ 2.4 or Exercise Section).

Selection of exercise

• Select an exercise you would like to try (☞ 2.5).

Confirmation of contents of exercise

• Read the guidance and understand the contents of the
exercise (☞ 2.5).

Creation of program

• Write a program following the guidance
(☞ 2.6 or Ladder Tool Section).

Confirmation of operation

• Transfer the program to the virtual PLC in your computer,
and confirm the machine operation.
(☞ 2.7).

Repeated learning
Self-judgement
End of exercise
End

• Judge the simulation result yourself. If you are a registered
User, points are added and your progress is updated.
(☞ 2.8).
• Exit the learning software. (☞ 2.9).

Stick to it while
aiming at the high
score!
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Setup of Software
Set up the software following the procedure below.
• System requirements for your computer
OS

Microsoft Windows 98, 98SE, Me
Microsoft Windows 2000

Microsoft Windows NT4.0 (SP3 or later)
Microsoft Windows XP*1

CPU

Pentium 500 MHz or more is recommended.

Memory

64 MB or more (128 MB or more is recommended.)*2

Hard disk

150 MB or more

CD-ROM drive

1 unit (for installation)

Display

XGA (1,024 × 768) or more is mandatory.

Video

Video card compatible with Direct3D whose VRAM capacity is 4 MB or more
(8 MB or more is recommended.)

Browser

Internet Explorer 4.0 or later is mandatory.

*1 Only users having the administrator privilege are allowed to set up the software to the
Windows XP and start it up.
*2 Mount the memory having a capacity larger than the value recommended by the used
OS.
"Microsoft", "Windows" and "Windows NT" are registered trademarks or trademarks of
Microsoft Corporation USA in the USA and other countries. Other company names and
product names are trademarks or registered trademarks of each company.
Operating Procedure
1) Start Windows and insert the CD (SW0D5C-FXTRN-BEG-E) included in the package into
the CD-ROM drive to begin system installation. It is recommended to end other application
software before beginning the installation process.
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2) The window below should be automatically displayed.

If the window is
not displayed
automatically,
double-click the
CD-ROM drive in
"My Computer".

Double-click this "Setup" icon on the window to start installation of the software.
* Three types of "Setup" icons are displayed. Double-click the one with a picture of a
computer.
3) When "Setup" is executed, the window shown below is displayed.
• After reading and understanding
messages, click [Next].

the

• Click [Cancel] to cancel installation.

4) Select a folder for the installation destination.
• If you wish to install it to the folder
displayed, click [Next].
• If you would like to change the folder, click
the [Browse] button to select the folder.
Click [Cancel] to cancel installation.

Installation destination folder
A-7
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5) Determine the program folder name.
• The training software will be installed in
this program folder or another folder name
can be entered.
A folder of the same name would be
overwritten if it exists.
• Click [Next] to start the installation.

6) Complete the setup.
• It takes about 10 seconds to perform
installation. If you take the CD out of the
CD -RO M dr ive o r shu t d own your
computer during installation, the software
will not install properly.
• Click the [Finish] button to finish the setup.
* Take out the CD and carefully store it for
later use.

7) Program folders are displayed.
• When installation is completed, the
window shown on the left is displayed.

Did you install
it properly?
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2.3

Begin to Learn PLC Programming

2.3.1

Start the Training Software
Let’s open the training software.
Select [Start] → [Programs] → [MELSOFT FX Trainer] → [FX-TRN-BEG-E].

Note: Do not use this software and MELSOFT GX Developer at the same time.
2.3.2

User Registration
When the software is opened the user registration window is displayed.
If registered as a user, exercises that have been successfully completed will be indicated on
the menu and points will be added to the user score.

If you do not wish to
register as a user, click
[Start] leaving the boxes
blank.

• Fill in the name and password fields to register for the first time.
Name:

Alphabetic and numeric ... 32 characters or less

Password: Numeric

... 8 characters or less

• If already registered as a user, select the user name on the pull-down menu and enter the
password.
If the password does not match, an error message will occur and the password must be
re-entered. The main menu is not accessible.
Register as a new user if the password is forgotten.
User registrations can be deleted by selecting “File” → “Delete user information” from the
tool menu.

A-9

FX-TRN-BEG-E

2.4

Outline of the Lesson Plan 2

Configuration of Main Menu
You can select an exercise from the main menu.
Main menu screen
Category tabs
’good’ award*
Exercise button to jump
to training screen
Number of times the
exercise has been
completed.
Links to the outline of
training software

Your score

The number of the stars indicates the
difficulty level.

* If you have registered as a user, the award

is displayed on the exercise buttons that

have been completed.

From which
exercise shall we
begin today?
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Configuration of Training Screen
When you select an exercise, the Ladder Program Area, Virtual Manufacturing Cell, and the
Operation Panel are displayed as shown below.

2.5.1

Training Screen
Menu Bar

Guidance Window
(☞ 2.5.5)

Minimizes the
screen.

Fixes the screen
display size.
Ends the
training
session

Remote
Control
(☞ 2.5.3)

3-D Graphic
Simulation
Virtual
Manufacturing
cell window
(☞ 2.5.2)

Ladder Program Area
I/O Image Table for
(☞ 2.5.4 and Ladder Tool Section) monitoring RUN status
in the virtual PLC
(☞ 2.5.6)

Operation Panel
(☞ 2.5.7)

Different machines and operation panels for
simulation will be displayed automatically
depending on the exercise. Let's try to operate
them correctly following the guidance.
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3-D Virtual Manufacturing Cell
A different machine is displayed for each exercise to be simulated.
• You can choose the view the machine by pressing the [F] / [T] / [S] button on the remote
control or selecting the direction on the "Tools" menu.
Side view

Front view

Top view

• The device numbers are assigned to all the inputs and outputs of the machine as seen in
the 3-D graphic simulation.
The I/O list can be displayed selecting "Edit" → "I/O list" on the simulation menu. The lists
are also found on the pages in the ’EXERCISES’ section in this manual.
Example of I/O list display
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Remote Control
Switches the mode in the virtual PLC from RUN to STOP.
Remote control
Tutor box
Displays or hide the guidance window.
[Edit Ladder]
Allows to create and modify programs in the ladder program
area.
Switches the mode in the virtual PLC from RUN to STOP.
[Write to PLC]
Transfers the program you create in the ladder program area to
the virtual PLC.
[Reset]
Returns the simulated machine to the initial condition.
- Resets the simulation in case of unwanted occurrence (such
as parts are stuck) takes place.
- Initializes the virtual PLC.
Initializes outputs or devices.
(The same operation as an actual PLC is switched from STOP
to RUN mode.)
[F] / [T] / [S]
Changes over the view point of the 3D screen.
Learning status display
Indicates the status such as “LEARN”, “PROGRAM” and “RUN”.
[Main]
Displays the main menu, or saves the program being edited and
then displays the main menu.
Jump buttons
Clicked to go to the next/previous page in the guidance.
(Use these buttons when indicated on the page.)
Title bar
Click the tutor on the remote control to alternately hide and
display the guidance window.
Or select “Tool” → “Fix remote control bar” and delete the check
mark to display the title bar at the top of the remote control. By
dragging the title bar using the mouse, you can move the
guidance window to an arbitrary position.
• The remote control can be displayed or hidden selecting “Tools” → “Remote Control“.

2.5.4

Ladder Program Area
Use this area to edit, create, monitor, save and print programs.
The details are explained in the ’LADDER PROGRAMS’ Section in this manual.
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Guidance Window
The guidance window displays the programming objectives, lessons, hints, and instructions for
the training software. (The display position is determined by the display position of the remote
control.)
• Outline of guidance
Example of guidance display
You can move it to an arbitrary position by dragging the title bar using
the mouse.
When it comes near a corner of the training software, it is absorbed.
If the title bar is not displayed on the remote control, select “Tool” →
“Fix remote control bar” from the tool menu, then delete the check
mark.
Chapter tabs
Title bar (2.5.3))
Tutor box
Displays or hide the
guidance window.

Scroll bar

Jump buttons
(Use them when
indicated on the page.)

Example of
hint page

Example of first page
in next chapter
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• Guidance Layout
An example of the setup for the guidance pages in an exercise is shown below.
Chapter 1

Chapter 2

Final chapter
Hint
page

Guidance

1)
Scroll

Hint

2)
Did you get it
right?
No
Yes

Guidance

Hint
page
Back

1)
Hint

2)
Did you get it
right?
No
Yes

Guidance

Hint
page
Back

2) Did you get it right?
Click Yes to proceed to the next chapter.
Click No to return to the top of the chapter.
When Yes is clicked in the final chapter, the 'self-judgment
page' is displayed.

1)
Hint

2)
Did you get it
right?
No
Yes

Confirmation screen
(☞ Refer to 2.8.)

Please try
it again.

Click [ ] on the
remote control to
update your score
after judging.
▲

1) Hint:
If you click [HINT] in the text, you jump to the hint
page, and come back when you click [Back] on the
hint page. They are provided in all the exercises in
Category D, E and F.

Back

Click [Main] on
the remote
control to return
to the main
menu.

Note: This box is not displayed if you
are not registered as a user.
Update main the
Returns to the
score, and returns confirmation
to the main menu. screen.
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I/O Image Table for Virtual PLC
The status of the virtual PLC, the Inputs, and Outputs are monitored here.
Green indicates the RUN status.
Gray indicates the STOP status.

Red indicates the ON status.
Gray indicates the OFF status.

2.5.7

Operation Panel
The configuration of the operation panel for each exercise differs.
I/O device numbers shown correspond to the ones on the specific virtual manufacturing cell.

Lamp display
Lit by outputs from the virtual PLC.

Operation switches
Used to operate the machine in the simulation.

Switches
Hold the ON or OFF status.
Turn ON and OFF with the mouse.
Pushbuttons
Turns the input ON while the button is pressed.
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Writing a Program
When reading the first two categories, ’A: Let’s Learn the FX Series PLC!’ and ’B: Let’s Study
the Basics’, the procedures to write the program are indicated in the guidance.
In higher level lessons, example programs are provided but not the individual keystrokes.

2.6.1

Preparation for Ladder Editing
The following operations are required in order to start ladder editing.
The PLC is in RUN mode immediately after the training screen is displayed. Ladder editing
cannot be performed in RUN mode.
1) Click [Edit Ladder] on the remote
control.
The status display is changed from
"RUN" to "PROGRAM".

PROGRAM

RUN

2) Click the Ladder Program Area or
click [Edit Ladder] on the remote
control to enable operation. The title
bar will turn blue.
Key operations are not enabled when
the title bar and menu bar are grayed
out.

PROGRAM
Operation enabled while the
title bar is displayed in blue
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Reading out the Model Answer
The model answer for each exercise can be read out as follows.
1) Click [Edit Ladder] on the remote control and confirm that [PROGRAM] is indicated.
2) Select “Help” → “Ladder example” → “Example 1 to 5” on the simulation menu bar. Up to
five model answers are provided for each exercise. You cannot select model answers
displayed in gray.

PROGRAM

Cautions
• If you edit a model answer and overwrite it, the contents of the model answer are changed.
• If you wish to edit a model answer file, select “Project” → “Save As” to create another model
answer file with a different name for editing.
• The contents of model answers are offered as examples of the control program.
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Operation Confirmation
After writing the program, transfer it to the virtual PLC.

2.7.1

Program Transfer
* Click [Write to PLC] on the remote control or select "Online" → "Write to PLC" on the ladder
menu to transfer the program to the virtual PLC.
While transfer is performed, the window shown below is displayed.

When transfer is finished, the message ’Write completed. The simulation will start.’ is
displayed.

Press [OK] to start the simulation.

2.7.2

Adjustment of Simulation Speed
If you are using a computer with high performance, the operation speed of the machine
simulation may be too high to realize the desired control.
If the message ’part does not stop in front of a sensor’ or the ’input data is not received
properly’ is received, select "Tools" → "Options" on the ladder menu and reduce the speed.
The adjusted speed is remembered.
* ’High’ on the scale bar means high speed. Try the operation at medium speed.

If you choose the ’Simple graphic mode’, the background in the 3-D graphic simulation is
omitted. However, troubles may occur in some exercises where the background is necessary.
In the ’Simple graphic mode’, the simulation speed is higher. If a problem occurs, cancel the
’Simple graphic mode’ or reduce the speed of the simulation.
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Self-judgement
If you are a registered user, the software will update your score whenever an exercise is
successfully completed.
• In the final chapter of each exercise, a dialog box requests confirmation that the exercise
has been successfully completed. The user can judge whether the exercise has been
completed successfully or not.
In the final chapter

Self-judgement page

Returns to the top
of the chapter.
If you are registered as a
user, click the [!] button on
If you are not registered as
the remote control.
a user, click [Main] on the
remote control to return to
the menu screen.

Return to the self-judgement page.
Adds the score, and returns to the menu menu.
(If you are editing the ladder program, the message ’Do you want to save the ladder
program?’ is displayed as shown on the next page.)
The exercise button should have the ’good’ award and the ’number of times completed’
should be updated.
• The updated score can be confirmed by selecting "File" → "Display High Score" on the
simulation menu.
• Additional points are earned if
complete the exercises repeatedly.

you

• The score can be deleted from the score
board selecting "File" → "Delete user
information" on the simulation menu.

User
name

Updated
score

Class
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Exit
You can exit the training software by clicking [×] in the upper right corner of the screen or
selecting "File" → "Exit" on the simulation menu.
• If you are editing the ladder program, the dialog box below is displayed.

Cancels the operation.

Saves the ladder program Exits the software without
in a specified folder and
saving the ladder program.
exits the software.
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EXERCISES
This section gives details about each exercise, the exercise objectives, and the I/O device
assignments.

Contents
List of Exercises
A: Learn the FX Series PLC!
Difficulty
level

Object to
Control

Chapter

A-1. Introduction to the FX Look at a typical operation sequence
Series PLC
and structure of the training software.

1

Door

1.1

A-2. Application Examples Look at field application examples for
for the FX Series PLC the FX Series PLC.

1



1.2

1

Conveyor

1.3

Difficulty
level

Object to
Control

Chapter

Exercise

A-3. Let's play a Little!

Objective

Let’s play a little and start writing a
program!

B: Let's Study the Basics
Exercise

Objective

B-1. Basic I/O Program

Learn input and output programs.

1

Indicator
lamp

2.1

B-2. Standard Program

Learn a latched output program and
SET/RST program.

1

Indicator
lamp

2.2

B-3. Control Precedence
Program

Learn an interlock program which
controls conflicting operations.

1

Traffic light
with two
signal lamps

2.3

B-4. Reading the Input
Status

Learn how to initiate instructions at the
detection of rising or falling edge of a
pulse.

2

Conveyor

2.4

Objective

Difficulty
level

Object to
Control

Chapter

C-1.Basic Timer Operation Learn the On-delay time function.

1

Door

3.1

C-2.Application Timer
Program - 1

Learn the Off-delay time function and
the one shot timer.

1

Door

3.2

C-3.Application Timer
Program - 2

Learn a "flicker" program executed by
timers.

2

Traffic light
with two
signal lamps

3.3

C-4.Basic Counter
Program

Learn control methods using counters.

2

Conveyor

3.4

C: Easy Does It!
Exercise
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D: Beginner Challenge
Exercise

Objective

D-1.Paging Unit
D-2.Detect Sensor
Light
D-3.Time Control for
Traffic Light
D-4. Part Sorting by
Size (I)
D-5.Conveyor Start/
Stop

Control the paging unit in a restaurant.
Turn the flashing lights turn ON when
an object is detected.
Control a traffic light where the signals are
changed at specified time intervals.
Sort different sized parts using
sensors.
Start and stop the conveyor according
to the predetermined procedure.
Operate the conveyor according to the
D-6.Conveyor Drive
sensor data.

Difficulty
Object to Control Chapter
level
1
Paging unit
4.1
1
1
1

Flashing light
Traffic light with
three signal lamps
Conveyor and
supply robot

4.2
4.3
4.4

2

Conveyor

4.5

2

Conveyor

4.6

E: Intermediate Challenge
Exercise

Objective

E-1. Pushbutton
Signal
E-2. Part Sorting by
Size (II)

Switch the traffic signals in response
to a pushbutton.
Distribute each part to its proper
destination according to its size.
Give the command to a robot to move
E-3. Part Separation
a part to a new location.
E-4. Drilling

Control the drill and other devices.

E-5. Part Supply
Control
E-6. Conveyor
Control

Supply a specified number of parts
according to the control specifications.
Move the conveyor forward or backward
according to the control specifications.

Difficulty
Object to Control Chapter
level
Traffic light with
2
5.1
three signal lamps
2
2
2
3
3

Branch conveyor
Conveyor and
unloading robot
Conveyor, supply
robot, and drill
Conveyor and
supply robot
Conveyor and
supply robot

5.2
5.3
5.4
5.5
5.6

F: Advanced Challenge
Exercise

Objective

F-1. Automatic Door Control the door which opens or
Operation
closes when detecting an object.
Control stage settings according to the
F-2. Stage Settings
control specifications.
Distribute the specified number of
F-3. Part Distribution
parts according to the size.
F-4. Sorting
Distinguish between defective parts
Defective Parts and good parts by their signals.
F-5. Forward/Reverse Move the conveyor forward or backward
Rotation Control according to the detected size.
Carry parts to three positions using
F-6. Lifter Control
the lift.
F-7. Sorting &
Sort each part to the specified place
Distribution Line according to the size.

Difficulty
Object To Control Chapter
level
3

Door

6.1

3

Stage settings

6.2

3
3
3
3
4

Conveyor and
pusher
Conveyor supply
robot and drill
Conveyor supply
robot and drill
Lifter and
conveyor
Conveyor supply
robot and
unloading robot

6.3
6.4
6.5
6.6
6.7

* The number for the difficulty level corresponds to the number of stars displayed on the
exercise button on the main menu.
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A: Let’s Learn the FX Series PLC!
A-1. Introduction to the FX Series PLC

A-3. Let’s play a Little!

A-2. Application Examples for the FX Series PLC





B-3

FX-TRN-BEG-E

1.1

A: Let’s Learn the FX Series PLC! 1

Introduction to the FX Series PLC
Category

A: Let’s Learn the FX Series PLC!

Exercise

A-1. Introduction to the FX Series PLC

Objective

Study the introductory information.

Difficulty Level

1 (★)

Score (Class)

80 (Basic programming)

1.1.1

Training Screen

1.1.2

Outline of Operation
Click ["] or [!] to return to the previous screen or to go to the next screen.
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A: Let’s Learn the FX Series PLC! 1

Points of Learning and Control Specifications
1) What is sequence control?
"Sequence control"
This is not a familiar term generally but sequence control happens around us every day. You
probably have seen or touched objects under sequence control.
In a dictionary*, the word "sequence" is explained as follows:
a)succession
b)connected line of events, ideas, etc.
c)the order in which they occur
d)three or more next to each other in value
* Oxford Advanced Learner’s Dictionary of Current English" (Oxford University Press)
Based on the above, we can see that the word "sequence" indicates "succession" and "the
order in which they occur".
The meaning of the term "sequence control" is derived from the word "sequence", and
indicates the control of operations in accordance with the predetermined order. The word
"control" indicates "means by which a machine, etc. is operated or regulated".
Let’s take a look at a familiar example and see how the PLC is used.
In the picture below, a door is opened and closed.
The person follows the necessary procedure and manipulates the door to allow a car to
pass through.
Opening and closing of the door (manual)

Operation sequence
The car approaches
the door.
The person opens
the door.
The car passes
through the opening.
The person closes
the door.
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2) Function of the PLC
On the previous page, the person opens and closes the door manually.
The door can be automatically opened and closed using the PLC.
The screen below shows the concept of the sequence, "predetermined order of work".
Sequence control indicates "let the sequence repeat automatically and correctly as many
times as desired".
By using the PLC, the door can be automatically opened and closed.
Control of automatic opening / closing of the door using the PLC

Operation

Control

The car approaching
the door is detected.

The In gate sensor
turns ON.

The loading bay door
is opened.

The door motor is
driven.

Passage of the car is
confirmed.

The Out sensor turns
ON.

The loading bay door
is closed.

The door motor is
driven in reverse.
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3) Control targets and control specifications
In the previous automatic door example, control targets are "sensors detecting the
approaching vehicle" and "motors to open and close the door".
The PLC can control a variety of equipment.
Relationship between inputs and outputs
Parts of control related equipment are mainly classified into two types as shown in the
screen below.
- Devices controlled by the operator →
Such as switches and push buttons
- Devices which indicate the machine
status → Such as sensors
- Devices which detect the machine
status → Such as lamps and buzzers
- Devices perform work → Such as
motors and solenoid valves

In PLC control, they are regarded as the
’conditions’ for operation, and called ’inputs’
in the PLC.

In PLC control, they are regarded as what
are ’operated’, and called ’outputs’ in the
PLC.

Each of the "input" and "output" equipment is individually connected to the PLC. The
operation of each piece of equipment is determined by the sequence program in the PLC.
Control target classification
Example of inputs and outputs in the PLC (in the unit of part)

Example of inputs and outputs in the PLC (in the unit of machine)
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4) Configuration of the training software
In this training software, machine parts such as sensors or conveyor motors in the 3-D
graphic simulation are already wired to the virtual PLC.
Write a program confirming the control specifications indicated in the guidance with
pre-assigned input (X) and output (Y) device numbers.
The machines in the 3-D graphic simulation will operate according to downloaded program.

Various exercises are prepared in the software.
Try to solve them all.

PLC and peripheral I/O equipment

Learning screen
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Application Examples for the FX Series PLC
Category

A: Let’s Learn the FX Series PLC!

Exercise

A-2. Application Examples for the FX Series PLC

Objective

Look at the introductory lessons.

Difficulty Level

1 (★)

Score (Class)

80 (Basic programming)

1.2.1

Training Screen

1.2.2

Outline of Operation
Click ["] or [!] to return to the previous screen or to go to the next screen.

1.2.3

Points of learning and control specifications
The PLC is used for various purposes in various fields.
Let’s look at various applications on the screen. You should have seen the equipment operated
by the PLC.
After confirming the application examples, try to find various places in which use of the PLC is
expected.
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Let’s play a Little!
Category

A: Let’s Learn the FX Series PLC!

Exercise

A-3. Let’s play a Little!

Objective

Look at the introductory lessons.

Difficulty Level

1 (★)

Score (Class)

80 (Introductory/Basic)

1.3.1

Training Screen

1.3.2

Device Assignment
Type
Input

Output

Device No.

Device name

Operation

X0

Sensor

ON when part is detected. Conveyor is stopped.

Y0

Supply command

One part is supplied when Y0 is ON. A process cycle
begins.

Y1

Conveyor forward

Conveyor moves forward when Y1 is ON.

Y2

Pusher

Extends when Y2 is ON and retracts when Y2 is OFF.
The pusher cannot be stopped in mid stroke.
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Points of Training and Control Specifications.
1) As a first step
Let’s follow the guidance and see how the PLC works.
- Confirm that the operations change according to the programs.
* The machines and the PLC on the screen are virtually simulated and are never
damaged. Don’t hesitate to use them!
- If you would like to learn the details of the key operations for the ladder programming,
refer to ‘LADDER PROGRAMS’ in this manual.
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B: Let’s Study the Basics
B-1. Basic I/O Program

B-2. Standard Program

B-3. Control Precedence Program

B-4. Reading the Input Status
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Basic I/O Program
Category

B: Let’s Study the Basics

Exercise

B-1. Basic I/O Program

Objective

Learn input and output programs.

Difficulty Level

1 (★)

Score (Class)

80 (Basic programming)

2.1.1

Training Screen

2.1.2

Device Assignment
Type
Output

Device No.

Device name

Operation

Y0

Operating lamp

Green lamp is lit when Y0 is ON.

Y1

Stop lamp

Yellow lamp is lit when Y1 is ON.

Y2

Error lamp

Red lamp is lit when Y2 is ON.
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Points of Training and Control Specifications
1) Inputs, outputs and other devices
The PLC is equipped with input points and output points which are connected to control
equipment and a variety of devices the aid in sequencing operations.
- What are devices?
Control equipment such as switches and lamps are connected to the PLC and symbols
such as X, Y, M, T and C are asssigned as their names. Each symbol represents a
different function and has a serial number to identify it.
Symbols and numbers handled inside the PLC are device symbols and device numbers,
most times these are generally called devices.
Input: From X000
Inputs are terminals to receive signals from external equipment (such as switches and
sensors) and their device symbol is represented by “X”.
Numbers are assigned starting from ’000’.
Output: From Y000
Outputs are terminals to drive external equipment (such as lamps and motors) and their
device symbol is represented by “Y”.
Numbers are assigned starting from ’000’.
Auxiliary relay: From M0
Auxiliary relays (which are also called internal relays) are provided inside the PLC and their
device symbol is represented by “M”.
Auxiliary relays are convenient when using dual OUT instructions and two or more contacts
at a time. (Refer to the explanation in Section 3).
Timer: From T0
Timers are provided inside the PLC and their device symbol is represented by “T”. Timers
are used provide a set period of delay time before their nominated contacts are either
opened or closed depending upon the program instructions.
Timers will be studied in the exercises in the category ‘C: Step-up’.
Counter: From C0
Counters are provided inside the PLC and their device symbol is represented by “C”.
Counters are used to increment or decrement in steps of one to a preset value and
subsequently open or close their nominated contacts depending on the program
instructions.
Counters will be studied in the exercises in the category ‘C: Step-up’.
- Device number and number of devices
Inputs (X) and outputs (Y) are expressed in octal - X000 to X007, X010 to X017 (and so
on), Y000 to Y007, Y010 to Y017 (and so on).
Auxiliary relays (M), timers (T) and couners (C) are expressed in decimal - M0 to M10,
M11, M12 (and so on).
The number of devices available varies depending on the PLC. For the number of
available devices in the virtual PLC, refer to the appendix.
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2) Contact instruction and OUT instruction
As you studied in ’A: Let’s Learn the FX Series PLC!’, the input/output equipment is
individually connected to the PLC.
The operation of individual control equipment is determined by the internal wiring within the
PLC. This internal wiring work is called programming.
In this software, connection (programming) can be easily performed using instruction
symbols.
Contact symbols
NO
contact

Is normally open (OFF), and is closed (turned ON) when a signal is
received from the input equipment.

NC
contact

Is normally closed (ON), and is opened (turned OFF) when a signal
is received from the input equipment.

OUT instruction symbol
Is driven (turned ON) when signals for all the contacts connected to the
OUT instructions are received (turned ON).

Example of program (See Chapter 1 in the guidance.)
X020
Y000

Green lamp

Y001

Yellow lamp

Y002

Red lamp

X020
X021

X024

X022

Bus: The left vertical line is used as the base for in writing a program.

Reference: Instruction word
Inside the PLC, contact symbols and Out instruction symbols are handled in "instruction words".
LD

AND

AND
OUT

OR
OR
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3) How to write dual coils and auxiliary relays
’Writing dual coils’ means to construct a program with two or more control steps for the
same output.
If you wish to control an identical output with multiple input conditions, try to combine the
input conditions as in the program below.
Example of dual coil
X000

* The output Y000 is controlled with both inputs
X000 and X002.

Y000
X002
Y000

Example in which auxiliary relays are used
X000

or

X000

Y000
X002

M0
X002
M1
M0
Y000
M1

Tips for using auxiliary relays
Auxiliary relays are convenient when avoiding dual coils as shown or when writing
similar input conditions as shown below.
Example in which auxiliary relay is not used
X000 X001 X002 X003

Example in which auxiliary relays are used
X000 X001 X002

Y000
X000 X001 X002 X004

M0
M0 X003

Y001
X000 X001 X002 X005

Y000
M0 X004

Y002
Same set of contacts are used.

Y001
M0 X005
Y002

The same OUT instruction should not be
operated by multiple input contacts, but the
identical input contact can be used many times
for different OUT instructions.

Instruction words
LD (load)
LDI (load inverse)
AND (and)
ANI (and inverse)
OR (or)
ORI (or inverse)
OUT (out)
* For the method
Appendix 1.

The program is simplified.

: NO contact starting from a bus
: NC contact starting from a bus
: NO contact connected in serial to a contact LD (or LDI)
: NC contact connected in serial to a contact LD (or LDI)
: NO contact connected in parallel to a contact LD (or LDI)
: NC contact connected in parallel to a contact LD (or LDI)
: Coil drive instruction
to enter instruction words, refer to the ’LADDER PROGRAMS’ section or to
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Standard Program
Category

B: Let’s Study the Basics

Exercise

B-2. Standard Program

Objective

Learn a latched output program and SET/RST program.

Difficulty Level

1 (★)

Score (Class)

80 (Basic programming)

2.2.1

Training Screen

2.2.2

Device Assignment
Type
Output

Device No.

Device name

Operation

Y0

Operating lamp

Green lamp is lit when Y0 is ON.

Y1

Stop lamp

Yellow lamp is lit when Y1 is ON.

Y2

Error lamp

Red lamp is lit when Y2 is ON.
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Points of training and control specifications
1) Latched output instruction
The latched output instruction is frequently used in PLC programming. The Output contact
latches On when first energized by an Input(s), remaining On until forced Off by another
programming condition.
Example of latched output instruction
X020 (input condition)

• Write the contact of OUT instruction Y000
in parallel to the input condition X020.

Y000
Y000

Operation
X020
Y000
1
2

Y000

• When X020 is set ON, Y000 is driven
(turned ON) as indicated with the dotted
line 1.
• Even if X020 is set OFF the ON status of
the output Y000 is held as indicated with
the dotted line 2.

Example to shut down the latched output instruction
X020

X024
Y000

Y000
Attention!

• Enter another input condition X24 so that
the route 1 and 2 are shut down and the
latched output status is not operated.
* X024 is an NC contact and normally ON.
When an input signal is given, X024 is
set OFF, and the operation is stopped.

ON
X020 OFF
Y000
X024

2) Holding an output status using other methods
Another instructions provided in the PLC can be used to easily hold the output status.
Example of SET (Set) / RST (Reset) instructions
X020
SET

Y000

RST

Y000

X024

• When X020 is set ON, the output Y000
turns ON.
Even if the X020 is set OFF, the output
status of Y000 remains On.
• When X024 is set ON, Y000 is Reset
(turned Off).

The operation of this program is the same as the operation described above where the
latched output instruction is shut down by another input condition.
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Control Precedence Program
Category

B: Let’s Study the Basics

Exercise

B-3. Control Precedence Program

Objective

Learn a latched output program and SET/RST program.

Difficulty Level

1 (★)

Score (Class)

80 (Basic programming)

2.3.1

Training Screen

2.3.2

Device Assignment
Type
Output

Device No.

Device name

Operation

Y0

Red signal

Lit when Y0 is ON.

Y1

Green signal

Lit when Y1 is ON.

B-20

FX-TRN-BEG-E

2.3.3

B: Let’s Study the Basics 2

Points of training and control specifications
1) Interlock program (in which precedence is given to the first input)
The interlock program is used to give precedence to an input operated first to avoid any
unwanted interruption by another operation.
The principle is often used to control the forward/reverse rotation command of motors or the
ON/OFF status of a solenoid valve with possible safety hazards.
Example
X024 Y001
Y000
X025 Y000
Y001
Interlock program

• Enter Y001 as the NC contact for OUT
instruction Y000.
Enter Y000 as the NC contact for OUT
instruction Y001.
• The example demonstrates an interlock
operation whereby Y0 and Y1 can never
be set ON simultaneously.

X024
*C

Y000
X025
*B
Y001

*A

*A: As Y000 is set ON by X024, Y001 does not turn ON even if X025 turns ON.
*B: When X024 turns OFF, Y000 is turned OFF. Subsequently, Y001 turns ON.
*C: As Y001 is set ON by X025, Y000 is not turned ON even if X024 turns ON.

2) Interlock program (in which precedence is given to the last input)
In the interlock program in example 1) outlines a precedence to the first input. However, the
precedence can similarly be given to the input condition that has most recently come true.
Example
X020

X021
Y000

Y000
X021

X020
Y001

Y001

Interlock program

• The precedence is given to either X020 or
X021 which is input last, and the Y000 or
the Y001 turns ON accordingly.
Please note that if either
input X20 or X21 is to be
kept ON, precedence is
given to the first input.
If you want to give the last
input precedence in this
case, use the rising/falling
edge detection instruction
explained in the next
exercise.
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Reading the Input Status
Category

B: Let’s Study the Basics

Exercise

B-4. Reading the Input Status

Objective

Learn how to initiate instructions at the detection of rising or falling edge of a
pulse.

Difficulty Level

2 (★★)

Score (Class)

110 (Basic programming)

2.4.1

Training Screen

2.4.2

Device Assignment
Type
Input

Output

Device No.

Device name

Operation

X0

Starting point

ON when robot is at starting point.

X3

Sensor

ON when part is detected.

Y0

Supply command

One part is supplied when Y0 is ON. A process cycle
begins.

Y1

Conveyor forward

Conveyor moves forward when Y1 is ON.

Y2

Conveyor reverse

Conveyor moves backward when Y2 is ON.

Y3

Buzzer

Sounds when Y3 is ON (Lamp on screen is lit).

Y5

Red

Lit when Y5 is ON.

Y6

Green

Lit when Y6 is ON.

Y7

Yellow

Lit when Y7 is ON.
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Points of training and control specifications
1) Input rising / falling edge detection instruction
Let’s learn programs which operate only when an input is set to ON or OFF.
The rising / falling edge detection instruction captures the alternate status of ON to OFF and
OFF to ON.
It is used for control where the input signal should not be kept either ON or OFF.
Example
X024
PLS
M0

M0

X021
Y001

Y001
Y006
X020
PLF
M1

M1

X021
Y000

Y000

• X024 is an alternate switch which is
a lway s e i t h e r O N o r O F F. H ow eve r,
because the PLS instruction is used here,
the OUT instruction M0 is operated only on
the rising edge of input X024 for a single
scan cycle.
• X020 is a momentary pushbutton switch
which turns ON when pressed. However,
because the PLF instruction is used here,
the OUT instruction M1 is operated on the
falling edge of input X020 for a single scan
cycle.

* Even if inputs X024 or X020 are set ON or OFF by the PLS or PLF instruction, the latched
output instruction program for Y000, Y001 and Y006 can be shut down by the input of
X021.

2) Contact type rising/falling edge detection instruction
There is another type of rising/falling edge detection instruction which turns a contact only
for a moment.
Example
X024

X021
Y001

Y000
Y006
X020

X021

• The program shown on the left performs
the same operation with the program
shown above in which the PLS and PLF
instructions are used for rising/falling edge
detection.

Y000
Y001

rising edge
detection

falling edge
detection
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C-1. Base of timer circuit

C-2. Application of timer circuit 1

C-3. Application of timer circuit 2

C-4. Base of counter circuit
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Basic Timer Operation
Category

C: Step Up

Exercise

C-1. Basic Timer Operation

Objective

Learn the On-delay time function.

Difficulty Level

1 (★)

Score (Class)

80 (Basic programming)

3.1.1

Training Screen

3.1.2

Device Assignment
Type
Input

Output

Device No.

Device name

Operation

X0

Lower limit

ON when door reaches lower limit.

X1

Upper limit

ON when door reaches upper limit.

Y0

Door up command

Door moves up when Y0 is ON.

Y1

Door down command Door moves down when Y1 is ON.

Y5

Red

Lit when Y5 is ON.

Y6

Green

Lit when Y6 is ON.

Y7

Yellow

Lit when Y7 is ON.
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Points of training and control specifications
1) Basic operation of the timer
The timer in the PLC is expressed with the timer device number and the set value.
K30
T0
15

X020
Timer
contact

Set value

T0

Set value
Current value

Y000

: Expressed in decimal. K is added in front of the value.

Present value : Increases from 0 until it reaches the set value. (See the value by clicking
"Online" → "Monitor” in the ladder menu.)
X020

ON
OFF
*B 30

30 *D

15 *A
T0
Current
value

0

0

0

0

T0
contact

ON *C
OFF

Y0

ON
OFF

• The output driven by the time contact is kept On for a set period of time after the input is
turned ON.
(This is an ON-delay timer.)
If the timer operation is shut down before it reaches the set value, the current value
resets to 0 (See *A above).
• When the timer reaches the set value (*B), the current value becomes constant and the
timer contact turns ON (*C).
• When the input to operate the timer is turned OFF, the timer contact is also OFF and the
current value is cleared (*D).
• How to determine the set value depends on the device number. (Refer to the Appendix.)
For example, T0 is the time with the base time 100ms (0.1 sec). If the set value is ’K30’,
the operation starts after 3 seconds because 100ms x 30 = 3000ms = 3 sec.
2) Opening and closing of the door using timers
X020

K30
T0

T0
Y000
X021

K40
T1

T1

• When X020 is set ON, the timer T0 is
operated. Three seconds later, Y000 turns
ON (the door is opened).
• When X021 is set ON, the timer T1 is
operated. Four seconds later, Y001 turns
ON (the door is closed).

Y001
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Application Timer Program - 1
Category

C: Step Up

Exercise

C-2. Application Timer Program - 1

Objective

Learn the Off-delay time function and the one shot timer.

Difficulty Level

1 (★)

Score (Class)

80 (Basic programming)

3.2.1

Training Screen

3.2.2

Device Assignment
Type
Input

Output

Device No.

Device name

Operation

X0

Lower limit

ON when door reaches lower limit.

X1

Upper limit

ON when door reaches upper limit.

Y0

Door up command

Door moves up when Y0 is ON.

Y1

Door down command Door moves down when Y1 is ON.

Y5

Red

Lit when Y5 is ON.

Y6

Green

Lit when Y6 is ON.

Y7

Yellow

Lit when Y7 is ON.
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Points of training and control specifications
1) Off-delay timer
The timer turns the output OFF after a set period of time.
X020

T1 C

Y005
A
B
X020

Y005

K30
T1
B

• When X020 is set ON, Y005 turns ON as
indicated in line A.
• When X020 is set OFF, Y005 is latched
and timer T1 turns ON as indicated in line
B.
• After the set value of timer T1 elapses
(K30 = 3 sec), C turns OFF, and the OUT
instruction Y005 and T1 are turned OFF.

X020

Y005
Set value of T1 (3 sec)
Off-delay time

2) One-shot timer
The timer keeps the output ON for a set period of time.
(Even if the input for operating the timer remains ON, the output is turned OFF after a set
period of time.)
X021

T2 C

Y006
A
B

Y006

K50
T2
A
B

X021

• When X021 is set ON, Y006 and T2 turn
ON as indicated in line A. X021 is turned
ON instantaneously by the rising edge
detection instruction. Even if the input of
X021 is kept ON, the contact turns OFF.
• The latched output instruction enables
Y006 and T2 to remain ON as indicated in
line B.
• After the set time of the timer T2 elapses
(K50 = 5 sec), C turns OFF and then the
OUT instruction Y006 and T2 are turned
OFF.

Y006
Set value of T2 (5 sec)

3) Lighting the lamps using timers
X020

T1
Y005

Y005
X021

X020

K30
T1

T2
Y006

Y006

K50
T2

• When the switch (X020) is set ON, the
"red" lamp (Y005) is lit. Three seconds
(T1) after the switch (X020) is set, the
"red" lamp is extinguished.
• When the switch (X021) is set ON, the
"green" lamp (Y006) is lit. Even if the
switch (X021) remains ON, the "green"
lamp is extinguished five seconds (T2)
later.
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Application Timer Program - 2
Category

C: Step Up

Exercise

C-3. Application Timer Program - 2

Objective

Learn a "flicker" program executed by timers.

Difficulty Level

2 (★★)

Score (Class)

110 (Basic programming)

3.3.1

Training Screen

3.3.2

Device Assignment
Type
Output

Device No.

Device name

Operation

Y0

Red signal

Lit when Y0 is ON.

Y1

Green signal

Lit when Y1 is ON.
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Points of training and control specifications
1) Flicker circuit
Two timers drive the output ON and OFF at set intervals.
X024

K20
T3

T4 D

A
K40
T4

T3 B

C

• When X024 is set ON, the OUT instruction
of T3 turns ON as indicated in line A.
• Two seconds later (the set value of K20 in
T3), T3 indicated by B turns ON. Y001 and
T4 turn ON as indicated in line C.

Y001
C

• Four seconds later (set value of K40 in
T4), the contact D turns OFF and thus T3
turns OFF as indicated in line A.
• While X024 is ON, Y001 repeats an OFF
for 2 seconds and ON for 4 seconds cycle.

X024

ON
OFF

Y001

ON
OFF
T3
2 sec

T4
4 sec

T3
2 sec

T4
4 sec

T3
2 sec

When X024 is set OFF, the
output turns OFF.

2) Flickering the signal lamps
In the program above, Y001 flickers OFF for 2 seconds and ON for 4 seconds while the
switch X024 is ON.

B-31

FX-TRN-BEG-E

3.4

C: Easy Does It! 3

Basic Counter Program
Category

C: Step Up

Exercise

C-4. Basic Counter Program

Objective

Learn control methods using counters.

Difficulty Level

2 (★★)

Score (Class)

110 (Basic programming)

3.4.1

Training Screen

3.4.2

Device Assignment
Type

Device No.

Input

X0

Sensor

ON when part is detected at the right end.

Y0

Supply command

Indicator on screen is lit when Y0 is ON. Operator
supplies parts while indicator is lit.

Y1

Conveyor forward

Conveyor moves forward when Y1 is ON.

Y3

Red

Lit when Y3 is ON.

Y4

Green

Lit when Y4 is ON.

Y5

Yellow

Lit when Y5 is ON.

Output

Device name

Operation
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Points of training and control specifications
1) Basic operation of the counter
The counter in the PLC is expressed with the device number and the set value.
Set value

K5
C0
2

Count input

Current value

Reset input
RST

C0
Counter reset instruction

C0
Y003

Counter contact

Set value

: Expressed in decimal. K precedes the value.

Present value : Increments from 0 until it reaches the set value. (To monitor select "Online"
→ "Monitor” in the ladder menu.)
Reset

: Returns the current value of the counter to 0, and sets OFF the contact of
the counter (RST instruction).

Count input ON
OFF

*C

*A

*E

5
4
3

C0
Current value

2

2

1

*D
0

0
C0 contact
(Y003)
Reset input

ON
OFF

*F

1
0

*B
ON
OFF

• For each count input received (*A), the current value of the counter is incremented by 1.
When the current value reaches the set value, the contact of the counter turns ON (*B).
• After the counter reaches the set value, the current value is not changed even if the
count input (*C) is set ON and OFF, and the counter contact remains ON (*B).
• When the counter reset instruction (RST) is set ON, the current value of the counter
becomes 0 (*D) and the contact turns OFF. While the RST instruction is ON, any count
input is not counted (*E).
• When the RST instruction is set OFF, count inputs are counted. However, if the RST
instruction is set ON before the current value of the counter reaches the set value, the
current value is reset to 0 and thus the counter contact does not turn ON (*F).
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2) Counting the number of parts
Control specifications
a) When the part supply command (X002) is set ON, the part supply output (Y000) is
initiated.
b) The conveyor operation command (X003) initiates the conveyer forward output (Y001).
c) The number of parts is counted (counter C0) by the detection sensor (X000).
d) When the number of parts reaches 10, the count-up indicator lamp (Y006) is lit.
e) The counter is reset by input (X001).
X002
Y000

a)

Y001

b)

K10
C0

c)

Y006

d)

C0

e)

X003
X000
C0
X001
RST

Minor Addition
Let’s stop the supply of parts when the current value of the counter reaches the set value
(K10).
X002

C0
Y000

• Include a NC contact for the counter to line
a) above.

Add this.

Let’s supply parts only while the conveyor is moving.
X002

C0

Y001
Y000

• Include a NC contact for the conveyor
operation (Y001) to line a) above.

Add this.

As you can see, the operation is changed when
only a minor addition is made in the program. In
actual machines, programs for assuring safety are
added to the basic control specifications.
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4.

D: Beginner Challenge
D-1. Paging Unit

D-2. Detect Sensor Light

D-3. Time Control for Traffic Light

D-4. Part Sorting by Size (I)

D-5. Conveyor Start/Stop

D-6. Conveyor Drive
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D: Beginner Challenge 4

Paging Unit
Category

D: Beginner Challenge

Exercise

D-1. Paging Unit

Objective

Control the paging unit in a restaurant.

Difficulty Level

1 (★)

Score (Class)

130 (Beginner programming)

4.1.1

Training Screen

4.1.2

Device Assignment
Type
Input
Output

Device No.

Device name

Operation

X0

Button 1

Momentary ON/OFF (mouse click).

X1

Button 2

Momentary ON/OFF (mouse click).

Y0

Lamp 1

Lit when Y0 is ON.

Y1

Lamp 2

Lit when Y1 is ON.
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D: Beginner Challenge 4

Control Objective
Control the paging unit in a restaurant using the basic instructions previously studied.

4.1.4

Control Specifications
1) When Button 1 (X0) on the table is pressed, Lamp 1 (Y0) on the wall is lit.
If Button 1 (X0) is released, Lamp 1 (Y0) remains lit.
2) When Button 2 (X1) is pressed, Lamp 2 (Y1) on the wall is lit.
If Button 2 (X1) is released, Lamp 2 (Y1) remains lit.
3) When both Lamp 1 (Y0) and Lamp 2 (Y1) are lit, [PL4] (Y23) on the operation panel lights.
4) When [PB1] (X20) on the operation panel is pressed, both Lamp 1 (Y0) and Lamp 2 (Y1)
on the wall and [PL4] (Y23) on the operation panel are extinguished.
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D: Beginner Challenge 4

Detect Sensor Light
Category

D: Beginner Challenge

Exercise

D-2. Detect Sensor Light

Objective

Turn the flashing lights ON when an object is detected.

Difficulty Level

2 (★★)

Score (Class)

160 (Beginner programming)

4.2.1

Training Screen

4.2.2

Device Assignment
Type

Input

Output

Device No.

Device name

Operation

X0

In gate (person)

ON when person is detected.

X1

Out (person)

ON when person is detected.

X2

In gate (car)

ON when car is detected.

X3

Out (car)

ON when car is detected.

Y0

Red (person)

Lit when Y0 is ON.

Y1

Green (person)

Lit when Y1 is ON.

Y2

Yellow (person)

Lit when Y2 is ON.

Y3

Red (car)

Lit when Y3 is ON.

Y4

Green (car)

Lit when Y4 is ON.

Y5

Yellow (car)

Lit when Y5 is ON.

Y7

Buzzer

Sounds when Y7 is ON (Lamp on screen is lit).
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D: Beginner Challenge 4

Control Objective
Have the flashing lights turn ON when a person or car is detected.
Use the basic instructions and timers previously studied.

4.2.4

Control Specifications
Human side
1) When the sensor In gate (X0) detects a person, the flashing light Green (Y1) comes ON.
2) 5 seconds after the sensor Out (X1) detects the passage of the person, the flashing light
Green (Y1) is extinguished.
Car side
1) When the sensor In gate (X2) detects a car, the flashing light Green (Y4) is lit.
2) 5 seconds after the sensor Out (X3) detects the passage of the car, the flashing light Green
(Y4) is extinguished.
3) If the car does not pass through the area between In gate (X2) and Out (X3) within 10
seconds, the flashing light Red (Y3) is lit and Buzzer (Y7) sounds.
4) As soon as the car has passed the sensor Out (X3), the flashing light Red (Y3) is
extinguished and Buzzer (Y7) stops.
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D: Beginner Challenge 4

Time Control for Traffic Light
Category

D: Beginner Challenge

Exercise

D-3. Time Control for Traffic Light

Objective

Control a traffic light where the signals are changed at specified time
intervals.

Difficulty Level

2 (★★)

Score (Class)

160 (Beginner programming)

4.3.1

Training Screen

4.3.2

Device Assignment
Type
Output

Device No.

Device name

Operation

Y0

Red

Lit when Y0 is ON.

Y1

Yellow

Lit when Y1 is ON.

Y2

Green

Lit when Y2 is ON.
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D: Beginner Challenge 4

Control Objective
Control a traffic light where the signals are changed at specified time intervals. Use the basic
instructions and timers previously studied.

4.3.4

Control Specifications
1) When [PB1] (X20) on the operation panel is pressed, the process is started.
2) First, the signal lamp Red (Y0) is lit for 10 seconds.
3) he signal lamp Red (Y0) is extinguished after it has been lit for 10 seconds. The signal lamp
Yellow (Y1) is lit for 5 seconds.
4) The signal lamp Yellow (Y1) is extinguished after it has been lit for 5 seconds. The signal
lamp Green (Y2) is lit for 10 seconds.
5) The signal lamp Green (Y2) is extinguished after it has been lit for 10 seconds.
6) The operations starting from 2) above are repeated.
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D: Beginner Challenge 4

Part Sorting by Size (I)
Category

D: Beginner Challenge

Exercise

D-4. Part Sorting by Size (I)

Objective

Sort different sized parts using sensors.

Difficulty Level

2 (★★)

Score (Class)

160 (Beginner programming)

4.4.1

Training Screen

4.4.2

Device Assignment
Type

Input

Output

Device No.

Device name

Operation

X0

Upper

ON when part is detected.

X1

Middle

ON when part is detected.

X2

Lower

ON when part is detected.

X4

Sensor

ON when part is detected at the right end.

X5

Starting point

ON when robot is at starting point.

Y3

Conveyor forward

Conveyor moves forward when Y3 is ON.

Y5

Supply command

One part is supplied when Y5 is ON. A process cycle
begins.

B-42

FX-TRN-BEG-E

4.4.3

D: Beginner Challenge 4

Control Objective
Sort three different sized parts carried a conveyor.

4.4.4

Control Specifications
1) When [PB1] (X10) on the operation panel is pressed, Supply command (Y5) for the robot
is turned ON.
When [PB1] (X10) is released, Supply command (Y5) is turned OFF.
2) When [Operation start] (X14) on the operation panel is turned ON, Conveyor forward (Y3)
is ON.
When [Operation start] (X14) on the operation panel is turned OFF, Conveyor forward (Y3)
is OFF.
3) Large, medium or small parts carried on the conveyor are sorted by the input of sensors
Upper (X0), Middle (X1) or Lower (X2), then a corresponding lamp is lit.
- Large → Y10
- Medium → Y11
- Small → Y12
4) A lamp is lit immediately after the sensors (X0, X1, X2) sort the size, then is extinguished
when the part has passed Sensor (X4).
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D: Beginner Challenge 4

Conveyor Start/Stop
Category

D: Beginner Challenge

Exercise

D-5. Conveyor Start/Stop

Objective

Start and stop the conveyor according to the predetermined procedure.

Difficulty Level

2 (★★)

Score (Class)

160 (Beginner programming)

4.5.1

Training Screen

4.5.2

Device Assignment
Type
Input

Output

Device No.

Device name

Operation

X0

Starting point

ON when robot is at starting point.

X3

Sensor

ON when part is detected at the right end.

Y0

Supply command

One part is supplied when Y0 is ON. A process cycle
begins.

Y1

Conveyor forward

Conveyor moves forward when Y1 is ON.

Y2

Conveyor reverse

Conveyor moves backward when Y2 is ON.

Y3

Buzzer

Sounds when Y3 is ON (Lamp on screen is lit).

Y5

Red

Lit when Y5 is ON.

Y6

Green

Lit when Y6 is ON.

Y7

Yellow

Lit when Y7 is ON.
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D: Beginner Challenge 4

Control Objective
Start and stop the conveyor according to the predetermined procedure.

4.5.4

Control Specifications
1) When [PB1] (X20) on the operation panel is pressed, the flashing light Yellow (Y7) is lit and
Buzzer (Y3) sounds for 5 seconds.
If [PB1] (X20) is released, Yellow (Y7) remains lit.
2) After the flashing light Yellow (Y7) is extinguished and Buzzer (Y3) stops, Conveyor
forward (Y1) is set ON.
The flashing light Green (Y6) remains lit while the Conveyor forward (Y1) is ON.
3) When [PB2] (X21) on the operation panel is pressed, the operations described in 1) and 2)
stop.
The operations should be repeated when the procedure described in 1) is executed.
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Conveyor Drive
Category

D: Beginner Challenge

Exercise

D-6. Conveyor Drive

Objective

Operate the conveyor according to the sensor data.

Difficulty Level

2 (★★)

Score (Class)

160 (Beginner programming)

4.6.1

Training Screen

4.6.2

Device Assignment
Type

Input

Device No.

Device name

Operation

X0

Sensor

ON when part is detected at the left end.

X1

Sensor

ON when part is detected at the left end.

X2

Sensor

ON when part is detected at the left end.

X3

Sensor

ON when part is detected at the right end.

X5

Starting point

ON when robot is at starting point.
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Output

4.6.3

D: Beginner Challenge 4

Device No.

Device name

Operation

Y0

Upper conveyor
forward

Conveyor moves forward when Y0 is ON.

Y1

Upper conveyor
reverse

Conveyor moves backward when Y1 is ON.

Y2

Middle conveyor
forward

Conveyor moves forward when Y2 is ON.

Y3

Middle conveyor
reverse

Conveyor moves backward when Y3 is ON.

Y4

Lower conveyor
forward

Conveyor moves forward when Y4 is ON.

Y5

Lower conveyor
reverse

Conveyor moves backward when Y5 is ON.

Y7

Supply command

One part is supplied when Y7 is ON. A process cycle
begins.

Control Objective
Operate the conveyor according to the sensor data.

4.6.4

Control Specifications
1) When [PB1] (X20) on the operation panel is pressed, Supply command (Y7) for the robot
is turned ON if the robot is at Starting point (X5).
When [PB1] (X20) is released, Supply command (Y7) is latched on until the robot returns
to the Starting point (X5).
2) When Sensor (X0) detects a part, Upper conveyor forward (Y0) is set ON.
3) When Sensor (X1) detects a part, Middle conveyor forward (Y2) is set ON and Upper
conveyor forward (Y0) stops.
4) When Sensor (X2) detects a part, Lower conveyor forward (Y4) is set ON and Middle
conveyor forward (Y2) stops.
5) When Sensor (X3) detects a part, Lower conveyor forward (Y4) stops.
6) When Sensor (X3) is set ON, Supply command (Y7) for the robot is turned ON and a new
part is supplied if the robot is at Starting point (X5).
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E: Intermediate Challenge
E-1. Pushbutton Signal

E-2. Part Sorting by Size (II)

E-3. Part Separation

E-4. Drilling

E-5. Part Supply Control

E-6. Conveyor Control
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E: Intermediate Challenge 5

Pushbutton Signal
Category

E: Intermediate Challenge

Exercise

E-1. Pushbutton Signal

Objective

Switch the traffic light signals in response to a pushbutton.

Difficulty Level

2 (★★)

Score (Class)

210 (Intermediate programming)

5.1.1

Training Screen

5.1.2

Device Assignment
Type
Output

Device No.

Device name

Operation

Y0

Red

Lit when Y0 is ON.

Y1

Yellow

Lit when Y1 is ON.

Y2

Green

Lit when Y2 is ON.
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E: Intermediate Challenge 5

Control Objective
Switch the traffic light signals in response to a pushbutton.

5.1.4

Control Specifications
1) The signal lamp Red (Y0) flickers at one-second intervals (ON for 1 second and OFF for 1
second).
2) When the pushbutton (X10) on the operation panel is pressed, the indicator (Y10) on the
operation panel is lit.
If the pushbutton (X10) is released, the indicator (Y10) remains lit.
3) After the indicator (Y10) is lit for 5 seconds, the operation of the signal is changed as
described in 4) to 7).
4) First, the signal lamp Red (Y0) flickers for 5 seconds while indicator (Y10) is lit.
5) The signal lamp Red (Y0) turns off. The signal lamp Yellow (Y1) is lit for 5 seconds.
6) After the lamp Yellow (Y1) is extinguished, signal lamp Green (Y2) is lit for 10 seconds.
7) After the signal lamp Green (Y2) turns OFF, the signal lamp Red (Y0) flickers at one-second
intervals (ON for 1 second and OFF for 1 second). The operations starting from 1) are
repeated.
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Part Sorting by Size (II)
Category

E: Intermediate Challenge

Exercise

E-2. Part Sorting by Size (II)

Objective

Distribute each part to its proper destination according to its size.

Difficulty Level

2 (★★)

Score (Class)

210 (Intermediate programming)

5.2.1

Training Screen

5.2.2

Device Assignment
Type

Input

Output

Device No.

Device name

Operation

X0

Starting point

ON when robot is at starting point.

X1

Upper

ON when part is detected.

X2

Middle

ON when part is detected.

X3

Lower

ON when part is detected.

X4

Sensor

ON when part is detected at the right end.

X5

Sensor

ON when part is detected at the right end.

Y0

Supply command

One part is supplied when Y0 is ON. A process cycle
begins: Metal cylinder repeats in order L, S, S, L and S.

Y1

Conveyor forward

Conveyor moves forward when Y1 is ON.

Y2

Conveyor forward

Conveyor moves forward when Y2 is ON.

Y5

Sorting wing

Moves toward front when Y5 is ON.
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E: Intermediate Challenge 5

Control Objective
Distribute each part to its proper destination according to its size.

5.2.4

Control Specifications
1) When [SW1] (X24) on the operation panel is turned ON, the conveyors move forward.
When [SW1] (X24) is turned OFF, the conveyors stop.
2) When [PB1] (X20) on the operation panel is pressed, Supply command (Y0) for the robot
is turned ON.
Supply command (Y0) is turned OFF when the robot has moved from the starting point.
(The robot will complete the part loading cycle.)
3) The robot supplies large, medium or small parts.
4) Large parts are led to the rear conveyor and small parts are led to the front conveyor.
The part size is detected by the input Upper (X1), Middle (X2) and Lower (X3) on the
conveyor.

B-53

FX-TRN-BEG-E

5.3

E: Intermediate Challenge 5

Part Separation
Category

E: Intermediate Challenge

Exercise

E-3. Part Separation

Objective

Give the command to a robot to move a part to a new location.

Difficulty Level

2 (★★)

Score (Class)

210 (Intermediate programming)

5.3.1

Training Screen

5.3.2

Device Assignment
Type

Input

Output

Device No.

Device name

Operation

X0

Starting point

ON when robot is at starting point.

X1

Part on table

ON when part is on table.

X2

Robot operation
finished

ON when robot operation finished.

Y0

Supply command

Indicator on screen is lit when Y0 is ON. Operator
supplies parts while indicator is lit.

Y1

Conveyor forward

Conveyor moves forward when Y1 is ON.

Y2

Unload command

Robot moves part to tray when Y2 is ON. A process
cycle begins.
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5.3.3

E: Intermediate Challenge 5

Control Objective
Give the command to a robot to move a part to a new location.

5.3.4

Control Specifications
1) The operator supplies parts.
The operator confirms the indicator lamp [Supply allowed] is lit and supplies a part to the
conveyor.
If the indicator lamp is always lit, the operator continuously supplies parts.
2) While the PLC is in RUN status, the conveyor always moves forward.
3) When [PB1] (X20) on the operation panel is pressed, Supply command (Y0) is turned ON
and the [Supply allowed] indicator lamp is lit. The operator supplies a part.
When [PB1] (X20) is released, the indicator lamp is extinguished.
However, if a part is still located on the table, Supply command (Y0) is not turned ON so
that the indicator lamp [Supply allowed] is not lit.
4) When Part on table (X1) is turned ON in the robot, Unload command (Y2) is set ON.
When Robot operation finished (X2) is turned ON (it is ON when a part is placed on the
tray), Unload command (Y2) is set OFF.
Unload command (Y2) should be set ON only when the robot is at the starting point.
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E: Intermediate Challenge 5

Drilling
Category

E: Intermediate Challenge

Exercise

E-4. Drilling

Objective

Control the drill and other devices.

Difficulty Level

2 (★★)

Score (Class)

210 (Intermediate programming)

5.4.1

Training Screen

5.4.2

Device Assignment
Type

Input

Output

Device No.

Device name

Operation

X0

Drilling

ON while drilling.

X1

Part under drill

ON when part is under the drill.

X2

Drilled correctly

ON when part is drilled correctly. Previous result is
cleared when drilling starts.

X3

Drilled wrong

ON when part is not drilled correctly. Previous result is
cleared when drilling starts.

X5

Sensor

ON when part is detected at the right end.

Y0

Supply command

One part is supplied when Y0 is ON. A process cycle
begins: Large metal cube.

Y1

Conveyor forward

Conveyor moves forward when Y1 is ON.

Y2

Start drilling

Starts drilling when Y2 is ON (A process cycle that
cannot be stopped partway).
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E: Intermediate Challenge 5

Control Objective
Drill holes in parts supplied from the hopper.

5.4.4

Control Specifications
Overall control
1) When [PB1] (X20) on the operation panel is pressed, Supply command (Y0) for the hopper
is turned ON.
When [PB1] (X20) is released, Supply command (Y0) is turned OFF.
When Supply command (Y0) is turned ON, the hopper supplies a part.
2) When [SW1] (X24) on the operation panel is turned ON, the conveyor moves forward.
When [SW1] (X24) is turned OFF, the conveyor stops.
Control of drill
1) When the sensor for Part under drill (X1) in the drill is turned ON, the conveyor stops.
2) When Start drilling (Y2) is turned ON, the drilling starts.
Start drilling (Y2) is turned OFF when Drilling (X0) is set ON.
3) When Start drilling (Y2) is turned ON, either Drilled correctly (X2) or Drilled wrong (X3)
is set ON after the drill machine has operated for one complete cycle.
(The drill cannot be stopped in the middle of an operation.)
4) After Drilled correctly (X2) or Drilled wrong (X3) is confirmed, the work is carried and put
on the tray at the right.
When multiple holes are drilled, Drilled wrong (X3) is set ON. In this exercise no specified
control for scrap parts exists.
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E: Intermediate Challenge 5

Part Supply Control
Category

E: Intermediate Challenge

Exercise

E-5. Part Supply Control

Objective

Supply a specified number of parts according to the control specifications.

Difficulty Level

3 (★★★)

Score (Class)

240 (Intermediate programming)

5.5.1

Training Screen

5.5.2

Device Assignment
Type

Input

Output

Device No.

Device name

Operation

X0

Starting point

ON when robot is at starting point.

X1

Box on conveyor

ON when box is under orange feeder.

X2

Orange supplied

ON when orange is detected (for counting).

X5

Sensor

ON when part is detected at the right end.

Y0

Supply command

One part is supplied when Y0 is ON. A process cycle
begins: Large box.

Y1

Conveyor forward

Conveyor moves forward when Y1 is ON.

Y2

Supply orange
command

Oranges are supplied while Y2 is ON.
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5.5.3

E: Intermediate Challenge 5

Control Objective
Place a specified number of oranges into a box located on the conveyor.

5.5.4

Control Specifications
Overall control
1) When [SW1] (X24) on the operation panel is turned ON, the conveyor moves forward.
When [SW1] (X24) is turned OFF, the conveyor stops.
2) When [PB1] (X20) on the operation panel is pressed, Supply command (Y0) for the robot
is turned ON.
Supply command (Y0) is turned OFF when the robot has moved from the starting point.
When Supply command (Y0) is turned ON, the robot supplies a box.
Control of oranges
1) When the sensor for Box on conveyor (X1) in the orange feeder is turned ON, the conveyor
stops.
2) Five oranges are placed in the box.
Boxes containing 5 oranges are carried to the tray at right.
3) Oranges are supplied when Supply orange command (Y2) is set ON and the number of
oranges supplied are counted when Orange supplied (X2) is set ON.
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E: Intermediate Challenge 5

Conveyor Control
Category

E: Intermediate Challenge

Exercise

E-6. Conveyor Control

Objective

Move the conveyor forward or backward according to the control
specifications.

Difficulty Level

3 (★★★)

Score (Class)

240 (Intermediate programming)

5.6.1

Training Screen

5.6.2

Device Assignment
Type
Input

Output

Device No.

Device name

Operation

X10

Left limit

ON when part is detected at the left end.

X11

Right limit

ON when part is detected at the right end.

X12

Stop sensor

ON when part is detected.

Y10

Supply command

One part is supplied when Y10 is ON. A process cycle
begins.

Y11

Conveyor forward

Conveyor moves forward when Y11 is ON.

Y12

Conveyor reverse

Conveyor moves backward when Y12 is ON.
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E: Intermediate Challenge 5

Control Objective
Move the conveyor forward or backward according to the control specifications.

5.6.4

Control Specifications
1) When [PB1] (X20) on the operation panel is pressed, Supply command (Y10) for the
hopper is turned ON.
When [PB1] (X20) is released, Supply command (Y10) is turned OFF.
When Supply command (Y10) is turned ON, the hopper supplies a part.
2) When [PB2] (X21) on the operation panel is pressed, the conveyor is operated in a
sequence as described in 3) to 6) below.
If [PB2] (X21) is released, the sequence of operation continues.
3) The conveyor starts moving when Conveyor forward (Y11) is set ON and stops when
Right limit (X11) for the part is turned ON.
4) The conveyor moves in reverse when Conveyor reverse (Y12) is set ON until Left limit
(X10) is turned ON.
5) The part stays at the left limit for 5 seconds.
6) 5 seconds later, Conveyor forward (Y11) is set ON and the conveyor moves until Stop
sensor (X12) is turned ON.
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6.

F: Advanced Challenge
F-1. Automatic Door Operation

F-2. Stage Settings

F-3. Part Distribution

F-4. Sorting Defective Parts

F-5. Forward/Reverse Rotation Control

F-6. Lifter Control

F-7. Sorting & Distribution Line
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6.1

F: Advanced Challenge 6

Automatic Door Operation
Category

F: Advanced Challenge

Exercise

F-1. Automatic Door Operation

Objective

Control the door which opens or closes when detecting an object.

Difficulty Level

3 (★★★)

Score (Class)

290 (Advanced programming)

6.1.1

Training Screen

6.1.2

Device Assignment
Type

Input

Output

Device No.

Device name

Operation

X0

Lower limit

ON when door reaches lower limit.

X1

Upper limit

ON when door reaches upper limit.

X2

In gate sensor

ON when object approaches the door.

X3

Out sensor

ON when object leaves the door.

Y0

Door up

Moves up when Y0 is ON.

Y1

Door down

Moves down when Y1 is ON.

Y6

Light

Lit when Y6 is ON.

Y7

Buzzer

Sounds when Y7 is ON (Lamp on screen is lit).
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6.1.3

F: Advanced Challenge 6

Control Objective
Control the door which opens or closes when detecting a car.

6.1.4

Control Specifications
1) When the car comes near the opening, the door moves up.
2) When the car passes through the door, the door moves down.
3) The door stops moving up when Upper limit (X1) is turned ON.
4) The door stops moving down when Lower limit (X0) is turned ON.
5) While the car is still in the detection range between In gate sensor (X2) and Out sensor
(X3), the door will not move down.
6) Buzzer (Y7) sounds while the door is in motion.
7) Light (Y6) is lit while the car is in the detection range between In gate sensor (X2) and Out
sensor (X3).
8) Four indicator lamps on the operation panel are lit or extinguished according to the
movement of the door.
9) The door can be opened/closed manually by pressing the buttons [# Door up] (X10) and
[$ Door down] (X11) on the operation panel.
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6.2

F: Advanced Challenge 6

Stage Settings
Category

F: Advanced Challenge

Exercise

F-2. Stage Settings

Objective

Control stage settings according to the control specifications.

Difficulty Level

3 (★★★)

Score (Class)

290 (Advanced programming)

6.2.1

Training Screen

6.2.2

Device Assignment
Type

Input

Device No.

Device name

Operation

X0

Inside (Left curtain)

ON when curtain closes completely.

X1

Middle (Left curtain)

ON when curtain is halfway.

X2

Outside (Left curtain) ON when curtain opens completely.

X3

Inside (Right curtain) ON when curtain closes completely.

X4

Middle (Right curtain) ON when curtain is on its half way.

X5

Outside (Right
curtain)

ON when curtain opens completely.

X6

Stage upper limit

ON when stage reaches upper limit.

X7

Stage lower limit

ON when stage reaches lower limit.
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Type

Output

6.2.3

F: Advanced Challenge 6

Device No.

Device name

Operation

Y0

Curtain open
command

Curtains open when Y0 is ON. Curtains stop when Y0 is
OFF.

Y1

Curtain close
command

Curtains close when Y1 is ON. Curtains stop when Y1 is
OFF.

Y2

Stage up

Stage moves up when Y2 is ON. Stage stops when Y2 is
OFF.

Y3

Stage down

Stage moves down when Y3 is ON. Stage stops when
Y3 is OFF.

Y5

Buzzer

Sounds when Y5 is ON (Lamp on screen is lit).

Control Objective
Control stage settings including opening/closing curtains and raising/lowering the stage.

6.2.4

Control Specifications
Specifications for automatic operation
1) When [Begin] (X16) on the operation panel is pressed, Buzzer (Y5) sounds for 5 seconds.
[Begin] (X16) can be set ON only while the curtains are closed and the stage is located at
the lower limit.
2) When the buzzer stops, Curtain open command (Y0) is set ON and the curtains are
opened until they reach their outward limits (X2 and X5).
3) After the curtains are completely opened, the stage starts to move up when Stage up (Y2)
is set ON and it is stopped when Stage upper limit (X6) is set ON.
4) When [End] (X17) on the operation panel is pressed, Curtain close command (Y1) is set
ON and the curtains are closed until they reach their inward limits (X0 and X3).
Specifications for manual operation
1) The following operations are enabled only while the automatic operation described above is
not in operation.
2) The curtains can be opened only while [Curtain open] (X10) on the operation panel is being
pressed. The curtains stop at their outward limits (X2 and X5).
3) The curtains can be closed only while [Curtain close] (X11) on the operation panel is being
pressed. The curtains close until their inward limits (X0 and X3).
4) The stage can be moved up only while [# Stage up] (X12) on the operation panel is being
pressed. The stage stops when it reaches the upper limit (X6).
5) The stage can be moved down only while [$ Stage down] (X13) on the operation panel is
being pressed. The stage stops when it reaches the lower limit (X7).
6) The indicator lamps on the operation panel are lit or extinguished according to the operation
of the curtains and stage.
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6.3

F: Advanced Challenge 6

Part Distribution
Category

F: Advanced Challenge

Exercise

F-3. Part Distribution

Objective

Distribute the specified number of parts according to the size.

Difficulty Level

3 (★★★)

Score (Class)

290 (Advanced programming)

6.3.1

Training Screen

6.3.2

Device Assignment
Type

Input

Device No.

Device name

Operation

X0

Starting point

ON when robot is at starting point.

X1

Upper

ON when part is detected.

X2

Middle

ON when part is detected.

X3

Lower

ON when part is detected.

X4

Sensor

ON when part is detected on the incline.

X5

Sensor

ON when part is detected on the incline.

X6

Sensor

ON when part is detected on the incline.

X7

Sensor

ON when part is detected at the right end.

X10

Detect part

ON when part is detected in front of pusher.

X11

Detect part

ON when part is detected in front of pusher.

X12

Detect part

ON when part is detected in front of pusher.
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F: Advanced Challenge 6

Type

Device No.

Output

6.3.3

Device name

Operation

Y0

Supply command

One part is supplied when Y0 is ON. A process cycle
begins: Wooden part repeats in order M, S, L, M, M, L,
S, S, L, L.

Y1

Conveyor forward

Conveyor moves forward when Y1 is ON.

Y2

Conveyor forward

Conveyor moves forward when Y2 is ON.

Y3

Conveyor forward

Conveyor moves forward when Y3 is ON.

Y4

Conveyor forward

Conveyor moves forward when Y4 is ON.

Y5

Pusher

Extends when Y5 is ON and retracts when Y5 is OFF.
The pusher cannot be stopped in the mid stroke.

Y6

Pusher

Extends when Y6 is ON and retracts when Y6 is OFF.
The pusher cannot be stopped in the mid stroke.

Y7

Pusher

Extends when Y7 is ON and retracts when Y7 is OFF.
The pusher cannot be stopped in the mid stroke.

Control Objective
Distribute the specified number of parts according to the size.

6.3.4

Control Specifications
1) When [PB1] (X20) on the operation panel is pressed, Supply command (Y0) for the robot
is turned ON.
Supply command (Y0) is turned OFF when the robot has finished moving the part and
returned to the starting point.
2) When [SW1] (X24) on the operation panel is turned ON, the conveyors move forward.
When [SW1] (X24) is turned OFF, the conveyors stop.
3) Large, medium and small parts on the conveyors are sorted by the input of sensors Upper
(X1), Middle (X2) and Lower (X3) and carried to the specified trays.
4) When the sensor for Detect part (X10, X11 or X12) in the pusher is turned ON, the
conveyor stops and the part is pushed onto the tray.
Note: When the actuating command for the pusher is set ON, it extends completely.
When the actuating command is set OFF, the pusher retracts.
5) The following number of parts for each size are to be placed in the trays.
Excess parts are to pass in front of the pushers and fall from the right end.
-

Large: 3 parts

-

Medium: 2 parts

-

Small: 2 parts
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6.4

F: Advanced Challenge 6

Sorting Defective Parts
Category

F: Advanced Challenge

Exercise

F-4. Sorting Defective Parts

Objective

Distinguish between defective parts and good parts by their signals.

Difficulty Level

3 (★★★)

Score (Class)

290 (Advanced programming)

6.4.1

Training Screen

6.4.2

Device Assignment
Type

Input

Device No.

Device name

Operation

X0

Drilling

ON while drilling.

X1

Part under drill

ON when part on conveyor is detected by drill.

X2

Drilled correctly

ON when part is drilled correctly. Previous result is
cleared when drilling starts.

X3

Drilled wrong

ON when part is not drilled correctly. Previous result is
cleared when drilling starts.

X4

Sensor

ON when part is detected at the left end.

X5

Sensor

ON when part is detected at the right end.

X10

Detect part

ON when part is detected in front of pusher.

B-70

FX-TRN-BEG-E

Type

Output

6.4.3

F: Advanced Challenge 6

Device No.

Device name

Operation

Y0

Supply command

One part is supplied when Y0 is ON: Large metal cube.

Y1

Conveyor forward

Conveyor moves forward when Y1 is ON.

Y2

Start drilling

Starts drilling when Y2 is ON (A process cycle that
cannot be stopped partway).

Y3

Conveyor forward

Conveyor moves forward when Y3 is ON.

Y5

Pusher

Extends when Y5 is ON and retracts when Y5 is OFF.
The pusher cannot be stopped in the mid stroke.

Control Objective
Distinguish between defective parts and good parts by their signals and distribute them
accordingly.

6.4.4

Control Specifications
Overall control
1) When [PB1] (X20) on the operation panel is pressed, Supply command (Y0) for the hopper
is turned ON.
When [PB1] (X20) is released, Supply command (Y0) is turned OFF.
When Supply command (Y0) is turned ON, the hopper supplies a part.
2) When [SW1] (X24) on the operation panel is turned ON, the conveyors move forward.
When [SW1] (X24) is turned OFF, the conveyors stop.
Control of drill
1) When the sensor for Part under drill (X1) in the drill is turned ON, the conveyor stops.
2) When Start drilling (Y2) is turned ON, the drilling starts.
Start drilling (Y2) is turned OFF when Drilling (X0) is set ON.
3) When Start drilling (Y2) is turned ON, either Drilled correctly (X2) or Drilled wrong (X3)
is set ON after the drill machine has operated for one complete cycle.
(The drill cannot be stopped in the middle of an operation.)
In this simulation, one out of three parts is to be a defective part.
(When multiple holes are drilled on a part, it is also a defective part.)
4) When a defective part is detected by Detect part (X10) in the pusher, the conveyor stops
and the pusher pushes it onto the ’Defective’ tray.
Note: When the actuating command for the pusher is set ON, it extends completely.
When the actuating command is set OFF, the pusher retracts completely.
5) A good part is carried on the conveyor to the ’OK’ tray located at the right end.
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6.5

F: Advanced Challenge 6

Forward/Reverse Rotation Control
Category

F: Advanced Challenge

Exercise

F-5. Forward/Reverse Rotation Control

Objective

Move the conveyor forward or backward according to the detected size.

Difficulty Level

3 (★★★)

Score (Class)

290 (Advanced programming)

6.5.1

Training Screen

6.5.2

Device Assignment
Type

Input

Device No.

Device name

Operation

X0

Upper

ON when part is detected.

X1

Middle

ON when part is detected.

X2

Lower

ON when part is detected.

X3

Detect part

ON when part is detected in front of pusher.

X4

Starting point

ON when robot is at starting point.

X5

Part on table

ON when part is on table.

X6

Robot operation
finished

ON when robot operation finished.

X7

Sensor

ON when part is detected on the incline.

X10

Sensor

ON when part is detected at the right end.

X11

Sensor

ON when part is detected at the left end.

X12

Sensor

ON when part is detected at the right end.
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Type

Output

6.5.3

F: Advanced Challenge 6

Device No.

Device name

Operation

Y0

Supply command

One part is supplied when Y0 is ON: Wooden part
repeats in order L, M, S, M, S, L.

Y1

Conveyor forward

Conveyor moves forward when Y1 is ON.

Y2

Conveyor forward

Conveyor moves forward when Y2 is ON.

Y3

Pusher

Extends when Y3 is ON and retracts when Y3 is OFF.
The pusher cannot be stopped in the mid stroke.

Y4

Unload command

Robot moves part to tray when Y4 is ON. A process
cycle begins.

Y5

Conveyor forward

Conveyor moves forward when Y5 is ON.

Y6

Conveyor reverse

Conveyor moves backward when Y6 is ON.

Control Objective
Detect the size of each part and distribute it to the specified place.

6.5.4

Control Specifications
1) When [PB1] (X20) on the operation panel is pressed, Supply command (Y0) for the hopper
is turned ON.
When [PB1] (X20) is released, Supply command (Y0) is turned OFF.
When Supply command (Y0) is turned ON, the robot supplies a part.
2) When [SW1] (X24) on the operation panel is turned ON, the conveyors move forward.
When [SW1] (X24) is turned OFF, the conveyors stop.
3) Large, medium and small parts on the conveyors are sorted by the input of sensors Upper
(X0), Middle (X1) and Lower (X2) and carried to the specified trays.
- Large part: Pushed to the lower conveyor and carried to the right tray.
- Medium part: Moved to the tray by the robot.
- Small part: Pushed to the lower conveyor and carried to the left tray.
4) When the sensor Detect part (X3) is turned ON, the conveyor stops and a large or small
part is pushed to the lower conveyor.
Note:When the actuating command for the pusher is set ON, it extends completely.
When the actuating command is set OFF, the pusher retracts completely.
5) When Part on table (X5) is turned ON in the robot, Unload command (Y4) is set ON.
When Robot operation finished (X6) is turned ON (it is ON when a part is placed on the
tray), Unload command (Y4) is set OFF.
6) While [SW2] (X25) on the operation panel is ON, a new part is to be automatically supplied
at the following time.
- When the robot starts to carry a medium part
- When a small or large part is put into a tray
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6.6

F: Advanced Challenge 6

Lifter Control
Category

F: Advanced Challenge

Exercise

F-6. Lifter Control

Objective

Carry parts to three positions using the lift.

Difficulty Level

3 (★★★)

Score (Class)

290 (Advanced programming)

6.6.1

Training Screen

6.6.2

Device Assignment
Type

Input

Device No.

Device name

Operation

X0

Upper

ON when part is detected.

X1

Middle

ON when part is detected.

X2

Lower

ON when part is detected.

X3

Part on lift

ON when part is on the lift.

X4

Lower lift position

ON when the lift is at lower position.

X5

Middle lift position

ON when the lift is at middle position.

X6

Upper lift position

ON when the lift is at upper position.

X10

Sensor

ON when part is detected at the left end.

X11

Sensor

ON when part is detected at the right end.

X12

Sensor

ON when part is detected at the left end.

X13

Sensor

ON when part is detected at the right end.

X14

Sensor

ON when part is detected at the left end.

X15

Sensor

ON when part is detected at the right end.
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Type

F: Advanced Challenge 6

Device No.

Output

6.6.3

Device name

Operation

Y0

Supply command

One part is supplied when Y0 is ON: Metal cylinder
repeats in order S, L, M, L, M, S.

Y1

Conveyor forward

Conveyor moves forward when Y1 is ON.

Y2

Lift up command

Lift moves up when Y2 is ON. Lift stops when Y2 is OFF.

Y3

Lift down command

Lift moves down when Y3 is ON. Lift stops when Y3 is OFF.

Y4

Lift rotation command

Lift rotates to transfer part to conveyor when Y4 is ON.
Lifts rotates back to original position when Y4 is OFF.

Y5

Lower conveyor forward Conveyor moves forward when Y5 is ON.

Y6

Middle conveyor forward Conveyor moves forward when Y6 is ON.

Y7

Upper conveyor forward Conveyor moves forward when Y7 is ON.

Control Objective
Carry parts to three positions using the lift.

6.6.4

Control Specifications
Overall control
1) When [PB1] (X20) on the operation panel is pressed, Supply command (Y0) for the hopper
is turned ON.
When [PB1] (X20) is released, Supply command (Y0) is turned OFF.
When Supply command (Y0) is turned ON, the hopper supplies a part.
2) When [SW1] (X24) on the operation panel is turned ON, the conveyors move forward.
When [SW1] (X24) is turned OFF, the conveyors stop.
3) After the sensor X10, X12 or X14 at the left of conveyor has detected a part, the
corresponding conveyor is set ON and carries it to the tray at the right end.
The conveyor stops 3 seconds after a part has passed the sensor X11, X13 or X15 at the
right of conveyor.
4) Large, medium and small parts on the conveyor are sorted by the input of sensors Upper
(X0), Middle (X1) and Lower (X2).
Lift Control
1) When the sensor for Part on lift (X3) in the lift is turned ON, a part is carried to either of the
following conveyors according to its size.
- Large part

: Upper conveyor

- Medium part : Medium conveyor
- Small part

: Lower conveyor

2) Lift up command (Y2) and Lift down command (Y3) are controlled according to the lift
position detected by the following sensors.
- Upper : X6
- Meddle: X5
- Lower : X4
3) When a part is transferred from the lift to the conveyor, Lift rotation command (Y4) is set
ON.
4) After a part is transferred, the lift is to return to the initial position and stand by.
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6.7

F: Advanced Challenge 6

Sorting & Distribution Line
Category

F: Advanced Challenge

Exercise

F-7. Sorting & Distribution Line

Objective

Sort each part to the specified place according to the size.

Difficulty Level

4 (★★★★)

Score (Class)

320 (Advanced programming)

6.7.1

Training Screen

6.7.2

Device Assignment
Type

Input

Device No.

Device name

Operation

X0

Starting point (Supply) ON when supplying robot is at start point.

X1

Upper

ON when part is detected.

X2

Middle

ON when part is detected.

X3

Lower

ON when part is detected.

X4

Sensor

ON when part is detected at the right end.

X5

Sensor

ON when part is detected at the right end.

X6

Detect part

ON when part is detected in front of pusher.

X10

Starting point
(Unload)

ON when unloading robot is at start point.

X11

Part on table

ON when part is on table.

X12

Robot operation
finished

ON when robot operation finished.
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Type

Output

6.7.3

F: Advanced Challenge 6

Device No.

Device name

Operation

Y0

Supply command

One part is supplied when Y0 is ON. A process cycle begins:
Wooden part repeats in order S, M, L, S, L, M.

Y1

Conveyor forward

Conveyor moves forward when Y1 is ON.

Y2

Conveyor forward

Conveyor moves forward when Y2 is ON.

Y3

Sorting wing

Moves toward front when Y3 is ON.

Y4

Conveyor forward

Conveyor moves forward when Y4 is ON.

Y5

Conveyor forward

Conveyor moves forward when Y5 is ON.

Y6

Pusher

Extends when Y6 is ON and retracts when Y6 is OFF. The
pusher cannot be stopped in the mid stroke.

Y7

Unload command

Robot moves part to tray when Y7 is ON. A process cycle begins.

Y10

Red

Lit when Y10 is ON.

Y11

Green

Lit when Y11 is ON.

Y12

Yellow

Lit when Y12 is ON.

Control Objective
Detect the part size, and sort each part to the specified place according to the size.

6.7.4

Control Specifications
1) When [PB1] (X20) on the operation panel is pressed, Supply command (Y0) for the robot
is turned ON.
Supply command (Y0) is turned OFF when the robot has finished moving the part and
returned to the starting point.
When Supply command (Y0) is turned ON, the robot supplies a part.
2) When [SW1] (X24) on the operation panel is turned ON, the conveyors move forward.
When [SW1] (X24) is turned OFF, the conveyors stop.
3) Large, medium and small parts on the conveyors are sorted by the input of sensors Upper
(X1), Middle (X2) and Lower (X3) and carried to the specified trays.
- Large part : Led to the rear conveyor when Sorting wing (Y3) of the branch conveyor
is set ON and then carried on the conveyor and dropped from the right end.
- Medium part: Led to the front conveyor when Sorting wing (Y3) of the branch conveyor
is set OFF and then moved onto the tray by the robot.
- Small part : Led to the rear conveyor when Sorting wing (Y3) of the branch conveyor
is set ON.
When the sensor for Detect part (X6) in the branch conveyor is turned
ON, the conveyor stops and the part is pushed onto the tray.
4) When Part on table (X11) is turned ON in the robot, Unload command (Y7) is set ON.
When Robot operation finished (X12) is turned ON (it is ON when a part is placed on the
tray), Unload command (Y7) is set OFF.
5) While [SW2] (X25) on the operation panel is ON, a new part is to be automatically supplied
at the following time.
- When the robot starts to carry a medium part.
- When a small part is put into the tray, or when a large part is dropped from the right end
of the conveyor.
6) The flashing lights are lit as follows.
- Red : Lit while the robot is supplying a part.
- Green : Lit while the conveyor is moving.
- Yellow : Lit while the conveyor is stopped.
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LADDER PROGRAMS
The method to write a PLC program in the ladder program area is explained in this section.
The key operations are mostly the same as those in GX Developer, the FX Series
Programming Software.
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1.

Outline 1

Outline
The learning software consists of the 3-D graphic simulation, the ladder program area and the
operation panel. This section explains how to use the ladder.

3-D graphic simulation

Remote control

Guidance

Ladder
program area

Virtual PLC

Operation
panel

Click [Edit Ladder] on the remote control to
activate the ladder program area.
(Refer to 3.4.)
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1.1

Outline 1

Role of ladder tool
In the ladder program creates, area, you write, edit and monitor ladder programs. Machines in
the simulation are operated by the ladder programs you create here.

Virtual PLC
Program

Monitoring

Writing

ON
Program

ON

Programming
Device test

C-3

FX-TRN-BEG-E

Outline 1

MEMO

C-4

Preparation befor Operating 2

FX-TRN-BEG-E

2.

Preparation befor Operating
This chapter explains the basic knowledge required before creating ladder programs by using
the ladder tool.

2.1

What is a Project
A project consists of programs and device comments.

Programs

Project
Device
comments

Item

Description

Program

Program to operate the CPU of the PLC

Device comment

Comment on device

2.2

Creating and Saving Project

2.2.1

Creating a new project
1) Select "Project" → "New project".
2) A new project is created.

When a new project is
created, the screen
displays this.
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2.2.2

Preparation befor Operating 2

Saving of a Project with a Different Name
1) Select "Project" → "Save as".
2) The screen shown below is displayed.
Enter the project name and the header, then click the [Save] button.
Specify the place in which
the project is saved.
Enter the project name.

Enter the header.
2.2.3

Overwriting of a project
1) Select "Project" → "Save".
2) The open project is overwritten with the contents displayed on the screen.
When "Save" is selected for the first time since the project is created, the ’Save as’ dialog box
is displayed in the same way as explained above.
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2.3

Preparation befor Operating 2

Opening a project
Open an existing project from a floppy disk or hard disk.
1) Select "Project" → "Open project".
2) When the ’Open’ dialog box is displayed, select a project to open.

The place in which the project
is located is displayed.
Select a project.

The selected project name is
displayed.
You can open only one project at a time. If you try to open another project while editing a
project, the message is displayed asking if you want to save it.

POINT
For reading and handling of model answers, refer to the ’Introduction Section’ in this manual.
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2.4

Preparation befor Operating 2

Copying a project
You can copy the data (programs and comments) of another project to the currently open
project.
1) Select "Project" → "Copy". The ’Copy’ dialog box is displayed.
2) Select a source file and the data to be copied, then click the [Execute] button.
The drive/path name and the
project name of the source
file are displayed.
Click the [Browse] button,
then select a source file.

Coose the data to be copied.
If you click the [Execute]
bu t t o n w i t h o u t c h o o s i n g
anything, an error message
is displayed.

Source file
Programs
Device comments

Project being
edited

Programs
Device comments
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3.

Operation
This chapter explains how to perform programming, online operations and printing.
Virtual PLC
You can transfer the
program to the virtual
PLC.

→ 3.4.1 Writing
to PLC

You can monitor how the
program is executed in the
virtual PLC.

Program

Monitoring

Writing

Program

→ 3.4.2 Monitor
display

ON

ON

Programming
You can write and convert
programs and enter device
comments.
→ 3.1 Writing the program
3.2 Editing the program
3.3 Displaying and entering
comments

Device test
You can set devices ON and
OFF, write values, confirm the
operation of the program.
→ 3.4.3 Device test
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3.1

Operation 3

Writing the program
The program can be writen or edited in the overwrite mode or in the insert mode. Choose the
mode as follows.
1) Press the [Insert] key.
2) Every time you press the [Insert] key, the overwrite mode and the insert mode are changed
over alternately. The currently selected mode is indicated on the status bar.

Check the current mode
here.

Number of steps programmed

3.1.1

Program capacity
(8000 steps)

Basic instruction
This is how to write basic instructions.
When writing a basic instruction, specify a symbol pressing a function key, the device number
and the set value.
• How to write NO contact
(1) Place the cursor where you write an NO contact.

(2) Press the [F5] key. The ’Enter symbol’ dialog box is displayed.
(3) Type a device, and click the [OK] button.
If you click this button, the dialog
box will not be closed after you
finish writing a program. You can
continue writing.

Type a device.
The instruction symbol to be
written on the screen is displayed.

NO contact is written. After the program is written, the background is displayed in gray.

C-10

FX-TRN-BEG-E

Operation 3

POINT
If you write a program placing a cursor on a program symbol already written, the results differ
as shown below depending on the mode.
Overwrite mode

Insert mode

Input

Input
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Operation 3

• How to write basic instructions
The figure below shows the function keys, the device numbers and the set values for basic
instructions.
NO contact OR
F6
Y0
NC contact
Shift F5

X1

OUT instruction
F7
Y0

Timer
F7 T0 K50

Counter
F7 C0 K20
PLS
F8 PLS M1
SET
F8 SET Y1

Horizontal line*1
F9
Vertical line*1
Shift F9
*1 Type a number for the length after pressing F9 key.

F8 : Function key
XXXX

: Characters to type

POINT
• If you double-click a contact, the instruction symbol and the device entered are displayed in
the dialog box ’Enter symbol’.
The contact data can be changed.
Example:

Double-click it.

Changed to NC contact.
Press [Shift] + [F6].

• You can input basic instructions not only by pressing the function keys but also by typing
letters. For its method, refer to the Appendix 1.2.
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3.1.2

Operation 3

Writing STL Instruction
1) Place the cursor where the STL instruction is to be written.
2) Press the [F8] key. The ’Enter symbol’ dialog box is displayed.
3) Type STL S0.
Type the state number

Both capital letters and small
letters can be used.

4) Click the [OK] button.

Writing the RET instruction.
1) Draw a vertical line from the STL symbol and place the cursor where the RET instruction is
to be written.

Write the RET instruction after drawing a vertical line
from the STL instruction.

2) Press the [F8] key. The ’Enter symbol’ dialog box is displayed.
3) Type RET.

Both capital letters and small
letters can be used.

4) Click the [OK] button.
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3.1.3

Operation 3

Application instruction
The following is how to input application instructions.
The MOV instruction and the LD= instruction are explained up as examples.
• MOV instruction
1) Place the cursor where the MOV instruction is to be written.
Press the [F8] key. The ’Enter symbol’ dialog box is displayed.
Type MOV K100 D0.

2) Click the [OK] button.

Write the MOVP instruction and the DMOVP instruction as follows.
MOVP instruction

DMOVP instruction

• LD= instruction
1) Place the cursor where the LD= instruction is to be written.
Press the [F8] key. The ’Enter symbol’ dialog box is displayed.
Type LD= K100 D20.

Both capital letters and small
letters can be used.

2) Click the [OK] button.

POINT
For the list of available instructions and input procedures, refer to the Appendix 1.
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3.1.4

Operation 3

Conversion
The programs you write should be converted into the form which can be processed by the
virtual PLC.
This is how to convert them.
1) After writing the programs, press the [F4] key.
2) The programs are converted. The background of the programs should be displayed in white.
If there is an incorrect program, an error message is displayed and the part is displayed in
yellow. Correct the program.
An incorrect program is displayed
in yellow.

POINT
Programs you write are determined when they are converted.
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Operation 3

3.2

Editing the Program

3.2.1

Insert and Delete
• Insert line and delete line
Insert a line as follows.
1) Place the cursor where a line is to be inserted.
2) Press the [Shift] + [Insert] keys.
One line is inserted in the cursor position.
Delete a line as follows.
1) Place the cursor where a line is to be deleted.
2) Press the [Shift] + [Delete] keys.
One line is deleted in the cursor position.
• Deleting contacts
Delete a contact pressing the [Delete] or [Back space] key.
The result displayed on the screen differs depending on the mode as shown below.
Overwrite mode
Delete

The contact in the cursor position
is deleted and the position
becomes blank.

Back space

The contact on the left side of the
cursor position is deleted and the
position becomes blank.

Insert mode
Delete

The contact in the cursor position
is deleted and a horizontal line is
displayed.

Back space

The contact on the left side of the
cursor position is deleted and a
horizontal line is displayed.
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• Writing and deleting ines
Write ruler lines as follows.
1) Press the [F10] key first.
2) When writing a horizontal line, press the [Shift] + [→] keys to move the cursor. When
writing a vertical line, press the [Shift] + [↓] keys to move the cursor.

Shift + →

3) When you release the [Shift] key, a horizontal or vertical line is written.
Delete lines as follows.
1) Press the [Alt] + [F9] keys first.
2) When deleting a horizontal line, press the [Shift] + [→] keys to move the cursor. When
deleting a vertical line, press the [Shift] + [↓] keys to move the cursor.

Shift + →

3) When you release the [Shift] key, a horizontal or vertical line is deleted.

POINT
Only horizontal and vertical lines can be deleted using this method. Even if you operate the
above explained procedure on a contact, the contact is not deleted.

3.2.2

Cut, Copy and Paste
The method to cut, copy and paste a program is explained here.
You can efficiently edit programs using these functions.
1) Press the [Shift] + [→] keys to select the range to be cut or copied.

2) Select "Edit" → "Cut" or "Edit" → "Copy".
C-17

FX-TRN-BEG-E

Operation 3

3) Move the cursor to the position where the selected range is to be pasted, then select
"Edit" → "Paste".

4) The paste result is different between the overwrite mode and the insert mode as shown
below.
Overwrite mode

Insert mode

The vertical line is
extended.

3.2.3

Undo
• Return to the former status
After you write, insert, delete, cut or paste a program, you can undo the operation to return
to the former status.
1) After performing those operations, select "Edit" → "Undo".
* You can undo up to ten operations. However, you cannot delete comments by "Undo".

• Return to the status after circuit conversion
You can delete the programs currently being edited, and return to the status immediately
after the previous conversion.
1) A program is edited.

Newly created circuit

2) Select "Edit" → "Restore after ladder conversion". When the confirmation dialog box is
displayed, click [Yes]. The program edited in 1) is deleted and the screen returns to the
status just after the previous conversion.
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3.3

Operation 3

Display and input of comments
This chapter explains how to display and input device comments.

3.3.1

Display of comments
The following is how to display device comments for devices in the program being edited.
• Displaying a comment
1) Select "View" → "Comment".
2) Comments are displayed.

Device comment

• Changing the number of characters for device comments
You can select the number of characters of each displayed device comment between 16
and 32. When changing the number of displayed characters, follow the below procedure.
1) Select "Tools" → "Options".
2) When the ’Options’ dialog box is displayed, select 16 or 32 at ’Show device comment’.

Select the number of characters for
the comment field.

X000
X000

16 characters

32 characters
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3.3.2

Operation 3

Input of comments
This chapter explains how to input a device comment.
1) Select "Edit" → "Documentation" → "Comment".
2) Place the cursor on the device for which a comment is to be input and double-click it.
Double-click on the coil.

3) When the ’Enter device comment’ dialog box is displayed, type a comment. Up to 32
characters are available.
The device number for the comment.

Type a comment up to 32 characters.

You cannot delete a comment selecting "Undo".
POINT
You can type device comments when you are writing an instruction.
1) Select "Tools" → "Options".
2) When the ’Options’ dialog box is displayed, specify ’Continues during instruction write’.

If you specify it, you can type in
device comments after writing an
instruction.

Enter an instruction and comment as follows.
1) Write an instruction.

2) The 'Enter device comment' dialog box is displayed next.
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3.4

Operation 3

Communication with virtual PLC
This chapter explains how to write your programs to the virtual PLC and how to confirm the
operation.

3.4.1

Write to PLC
"Writing to PLC" means to transfer programs to the virtual PLC. After writing programs to the
virtual PLC, you can operate the machines in the simulation as well as the lamps on the
operation panel.
Write to PLC
Virtual PLC

Program

Program

1) Write a program, and convert it.
2) Select "Online" → "Write to PLC". (Or you can use the remote control.)
The ’Write to PLC’ dialog box is displayed, and you can check the writing status there. (If the
virtual PLC is in RUN mode, it is automatically and writing is executed.)
3) When writing is completed, the dialog box ’Write completed. The simmulation will start!’ is
displayed.
Click the [OK] button to run the virtual PLC.
POINT
• Status display of the virtual PLC and [Write to PLC] on the remote control

Click the [Write to PLC] button to
write a program to the virtual PLC.
This button functions the same way
as selecting "Online" → "Wite to
PLC" as described above.

The virtual PLC status is indicated
here.
You can write and edit a program if
you click [Edit Ladder] when the
PLC is in RUN mode.
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3.4.2

Operation 3

Monitor display
When you write a program to the virtual PLC, the ladder program area automatically displays
the monitoring result and you can check the ON/OFF status and stored values of devices.
The device status is displayed as follows.
OFF status

ON status

In order would to finish monitoring and write or edit a program, click the [Edit Ladder] button on
the remote control.
• Changing the current value display format
The current values of devices can be expressed in decimal or hexadecimal.
1) Select "Online" → "Monitor", → "Change current value monitor (Decimal)" or "Change
current value monitor (Hexadecimal)".
Then, the present values of timers and counters as well as the present values of operand
devices of application instructions are displayed in the selected display format.

Decimal
format

Hexadecimal
format

The present values are displayed in real numbers if the instructions take real numbers.
3.4.3

Device test
During monitoring, you can confirm the program operation by setting devices to ON or OFF
and changing the present values.
1) Select "Online" → "Devece Test".
2) When the ’Device Test’ dialog box is displayed, type the device number to the ’Device’ field.
• Bit device
ON
Type the device number whose
value is to be changed.
ON

Force the selected device ON.
Force the selected device OFF.
Force a change in the status of a
device.

You can also force a change in the device status by
placins the cursor on the device and pressing [shift] +
[Enter] or [shift] + double-click.

In the virtual PLC, you
can forcibly set inputs
(X) ON or OFF.
In the actual FX Series
PLC, however, the
priority is given to actual
connected equipment so
you cannot forcibly set
inputs (X) ON or OFF.
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• Word device

Type the device number whose
value is to be changed.

100

Enter the device number to be
changed.
Specify decimal or
hexadecimal. Specify 16-bit
integer, 32-bit integer or real
number, then type a desired
value.
Select decimal and
16-bit integer, then
set 100 to the D5.

After specifying the value, click
the [set] button.
The value will be set for the
selected device.

POINT
• The devices to which the device test was executed and the setting status are displayed in
the ’Execution history’ field. You can execute again the test displayed in the ’Execution
history’ field.

Devices which have been tested are
displayed.

• If you change the value of a device by the device test while simulation is being executed, the
machines simulated and the operation panel in which the same device is set are also
affected in the same way.
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3.5

Operation 3

Print
This chapter explains how to print the programs and device comments.
1) Select "View" → "Comment" to display device comments in the ladder program area.
2) Select "Project" → "Print".
Printing is executed according to the device comment display status as shown below.
Display in ladder program area
Each device comment is displayed in up to 16
characters.

Printing result
Each device comment is printed in up to 16
characters.

・
・
・
Each device comment is displayed in up to 32
characters.

Each device comment is printed in up to 32
characters.

・
・
・
Device comments are not displayed.

Device comments are not printed.

・
・
・

POINT
• All the programs are printed.
• If printing is executed during monitoring, the contents of the monitor display are also
printed.
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Appendix A: Instruction List for Virtual PLC
The Instructions available in the training software and their functions are listed.

A-1:

Basic instructions
Mnemonic

LD
(LoaD)

Function
Initial logical operation
contact type NO
(normally open)

Input method
(Symbol)
[F5] → X0

Input
method
(Instruction)

Program and target
device

LD_X0

Initial logical operation
LDI
contact type NC
(LoaD Inverse)
(normally closed)

[Shift] + [F5] → X0 LDI_X0

LDP
(LoaD Pulse)

Initial logical operation
Rising edge pulse

[Shift] + [F7] → X0 LDP_X0

LDF
(LoaD Falling
pulse)

Initial logical operation
Falling / trailing edge
pulse

[Shift] + [F8] → X0 LDF_X0

AND
(AND)

Serial connection of
NO (normally open)
contacts

[F5] → X0

ANI
(AND Inverse)

Serial connection of
NC (normally closed)
contacts

[Shift] + [F5] → X0 ANI_X0

ANP
(ANd Pulse)

Serial connection of
Rising edge pulse

[Shift] + [F7] → X0 ANDP_X0

ANF
(ANd Falling
pulse)

Serial connection of
Falling / trailing edge
pulse

[Shift] + [F8] → X0 ANDF_X0

OR
(OR)

Parallel connection of
NO (normally open)
contacts

[F6] → X0

ORI
(OR Inverse)

Parallel connection of
NC (normally closed)
contacts

[Shift] + [F6] → X0 ORI_X0

ORP
(OR Pulse)

Parallel connection of
Rising edge pulse

[Alt] + [F7] → X0

ORP_X0

ORF
(OR Falling
pulse)

Parallel connection of
Falling / trailing edge
pulse

[Alt] + [F8] → X0

ORF_X0

AND_X0

OR_X0
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Function

Input method
(Symbol)

Input
method
(Instruction)

ANB
(ANd Block)

Serial connection of
multiple parallel circuits





ORB
(OR Block)

Parallel connection of
multiple contact circuits





OUT
(OUT)

Final logical operation
type coil drive

[F7] → Y0

OUT_Y0

SET
(SET)

Sets a bit device
permanently ON

[F8] → SET_Y0

SET_Y0

RST
(ReSeT)

Resets a bit device
permanently OFF

[F8] → RST_Y0

RST_Y0

PLS
(PuLSe)

Rising edge pulse

[F8] → PLS_X0

PLS_X0

PLF
Falling / trailing edge
(PuLse Falling) pulse

[F8] → PLF_X0

PLF_X0

MC
(Master
Control)

[F8] → MC_N0_X0 MC_N0_X0

Mnemonic

Denotes the start of
a master control block

MCR
Denotes the end o
(Master
a master control block
Control Reset)
MPS
(Master Point
Store)

[F8] → MCR_N0

MCR_N0

Stores the current
result of the internal
PLC operations





Reads the current
MRD
result of the internal
(Master ReaD)
PLC operations









MPP
(Master PoP)

Pops (recalls and
removes) the currently
stored result

INV
(INVerse)

Invert the current result
of the internal PLC
[Alt] + [Ctrl] + [F10] INV
operations

END
(END)

Forces the current
program scan to end



Program and target
device



 : Cannot be written.
_ (underline): Leave a space here.
D-2

FX-TRN-BEG-E

A-2:

Stepladder instructions
Mnemonic

Function

Input method
(Symbol)

Input
method
(Instruction)

STL
(STep Ladder)

Starts stepladder

[F8] → STL_S0

STL_S0

RET
(RETurn)

Ends stepladder

[F8] → RET

RET

Program and target
device

_ (underline): Leave a space here.
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A-3:

Application instructions
Category

Program flow

Transfer /
Compare

Four rules /
Logical operation

Rotation shift

Function Instruction
number
symbol

Function

32-bit
instruction

Execution of
PLS
instruction

00

CJ

Conditional jump



✔

01

CALL

Call Subroutine



✔

02

SRET

Subroutine Return





06

FEND

First End





08

FOR

Start of a For/Next Loop





09

NEXT

End a For/Next Loop





10

CMP

Compare

✔

✔

11

ZCP

Zone Compare

✔

✔

12

MOV

Move

✔

✔

13

SMOV

Shift Move



✔

14

CML

Compliment

✔

✔

15

BMOV

Block Move



✔

16

FMOV

Fill Move

✔

✔

17

XCH

Exchange

✔

✔

18

BCD

Binary Coded Decimal

✔

✔

19

BIN

Binary

✔

✔

20

ADD

Addition

✔

✔

21

SUB

Subtraction

✔

✔

22

MUL

Multiplication

✔

✔

23

DIV

Division

✔

✔

24

INC

Increment

✔

✔

25

DEC

Decrement

✔

✔

26

WAND

Word AND

✔

✔

27

WOR

Word OR

✔

✔

28

WXOR

Word Exclusive OR

✔

✔

29

NEG

Negation

✔

✔

30

ROR

Rotation Right

✔

✔

31

ROL

Rotation Left

✔

✔

32

RCR

Rotation Right with
Carry

✔

✔

33

RCL

Rotation Left with Carry

✔

✔

34

SFTR

(Bit) Shift Right



✔

35

SFTL

(Bit) Shift Left



✔

36

WSFR

Shift Register Write



✔

37

WSFL

Word Shift Left



✔

38

SFWR

Shift Register Write



✔

39

SFRD

Shift Register Read



✔
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Category

Data process

Useful instruction

External
equipment/
I/O
External
equipment/
SER

Floating decimal
point

Function Instruction
number
symbol

Function

32-bit
instruction

Execution of
PLS
instruction

40

ZRST

Zone Reset



✔

41

DECO

Decode



✔

42

ENCO

Encode



✔

43

SUM

The Sum Of Active Bits

✔

✔

44

BON

Check Specified Bit
Status

✔

✔

45

MEAN

Mean

✔

✔

46

ANS

(Timed) Annunciator Set





47

ANR

Annunciator Reset



✔

48

SQR

Square Root

✔

✔

49

FLT

Float, (Floating Point)

✔

✔

60

IST

Initial State





61

SER

Search

✔

✔

62

ABSD

Absolute Drum

✔



63

INCD

Incremental Drum





64

TTMR

Teaching Timer





65

STMR

Special Timer Definable





66

ALT

Alternate State





67

RAMP

Ramp - Variable Value





69

SORT

Sort Data





76

ASC

ASCII Code





78

FROM

Read From A Special
Function Block

✔

✔

79

TO

Write To A Special
Function Block

✔

✔

82

ASCI

Hexadecimal to ASCII



✔

83

HEX

ASCII to Hexadecimal



✔

110

ECMP

Float Compare

✔

✔

111

EZCP

Float Zone Compare

✔

✔

118

EBCD

Float to Scientific

✔

✔

119

EBIN

Scientific to Float

✔

✔

120

EADD

Float Add

✔

✔

121

ESUB

Float Subtract

✔

✔

122

EMUL

Float Multiplication

✔

✔

123

EDIV

Float Division

✔

✔

127

ESQR

Float Square Root

✔

✔

129

INT

Float to Integer

✔

✔

130

SIN

Sine

✔

✔

131

COS

Cosine

✔

✔
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Category
Floating decimal
point

Clock operation

Others

Contact
comparison

Function Instruction
number
symbol

Function

32-bit
instruction

Execution of
PLS
instruction

132

TAN

Tangent

✔

✔

147

SWAP

Float to Scientific

✔

✔

160

TCMP

Time Compare



✔

161

TZCP

Time Zone Compare



✔

162

TADD

Time Add



✔

163

TSUB

Time Subtract



✔

166

TRD

Read RTC data



✔

170

GRY

Decimal to Gray Code

✔

✔

171

GBIN

Gray Code to Decimal

✔

✔

224

LD=

LoaD compare

✔



225

LD>

LoaD compare

✔



226

LD<

LoaD compare

✔



228

LD<>

LoaD compare

✔



229

LD<=

LoaD compare

✔



230

LD>=

LoaD compare

✔



232

AND=

AND compare

✔



233

AND>

AND compare

✔



234

AND<

AND compare

✔



236

AND<>

AND compare

✔



237

AND<=

AND compare

✔



238

AND>=

AND compare

✔



240

OR=

OR compare

✔



241

OR>

OR compare

✔



242

OR<

OR compare

✔



244

OR<>

OR compare

✔



245

OR<=

OR compare

✔



246

OR>=

OR compare

✔



 : Application instructions available only in 16-bit or only as consecutive-execution type
instruction
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Appendix B: Device List for Virtual PLC
B-1:

Device range list
Device range
(points)

Devices

Remark

Inputs (X)

X000 to X177 (128)

Octal number

Outputs (Y)

Y000 to Y177 (128)

Octal number

General

M0 to M512 (512)



Special

M8000 to M8255
(256)



Initial

S0 to S9 (10)



General

S10 to S511 (502)



100ms

T0 to T199 (200)



10ms

T200 to T245 (46)



T246 to T249 (4)



T250 to T1255 (6)



16-bit up

C0 to C T199 (200)



32-bit up/down

C200 to C234 (35)



General

D0 to D511 (512)



D8000 to D8255
(256)



Index

V0 to V7 and Z0 to
Z7 (16)



Nest levels (N)

For master control
block

N0 to N7 (8)



Pointers (P)

For use with CALL /
JUMP

P0 to P127 (128)



16-bit

-32768 to 32767



32-bit

-2147483648 to
2147483647



16-bit

H0 to HFFFF



32-bit

H0 to HFFFFFFFF



Bit devices Auxiliary relays (M)

State relays (S)

Timers (T)

1ms

retentive*1

100ms retentive*1
Word
devices

Counters (C)

Data registers (D)
Latched
Pair for 32-bit device

Decimal K

Hexadecimal H

*1 The current value of the elapsed timer can be cleared by the following operations.
- When the [Reset} button on the remote control is pressed
- When the program is written to the PLC
- When returning to the main menu
In programming, RST or MOV instruction can be used to clear the current value.
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B-2:

Special device list

B-2-1:

Special auxiliary relays
Diagnostic
Device

Name

Operation

M8000

RUN monitor NO contact

OFF: STOP
ON: RUN

M8001

RUN monitor NC contact

OFF: RUN
ON: STOP

M8002

Initial pulse NO contact

1 scan ON after RUN

M8003

Initial pulse NC contact

1 scan OFF after RUN

M8004

Error occurrence

M8011

10ms clock pulse

M8012

100ms clock pulse

M8013

1 sec clock pulse

M8014

1 min clock pulse

M8018

RTC available

When ON Real Time Clock is installed

M8020

Zero

Set when the result of an ADD or SUB is “0”

M8021

Borrow

Set when the result of a SUB is less than the min. negative
number

M8022

Carry

Set when ’carry’ occurs during an ADD (FNC 20) or when
an overflow occurs as a result of a data shift operation

M8024

BMOV reverse mode

ON: Write
OFF: Read

M8026

RAMP hold mode

ON: Hold output value
OFF: Reset output value

M8029

Instruction execution
complete

OFF: Executing
ON: Execution complete

M8031

Non-latch memory all clear

OFF: Hold
ON: Clear

M8033

Memory hold in ’stop’ mode

OFF: Hold
ON: Clear

M8034

All outputs disable

OFF: Output enable
ON: Output disable

M8040

STL transfer disable

OFF: Transfer enable
ON: Transfer disable

M8041

Transfer start

ON: Stop
OFF: Transfer disable

M8042

Start pulse

ON: IST instruction start command

M8043

Zero return complete

ON: IST instruction zero return command

M8044

Zero point condition

ON: Zero point position
OFF: Zero point undecided
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Diagnostic
Device

Name

Operation

M8045

All output reset disable

ON: Reset disable
OFF: Reset enable

M8046

STL state ON

ON: STL monitoring has been enabled (M8047) and there
is an active STL state

M8047

Enable STL monitoring

ON: D8040 to D8047 are enabled for active STL step
monitoring

M8048

Annunciator ON

ON: Annunciator monitoring has been enabled (M8049)
and there is an active Annunciator flag

M8049

Enable Annunciator
monitoring

ON: D8049 is enabled
OFF: D8049 is not enabled

M8067

Operation error

ON: Operation error
OFF: No operation error

M8068

Operation error latch

Hold occurrence of M8067

M8160

Selection of XCH operation
ON: 8-bit conversion
to swap bytes in a single
OFF: Normal bit
data word

M8161

Mode of 8 bit operation

Selection of 8 bit operations for applied instructions ASC,
RS, ASCI, HEX, CCD

M8164

When ON, a value in
D8164 is used as the
number of FROM/TO
exchange points.

Transfer points exchange command

M8168

Selection of BCD mode for
use with the SMOV
Digit shift in 4-bit unit
instruction

M8200

Up/Down Counter Control

ON: C200 functions as a down counter.
OFF: C200 functions as an up counter.

M8201

Up/Down Counter Control

ON: C201 functions as a down counter.
OFF: C201 functions as an up counter.

M8202

Up/Down Counter Control

ON: C202 functions as a down counter.
OFF: C202 functions as an up counter.

M8203

Up/Down Counter Control

ON: C203 functions as a down counter.
OFF: C203 functions as an up counter.

M8204

Up/Down Counter Control

ON: C204 functions as a down counter.
OFF: C204 functions as an up counter.

M8205

Up/Down Counter Control

ON: C205 functions as a down counter.
OFF: C205 functions as an up counter.

M8206

Up/Down Counter Control

ON: C206 functions as a down counter.
OFF: C206 functions as an up counter.

M8207

Up/Down Counter Control

ON: C207 functions as a down counter.
OFF: C207 functions as an up counter.

M8208

Up/Down Counter Control

ON: C208 functions as a down counter.
OFF: C208 functions as an up counter.

M8209

Up/Down Counter Control

ON: C209 functions as a down counter.
OFF: C209 functions as an up counter.

M8210

Up/Down Counter Control

ON: C210 functions as a down counter.
OFF: C210 functions as an up counter.

M8211

Up/Down Counter Control

ON: C211 functions as a down counter.
OFF: C211 functions as an up counter.
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Diagnostic
Device

Name

Operation

M8212

Up/Down Counter Control

ON: C212 functions as a down counter.
OFF: C212 functions as an up counter.

M8213

Up/Down Counter Control

ON: C213 functions as a down counter.
OFF: C213 functions as an up counter.

M8214

Up/Down Counter Control

ON: C214 functions as a down counter.
OFF: C214 functions as an up counter.

M8215

Up/Down Counter Control

ON: C215 functions as a down counter.
OFF: C215 functions as an up counter.

M8216

Up/Down Counter Control

ON: C216 functions as a down counter.
OFF: C216 functions as an up counter.

M8217

Up/Down Counter Control

ON: C217 functions as a down counter.
OFF: C217 functions as an up counter.

M8218

Up/Down Counter Control

ON: C218 functions as a down counter.
OFF: C218 functions as an up counter.

M8219

Up/Down Counter Control

ON: C219 functions as a down counter.
OFF: C219 functions as an up counter.

M8220

Up/Down Counter Control

ON: C220 functions as a down counter.
OFF: C220 functions as an up counter.

M8221

Up/Down Counter Control

ON: C221 functions as a down counter.
OFF: C221 functions as an up counter.

M8222

Up/Down Counter Control

ON: C222 functions as a down counter.
OFF: C222 functions as an up counter.

M8223

Up/Down Counter Control

ON: C223 functions as a down counter.
OFF: C223 functions as an up counter.

M8224

Up/Down Counter Control

ON: C224 functions as a down counter.
OFF: C224 functions as an up counter.

M8225

Up/Down Counter Control

ON: C225 functions as a down counter.
OFF: C225 functions as an up counter.

M8226

Up/Down Counter Control

ON: C226 functions as a down counter.
OFF: C226 functions as an up counter.

M8227

Up/Down Counter Control

ON: C227 functions as a down counter.
OFF: C227 functions as an up counter.

M8228

Up/Down Counter Control

ON: C228 functions as a down counter.
OFF: C228 functions as an up counter.

M8229

Up/Down Counter Control

ON: C229 functions as a down counter.
OFF: C229 functions as an up counter.

M8230

Up/Down Counter Control

ON: C230 functions as a down counter.
OFF: C230 functions as an up counter.

M8231

Up/Down Counter Control

ON: C231 functions as a down counter.
OFF: C231 functions as an up counter.

M8232

Up/Down Counter Control

ON: C232 functions as a down counter.
OFF: C232 functions as an up counter.

M8233

Up/Down Counter Control

ON: C233 functions as a down counter.
OFF: C233 functions as an up counter.

M8234

Up/Down Counter Control

ON: C234 functions as a down counter.
OFF: C234 functions as an up counter.
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B-2-2:

Special data registers
Diagnostic
Device

Name

Operation

D8000

Watchdog timer

200ms*1

D8001

PLC type and version

24000

D8002

Memory capacity

8000

D8004

Error number M****

The contents of this register ✩✩✩✩ identifies which error
flag is active, i.e. if
✩✩✩✩ = 8060 identifies M8060

D8006

Low battery voltage

The level at which a low battery voltage is detected

D8010

Present scan time

Current operation cycle / scan time in units of 0.1ms

D8011

Minimum scan time

Minimum cycle / scan time in units of 0.1ms

D8012

Maximum scan time

Maximum cycle / scan time in units of 0.1ms

D8013

Second data

Seconds data for use with an RTC (0-59)

D8014

Minute data

Minute data for use with an RTC (0-59)*2

D8015

Hour data

Hour data for use with an RTC (0-23)*2

D8016

Day data

Day data for use with an RTC (1-31)*2

D8017

Month data

Month data for use with an RTC (1-12)*2

D8018

Year data

Year data for use with an RTC
(00-99 or 1980-2079, can be selected)*2

D8019

Weekday data

D8028

Current value of the Z0
index register

Current value of the Z0 index register

D8029

Current value of the V0
index register

Current value of the V0 index register

D8040

Lowest active STL step

Lowest active STL step

D8041

2nd active STL state

2nd active STL state

D8042

3rd active STL state

3rd active STL state

D8043

4th active STL state

4th active STL state

D8044

5th active STL state

5th active STL state

D8045

6th active STL state

6th active STL state

D8046

7th active STL state

7th active STL state

D8047

8th active STL state

8th active STL state

D8049

Lowest active Annunciator

Lowest active Annunciator

D8067

Error code identifying
operation error.

Error code identifying operation error.

D8068

Operation error step
number latched

Operation error step number latched

D8069

Step numbers for found
errors corresponding to
flags M8065 to M8067

Step numbers for found errors corresponding to flags
M8065 to M8067

D8102

Memory Capacity

8000

D8164

Number of FROM/
TO exchange points

Number of FROM/TO exchange points
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Diagnostic
Device

Name

Operation

D8182

Value of Z1 index register

Value of Z1 index register

D8183

Value of V1 index register

Value of V1 index register

D8184

Value of Z2 index register

Value of Z2 index register

D8185

Value of V2 index register

Value of V2 index register

D8186

Value of Z3 index register

Value of Z3 index register

D8187

Value of V3 index register

Value of V3 index register

D8188

Value of Z4 index register

Value of Z4 index register

D8189

Value of V4 index register

Value of V4 index register

D8190

Value of Z5 index register

Value of Z5 index register

D8191

Value of V5 index register

Value of V5 index register

D8192

Value of Z6 index register

Value of Z6 index register

D8193

Value of V6 index register

Value of V6 index register

D8194

Value of Z7 index register

Value of Z7 index register

D8195

Value of V7 index register

Value of V7 index register

*1 The initial value is 200ms. Can be rewritten, but WDT check is not executed.
*2 The time which the clock in your computer indicates is displayed.
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Appendix C: Details of Simulated Machine Components
This section explains each component of machines simulated used in each exercise.

C-1:

Component List
Component name
Sensor

Part
supplier

Outline of operation

Sensor

Sensor detects passage and
contact of parts.

Person

Person supplies parts.

Robot

Robot supplies parts.

Hopper

Hopper supplies parts.

Outline of control

Reference
chapter

Sensor turns ON when it
detects a part (Normally
Open contact).

C-2

Supply command is
given for output drive.

C-3

Output must be driven.

C-4

Output must be driven.

C-5

C-6

Hopper (Orange) Hopper supplies oranges.

Lamp

Machine

Traffic light
(two colors)

Red and green signal lamps
light.

Traffic light
(three colors)

Red, green and yellow signal
lamps light.

Rotating beacon

Red, green and yellow flashing
lights light.

Conveyor
(standard type)

Conveyor carries parts.

Conveyor
(branch type)

Conveyor distributes parts into
two directions.

Lifter

Lifter carries parts to upper and
lower positions.

Door

Door is opened and closed
vertically.

Pusher

Pusher pushes out parts.

Drill

Drill makes holes in parts.

Stage settings

Curtains are opened and closed
horizontally.
Stage is moved up and down.

Moving
device

Robot

Robot moves parts.

Output must be driven.

Tray

Tray stores parts. (When a
certain amount of parts are
stored, person automatically
collects them.)

Control is not required.

Buzzer

Buzzer indicator lamp flickers
and buzzer sounds at same
time.

Output must be driven.

Person and car

Person/car moves when button
on screen is clicked.

Button should be clicked.

Others

C-7
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C-2:

Sensor
Each sensor detects the passage and contact of a part.

• Appearance (side view)

To rear
To left

To right
To front

• Operation
- A sensor is assigned to an input (X).
- When an object such as a part passes a sensor, the corresponding input turns ON.
OFF

ON

ON

OFF
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C-3:

Part Supplier
The mechanisms to supply parts are explained.

C-3-1:

Person
The person supplies parts.
• Appearance (front view)

• Operation
Part

Person

Supply command
- As a supply command, a lamp output (Y)
is assigned.
- When the supply command lamp turns
ON, the person supplies a part.
* If two or more parts are supplied at a
time, they will be crushed.

Conveyor

C-3-2:

Robot
The robot arm supplies parts.
• Appearance (side view)
Starting point sensor

• Operation
Supplying robot

Supply command
- As a supply command, an output (Y) is
assigned.
When the output (Y) is set ON, the robot
starts to supply a part.

Part

Conveyor
Part stock (Tray)

- Even if the driving output for the robot is
set OFF while it is supplying a part, the
robot continues the operation until it
places the part on the conveyor.
- Even if the next supply command is given
to the robot while it is supplying a part, the
robot does not accept the command.
Make sure to give the command to the
robot while the starting point sensor is
ON.
- Supply command should be set OFF by
rising/falling edge detection.
* If two or more parts are supplied at a
time, they will be crushed.
Starting point sensor
- While the robot is located at the starting
point, the input (X) is ON.
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C-3-3:

Hopper
The hopper supplies parts.
• Appearance (side view)

• Operation
Supply command

Hopper

Part

- As a supply command, an output (Y) is
assigned.
When the supply command output (Y) is
set ON, the hopper supplies a part.
The hopper supplies one part when the
output (Y) is turned ON once.
Set the output ON and OFF alternately if
continuous supply is required.
* If two or more parts are supplied at a
time, they will be crushed.

Conveyor

C-3-4:

Orange
The hopper supplies oranges.
• Appearance (side view)

• Operation
Orange

Orange supply command
- As an orange supply command, an output
(Y) is assigned.
When the supply command output (Y) is
set ON, oranges are continuously
supplied.

Box detection
sensor

Orange
Orange
motion
sensor

Box detection sensor
- This sensor turns ON when it detects a
box under the feeder (NO contact).
This sensor is built in the feeder, and is
not displayed.
Orange passage sensor
- The input (X) of this sensor turns ON
when an orange is supplied and passes it
(NO contact).
Use this sensor to count the number of
oranges.
This sensor is built in the supplier, and is
not displayed.
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C-4:

Lamp
Indicator lamps such as signal lamps and flashing lights are explained.

C-4-1:

Signal (two colors)
Red and green signal lamps come ON.
• Appearance

• Operation
- An individual output (Y) is assigned to
each of red and green lamp.
Red

- Each lamp is lit when the output is ON,
and extinguished when the output is OFF.
* Mechanical interlock is not provided
between the two lamps. (The two lamps
can be lit at the same time.)

Green

* Do not specify the 'Simple graphic
mode'. The 3-D graphic would not be
displayed properly.
C-4-2:

Signal (three colors)
Red, green and yellow signal lamps come ON.
• Appearance

• Operation
- An individual output (Y) is assigned to
each of red, green and yellow lamp.
- Each lamp is lit when the output is ON,
and extinguished when the output is OFF.
* Mechanical interlock is not provided
between the three lamps. (The three
lamps can be lit at the same time.)

Green

C-4-3:

Yellow

Red

* Do not specify the 'Simple graphic
mode'. The 3-D graphic would not be
displayed properly.

Flashing Light
Red, green and yellow flashing lights come ON.
• Appearance

• Operation
- An individual output (Y) is assigned to
each of red, green and yellow flashing
light.
Red
Green
Yellow

- Each flashing light is lit when the output is
ON, and extinguished when the output is
OFF.
* Mechanical interlock is not provided
between the three flashing lights. (The
three flashing lights can be lit at the
same time.)

D-17

FX-TRN-BEG-E

C-5:

Machine
Machine parts such as conveyors and lifters are explained here.

C-5-1:

Conveyor (standard)
The conveyor carries parts.
• Appearance (side view)

• Operation
Conveyor forward/reverse command

Reverse ↔ Forward
Sensor

Indicator for
reverse rotation

Sensor

Indicator for
forward rotation

- An output (Y) is assigned to each of
forward and reverse movement.
When the output (Y) is set to ON, the
conveyor moves.
* In some exercises, an output (Y) is
assigned to either normal or reverse
movement.

* The motors for forward rotation and reverse rotation are built in the conveyor and not displayed.
* The mechanical interlock between the motor for forward rotation and the motor for reverse
rotation is provided inside the machine simulated. Even if both of them are operated at the same
time, they are not damaged, but the conveyor does not move.
Sensor
- Sensors are provided according to the exercise.
C-5-2:

Conveyor (with sorting wing)
The conveyor distributes parts (large ones and small ones, for example) in two directions.
• Appearance (side view)
Part carrying
direction

• Operation
Conveyor operation command
Sensor

Sensor
Sorting
wing
Sensor
Motor

Output ON

Output OFF

- An output (Y) is assigned to the conveyor.
When the conveyor output is set ON, it
moves to the right.
- The motor built in the conveyor is not
displayed.
Sorting wing
- An output (Y) is assigned to the sorting
wing.
While the output is ON, the sorting wing
turns to the front and parts are carried to
the rear conveyor.
While the output is OFF, the sorting wing
turns to the rear and parts are carried to
the front conveyor.
Sensor
- Sensors are provided according to the
exercise.
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C-5-3:

Lifter
The lifter carries parts upward or downward.
• Appearance (side view)

Conveyor

Part
Conveyor

Lifter
• Appearance (front view)

The lifter
moves up.

*2

*1
Conveyor
Lifter moving up/
down motors
(not displayed)

Part absence/
presence detection
sensor (not
displayed)

Lifter position
detection sensor
(not displayed)
*1 Part carrying direction
*2 Part carrying direction

• Operation
Lifter moving up/down
- An individual output (Y) is assigned to each lifter for each direction of movement. When
the output is set ON, the lifter moves up or down respectively. The motors are built in the
lifter and are not displayed.
* The mechanical interlock between the up and down movements of the lifter is provided
inside the machine simulation. If both inputs are ON at the same time, the lifter is not
damaged but neither does it move.
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Sensor
- An input (X) is assigned to the part detection sensor. The sensor turns ON when it
detects a part and is OFF when it does not detect a part.
The sensor is not displayed.
- An input (X) is assigned to the lifter position sensor. This sensor is used to determine the
stop position when the lifter is in motion.
The sensor is not displayed.
* The ON/OF status for part detection and lifter position
sensors can be monitored by the red indicator at the left of
the device numbers in the simulation or on the I/O image
table in the virtual PLC.

Example

Sensor (X000)
Displayed in
red while the
sensor is ON.

Lifter rotation
- An output (Y) is assigned to the lifter rotation. When the output (Y) is set to ON, the lifter
rotates clockwise to transfer a part.
* If the setting is incorrect, the lifter may rotate to a spot where no conveyor is available.
The part may fall down or become stuck.
C-5-4:

Door
The door is opened and closed vertically.
• Appearance (side view)

• Operation
Door opening/closing
Door opening/
closing motors

Buzzer

- An individual output (Y) is assigned to
each of the door opening and the door
closing. (The door opening and closing
motors are built in the door, and are not
displayed.)
- When the output (Y) is set ON, the door is
opened or closed.
* The mechanical interlock between the
opening motor and the closing motor is
provided inside the vir tual machine.
Even if the two motors are operated at
the same time, they are not damaged,
but the door does not move.

Light

Car

* If an object such as car collides the
closed door, the object disappears and
the screen returns to the initial status.
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• Appearance (front view)
Door upper
limit sensor

In gate/out sensor
In gate/out sensor

Light

Out
sensor
detection
range

Door lower
limit sensor

- The door is provided with an in gate/out
sensor to detect objects. An input (X) is
assigned to each sensor.
When the sensor detects an object, it
turns ON (NO contact).
* The ON/OF status of the in gate and out
s e n s o r s w h i c h a r e n o t d i s p l ay e d
graphically can be monitored by the red
indicator at the left part of the device
numbers on the simulation or indicators
on the I/O image table in the virtual PLC.
Example
In gate sensor
Out sensor
Displayed in red
while the
sensor is ON.

If an object is
located just under
the shutter, both
the entrance
sensor and the
exit sensor turn
ON.

In gate sensor
detection range

Upper limit/lower limit sensor
- When the door reaches the lower limit, the
lower limit sensor (X) tur ns ON (NO
contact).
- When the door reaches the upper limit,
the upper limit sensor (X) turns ON (NO
contact).
* The sensors are not displayed on the
screen. Their ON/OFF status is
indicated on the side of the device
numbers in the simulation.
Buzzer
- The buzzer is built in the door.
An output (Y) is assigned to the buzzer
and when the buzzer is set ON, "bingbong" sound is intermittently issued.
Light
- An output (Y) is assigned to the light.
When the output is set ON, the light is lit in
yellow.
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C-5-5:

Pusher
The pusher extends and moves a part.
• Appearance (side view)

• Operation
Part pushing out command

Part

Part
detection
sensor
Conveyor

• Appearance (top view) when the
pusher is pushing out a part
Pusher
Conveyor

Part

- An output (Y) is assigned to the push
command. When the output is set ON, the
pusher extends. When the output is set
OFF, the pusher pulls.
* If the output is kept ON, parts may be
stuck. Set the output ON for 0.5 to 1
second, then set it OFF.
* Even if the push command is set OFF
while the pusher is extending, the
operation is not stopped until the pusher
extends completely.
Part detection sensor
- The part detection sensor turns ON when
it detects a in front of the pusher (NO
contact).
Use the sensor data to push out a part.
- An input (X) is assigned to the sensor.
The sensor is built in the pusher and is not
displayed.
* The sensor itself is not displayed on the
screen. Its ON/OFF status is indicated
on the side of the I/O number and on the
I/O image table in the virtual PLC.
Example

Sensor
Displayed in red
while it is ON.
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C-5-6:

Drill
The drill makes holes in parts.
• Appearance (side view)

• Operation
Drilling start command

Part
detection
sensor
Part

- An output (Y) is assigned to the drilling start
command. When the output is set ON, the
drill starts drilling.
Drill

- When the drill starts drilling, the input (X) of
the drilling signal turns ON. Write the program
to turn OFF the drilling start command using
this input signal.

Conveyor

• Appearance (front view)

- Once the drilling operation is started, the drill
does not stop until it completes a cycle of
operation even if the drilling start command is
set OFF.
Drill

Part
Conveyor

Drilling signal

Correct/wrong signal
- If a part is located under the drill, a hole is
drilled in the center of the part and the correct
completion (Y) is set ON. If a par t is not
located under the drill or if multiple holes are
drilled on a part, the wrong drilling (Y) is set
ON. (When the wrong drilling is performed,
the part is crushed.)
* In some exercises, one out of certain
number of parts is to be a defective part.
Part detection sensor
- The part detection sensor turns ON when it
detects a part is coming close (NO contact).
Use this sensor to take the timing to start
drilling or stop the conveyor.
- An input (X) is assigned to the sensor. The
sensor is built in the drill and is not displayed
on the screen.
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C-5-7:

Stage Settings
The curtains are opened and closed horizontally, and the stage is moved up and down.
• Operation

• Appearance (side view)

Buzzer

Curtain opening/closing

Sensor

- An individual output (Y) is assigned to
each of the curtain opening and the curtain
closing.
The opening output or the closing output is
held while it is set ON.

Curtain
opening/
closing
motors

Curtain

Stage

* The curtain opening and closing motors
are not displayed on the screen.
Curtain position sensor

Person
(not controlled)

Details of stage
(front view)

Stage moving up/
down motors

- In the upper portion of the curtains, the
inside, middle and outside sensors are
provided (six sensors in all).
These sensors are used to detect the
curtain opening/closing position.
* The ON/OF status of the sensors not
displayed graphically can be monitored
by the red indicator at the left part of the
device numbers on the simulation or
indicators on the I/O image table in the
virtual PLC.

Stage moving up/down
- The stage carries up and down the person.
An output (Y) is assigned to each of the stage moving up and the stage moving down respectively.
While either output is ON, the stage is moved up or down. If the both outputs are set ON at the
same time, the stage is stopped. The motors are not displayed on the screen.
In the front view and
the plan view, you can
see in detail how the
trapdoor is moving.

Stage upper limit/lower limit sensor
- Sensors are provided in the upper limit and the lower limit of the stage.
Use these sensors to stop (set OFF) the stage moving up and moving down motors.
* The sensors are not displayed on the screen.
- Control of the person located on the stage is not required. (The person remains on the stage and
does not move.)
Buzzer
- An output (Y) is assigned to the buzzer. When the output is set ON, the buzzer flickers in yellow
and continuous "bing-bong" sound is issued intermittently.
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C-6:

Unloading Robot
The robot operation to unload parts is described in this section.

C-6-1:

Robot
The robot moves a part to the tray.
• Appearance (side view)

• Operation
Moving command

Part
Moving robot

Tray

Conveyor
Part
detection
sensor

- An output (Y) is assigned to the moving
command.
When the output is set ON, the moving
robot turns clockwise and carries a part.
- When the moving command is set ON, the
robot performs one complete cycle of
operation without regard to presence/
absence of part.
Robot operation finished
- When a part is put into the tray, the part in
tray signal (X) turns ON. Write the program
to turn OFF the moving command using
this input signal.
Starting point signal
- While a part is located at the starting point
as shown in the figure, the starting point
signal input (X) is ON.
It is recommended to use this starting
point signal for interlock of the part moving
command.
Part detection sensor
- This sensor detects presence/absence of
a part.
- An input (X) is assigned to the sensor.
The sensor turns ON when it detects a
part (NO contact).
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C-7:

Others
Auxiliary operations and parts for the simulation are explained in this section.

C-7-1:

Tray
The tray stores parts.
• Appearance (side view)

• Operation
Control is not required.
When the specified number of par ts are
stored, the person automatically appears to
collect the parts.

Tray

C-7-2:

Buzzer
The buzzer sounds.
• Appearance (side view)

• Operation
An output (Y) is assigned.
When the output (Y) is set ON, "bing-bong"
sound is intermittently issued. In addition, the
lamp provided in the center of the buzzer
flickers in yellow.

Buzzer

Lamp

C-7-3:

Person and Car
The person and the car appear on the screen.
• Appearance (side view)

• Operation
Control is not required.

Car

Person

* In some exercises, buttons are displayed
on the 3-D graphic simulation. While a
button is being pressed, the person or the
car moves.
When the person or the car collides with an
object or wall, it disappears and the screen
returns to the initial status.
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Appendix D: Questions & Answers and
Please refer to the Q&A listed here for information on the training software.

D-1:

Frequently Asked Questions
General
Question

Answer

How do I connect the PLC?

Actual PLC and connection cables are not required.
When the software is installed, the virtual PLC is set up in your
computer.

Where should I begin learning?

You can choose any exercise in the main menu. However, it is
recommended to start from the category 'Let's Learn the FX
Series PLC' to understand the structure and operation
procedures of the software.

What do I learn using this software?

You learn how to control various machines using basic PLC
instructions.

Can I use the software without
installing it to my computer?

No.

I have finished the exercise.
Where do I go next?

If you are a registered user, update your score and return to
the main menu as instructed on the self-judgment page.
If you are not a registered user, click [Main] on the remote
control to return to the main menu.

What does the 'good' award on an
exercise button on the main menu
indicate?

It indicates a completed exercise. Awards are only displayed
for registered users.

Click the tutor on the remote control to alternately hide and
display the guidance window.
How do I hide the guidance window to Or select “Tool” → “Fix remote control bar” and delete the
check mark to display the title bar at the top of the remote
look at the simulation?
control. By dragging the title bar using the mouse, you can
move the guidance window to an arbitrary position.
Ladder Program
Question

Answer

The program can be transferred only to the virtual PLC inside
Can I transfer the program to an actual
your computer. The ladder program area is internally
PLC?
connected to the virtual PLC.
How can I write a program while the
PLC is in RUN mode?

You cannot write a program while the PLC is in RUN mode.
Click [Write to PLC] on the remote control to write a program
easily. (Or select "Online" → "Write to PLC" on the ladder
menu.)

Which instructions are available?

Basic instructions, Application instructions and stepladder
instructions. For the details, refer to the tables in the appendix
in this manual.

Can I use the program later?

You can store the program selecting "Project" → "Save as".
You can read and edit data.

How can I display comments in the
ladder program?

Select "View" → "Comment".
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Ladder Program
Question

Answer

Can I type in the instructions in the
ladder program?

Yes. Type in the instructions after clicking the ladder program
area.
The instruction list is not available in the software. Refer to the
table in the appendix in this manual.

Can I change the window size?

No, the display size is fixed.

Why are some contacts highlighted in A feature of the I/O monitor display is that when a contact or a
blue?
program is set ON, it is highlighted in blue.
What are the numbers under the
timers and counters?

The numbers under the timers and counters are their current
values.

Does the program I write in this
software run in an actual PLC?

Yes, but this software is not equipped with the function to write
a program to an actual PLC. The program must be entered in a
general release software package such as GX-Developer and
then transferred to the PLC.

Ladder example
Question

Answer

How do I see the ladder example?

Click [Edit Ladder] on the remote control. Then select "Help"
→ "Ladder example" → "Example" on the simulation menu.

Should my program be exactly the
same as the ladder example?

No. Refer to the ladder example only as examples of one
correct control method.

How do I study the details of the
programs of ladder example?

Device comments are provided to the ladder example. Select
"View" → "Comment" to study them.
Yes. Select "Project" → "Print".

Can I print out the ladder example?
Can I edit the ladder example?

Yes. Select "Project" → "Save as" on the ladder menu to
create another file for editing so that the original model answer
is not deleted.

How do I save a ladder example with a
Select "Project" → "Save as" and name the file.
different name?
Can I confirm the operation after
editing the ladder example?

Yes. Let's see how your program operates!

Yes. Read out one of the ladder example, edit and overwrite it
Can I register my program as a ladder
selecting "Project" → "Save" on the ladder menu. (You cannot
example?
'add' a new ladder example.)
Virtual PLC
Question

Answer

What is the virtual PLC?

It is a PLC in which the program you write in your computer is
virtually transferred and run.

Which instructions and devices are
available in the virtual PLC?

Refer to the tables in the appendix in this manual.

RUN indicator and ON/OFF lamps for I/O on the 'I/O image
How do I know the status in the virtual
table' are lit or extinguished according to the status in the
PLC?
virtual PLC.
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Virtual PLC
Question

How can I switch the RUN mode and
STOP mode in the virtual PLC?

Answer
There are several ways to do it. (No RUN/STOP switch)
• Switched to STOP mode when you click [Edit Ladder] on
the remote control.
• Switched to RUN mode when you write your program to the
PLC in STOP mode.
• Switched to STOP mode and then to RUN mode when you
click [Reset] on the remote control.
• Switched to STOP mode when you write your program to
the PLC in RUN mode.

When is the program inside the virtual The program is cleared when you go to the main menu or exit
PLC cleared?
the software.
Simulated Machine
Question

Answer

Can I add sensors?
Can I change the device assignment? No. The device assignment in machines is determined in
advance. You cannot add or change them.
Can I change the operations of
machines?
Do I need to wire the virtual PLC to the
No. They are wired virtually inside your computer.
machines?
Can I restart the operation of the
Yes. Click [Reset] on the remote control to reset the I/O status
machine if the machine stops or parts of the PLC and return the screen to the initial status.
are stuck?
(The program is saved in the PLC.)
Can I perform the operations different
Yes. There is more than one way to control the machines.
from the ones shown in the guidance?
When does the person appear in the
3-D graphic simulation?

In most cases, the person appears to collect parts when
certain amount of parts are put in the tray.

When the performance of the computer is improved, the
operation speed of the machines is improved accordingly.
How do I speed up the operation of the
If you have the unwanted situation such as 'the input data from
simulation machines?
a sensor is not received properly', speed adjustment is
required.
Operation panel
Question

Answer

Can I add switches and lamps?
Can I change the device assignment?
Can I change or add letters and
phrases displayed?

No. Assignment of switches and lamps on the panel are
determined in advance and cannot be added or changed.

Can I change the lamp colors?
Can I use the switches and lamps the
guidance does not talk about?

Yes. Such switches are wired to the virtual PLC. You can use
them as your own operation switches and indicator lamps.

User registration/self-judgement
Question
What is the advantage of being a
registered user?

Answer
In the main menu, a 'good' award and the number of times the
exercise has been completed is displayed on the exercise
button and your total score is listed at the bottom.
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User registration/self-judgement
Question

Answer

Follow the instructions in the box.
If you are a registered user, you are asked to judge your
I am on the self-judgment page. What
understanding in a dialog box. If you click [Yes], the score and
do I do?
the number of times the exercise has been completed is
updated.
I am a registered user, but I forgot my
password. What should I do?

Register yourself as a new user.

What is the score I gain for finishing
each exercise?

Scores have been set according to the difficulty level of the
lesson. When an exercise has been completed, the score is
added to the registered user’s overall total.

What if I don't register myself as a
user?

An unregistered user can learn the lessons in the same
manner as a registered user. Unregistered users do not
collect points nor award stickers. This makes it more difficult
to monitor which lessons have been successfully completed.

System requirement
Question
Is a Pentium 500MHz CPU
mandatory?

Answer
No, the software runs at approximately 300 to 400MHz. Lower
specification equipment will cause the overall operation to be
slow.

64MB or more is mandatory. It is recommended to use 128MB
Is 64MB of RAM memory mandatory? or more for cases in which other softwares are running at the
same time.
Is 4MB of VRAM (video memory) or
more mandatory?

In order to assure the operation speed and the display
contents of the simulation, use a computer equipped with a
video memory of 4MB or more.

Is the screen display of XGA (1024 ×
768) or more mandatory?

Yes. This software is designed at the fixed size of the XGA
(1024 × 768).
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D-2:

What to do if...
It indicates that you completed the
Print out the program you have written, and check the
exercise. (It is not displayed if you are
contents.
not registered as a user when starting
Refer to model answers if needed.
the software.)
The machine in the simulation does
not operate.

Check whether the device assignments in the program are
equivalent to those shown in the guidance.
A conveyor does not move if the forward and reverse motors
are ON at the same time.

When the performance of the computer is improved, the
I would like to speed up the operations operation speed of the machines is improved accordingly.
in the virtual manufacturing cell.
If you have an error situation such as 'the input data from a
sensor is not received properly', speed adjustment is required.
The program cannot receive the input
data from the sensor.

Select "Tools" → "Options" and reduce the simulation speed.

A part does not stop where it should
•
•

Something is wrong with the 3-D
screen. (The display is disturbed, etc.)

•

Check whether the video card of your computer supports
the direct 3-D.
Select “My computer” → “Control panel” → “Screen” →
“Settings” tab → “Details” button → [Performance or
troubleshooting] tab, then decrease the set value of
“Hardware accelerator” to “zero”. If the problem is solved,
increase the set value one by one up to a highest allowable
value.
Select “My computer” → “Control panel” → “Screen” →
“Settings” tab, then increase [Screen color] to "24 bits" or
decrease it to "16 bits".

Or the problem may be solved if you update the video driver to
the latest version provided by the computer manufacturer. (For
details, consult with the computer administrator.)
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