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1 OUTLINE OF EDITING

This Parameter File Editor is a dedicated software to add/change/delete supporting models in FR Configurator SW3 and to
add/change/delete parameters displayed in FR Configurator SW3. By using this software, version upgrade of an inverter and
special inverters can be supported by FR Configurator SW3. 
Please note in advance that Mitsubishi does not offer any guarantee regarding Parameter File Editor. 

REMARKS
· If you want to edit and share the parameter data stored in the system area, copy the data to a location where other users also

have file access, and edit the copied data. By overwriting the system area data with the data edited by other user, the edited
parameter data can be shared.

· If you want to directly edit the parameter data stored in system area while using Windows Vista, log on as an administrator and
start the software.

· At the automatic recognition of FR Configurator, the added model using this software will be recognized as a standard inverter.
After the recognition of the new model, change the model setting manually.

Parameter File Editor

Adding a new model?

Editing parameters?

Deleting a model?

Adding a new model

Editing parameters

Completed

Select a editing folder

New

Delete

Edit

Editing parameters

Save

Model information editing

Deleting a 

supporting model

Model information 

editing

Specify the folder containing the parameter file.
（Refer to page 6）

Select an operation among [New(N)], [Edit(E)],
and [Delete(D)] from [Model(E)] menu. 
(Refer to page 5)

Perform model information editing (Refer to page 9)
and parameter list editing (Refer to page 3). 
Model information and parameter can be added/
deleted/edited.
Functional list code of each parameter can be also
edited (Refer to page 10).

· To create a new data, select a model and a
capacity for a prototype.

· To edit an existing model, select the model and
capacity. (Refer to page 7)

Save the edited data. When saving new or changed
data, select a position for the data in the model list
of FR Configurator. (Refer to page 12)

Unnecessary model can be deleted from the model
list of FR Configurator. (Refer to page 8)

Enter the name of the model and edit the model
information. (Refer to page 9)
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2 MENU AND SETTING WINDOW

2.1 Main window and parameter setting items 

Parameter list can be edited from the main window. From the menu bar, editing folder selection window, model addition
window, model information window and more are displayed.

No. Name Function and Description
A Title bar Model name and capacity is displayed next to "Parameter File Editor" on the title bar.

B Menu bar
Windows of different functions can be displayed from the menu. "Select a editing folder" window (Refer 
to page 6), "New" window (Refer to page 7), and "Model Information Editing" window (Refer to page 9) can 
be displayed from the menu.

C Editing folder Displays the folder being edited.

D Parameter No.
Displays the selected parameter number. If you enter a parameter number in this field, the cursor 
moves to the parameter of the entered number.

E Parameter list The area for parameters editing. Parameters can be added, edited, or deleted.

F Parameter check
Click to sort the parameter numbers, and to check for the each item for duplication or an error. 
Parameter with an error is displayed in red.

NOTE
For the models with parameters changed or deleted, Setting Wizard of FR Configurator may not behave properly. Check
the result of the Setting Wizard, and make settings manually from a parameter list if necessary.

B
D

E

F

C
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Main window and parameter setting items
Setting items on the parameter list

No. Name Function and Description
A Pr. Set the parameter number. Number from 0 to 999 can be entered (except for 902 to 939, which cannot be entered).
B Name Set the parameter name. Total of 159 one-byte characters can be entered.

C Initial Value
Set the initial value. Value from 0 to 65535, up to third decimal place can be entered. (The entered value will be 
rounded down to the third decimal place.)

D Digit
Select the significant figures. Value from 0 to 3 can be entered.
Example) Set significant figures of "2"(decimal place) for the setting unit of 0.01Hz. 

E Unit Select the unit of the parameter.

F
Setting 
Range

Set the setting range of the parameter. Total of 159 one-byte characters can be entered.
Setting range for standard models is displayed in the following manners.

· When two or more setting values exist, they are separated by "," (comma).
· When different setting ranges exist for different capacities, they are separated by "/".
· When the maximum value differs by the case, the maximum value is displayed as "****".
· When setting read-only setting ranges, they are displayed as surrounded by "("  ")".
· When not displaying the setting range, "---" or "-" is displayed.
· A value with special  meaning is displayed as 8888 or 9999. (Decided by the inverter side.)

(Example)
· Minimum value is 0 and maximum value is 500A for 55k or less, 

and minimum value is 0 and maximum value is 3600A for 75k or more... ........................ 0 to 500/0 to 3600A
· Minimum value is 0, maximum value is 400Hz, and the function is invalid when 9999..... 0 to 400Hz, 9999
· Minimum value is 0 and maximum value is 1000mH(50Ω)... ............................................ 0 to 1000mH(0 to 50ohm)

G
Special 
code

Select the parameter writing rule for the setting values of 9999 and 8888.
0: Not specified
1: Only 9999 is valid
2: Only 8888 is valid
3: 8888 and 9999 are both valid

H
Functional 
code

Categorizing of parameter into each Functional parameter lists is available from "Functional List Code" window.
(Hexadecimal codes are used in this column. Codes from 0x0000 to 0xFFFF can be set.)
Place the cursor to the row of the parameter, select [Functional List Code...] from [Edit] menu, and from the 
"Functional List Code" window, select the Functional parameter list category. (Refer to page 10)

I
Writing 
order

Set the order of parameter batch write. Value from 0 to 20 can be entered. Parameters with smaller value are written 
faster. When same value is set, writing is performed by the order of parameter value.
Set 10 in normal condition. To be written earlier, set a smaller value than 10. To be written later, set a larger value than 
10. 
(Change the writing order only for the special parameter, which affects other parameters and units when they are 
written (for example, Pr. 21 and Pr. 37.). If the writing order of an existing  parameter is changed, the setting values 
may not be written correctly.)

J Attribute

Set this field for the parameters which requires special processing.
0 : No action
1 : Parameters which announces re-reading of other parameters at parameter writing.
16 : Read-only parameters
32 : Parameters which does not allow inputting.

REMARKS
The initial value of the following parameters may vary depending on the capacity.
   Pr. 0, 7, 8, 9, 12, 44, 56, 557 and 893
   (Refer to the Instruction Manual of the each model for details.)
As for these parameters, FR Configurator displays calculated value based on the capacity in the initial value field.
(Note that if the initial value field is blank, FR Configurator also displays blank. Please fill a value in the field, and do not leave the
field blank for these parameters.)

A B C D E F G H I J
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Menu List
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2.2 Menu List

The following functions are available on the menu.

Menu Pull-down menu Function and Action
Refer 

to 
page

File Folder... Menu for specifying the folder storing the parameter data.
(Refer to page 6)

6

Save... Saves the edited model information and parameter data.
Setting of a display position in FR Configurator model list is available. (Refer to 
page 12)

12

Import... Imports the exported data of model information and parameter data. 
Exported file, which has been created using this Parameter File Editor, can be 
imported. Extension of import parameter files is *.vf_.

-
Export... Exports the model information and parameter data created with this software. The 

created model information and parameter data can be re-used in a different 
personal computer. Extension of export parameter files is *.vf_.

Exit Exits Parameter File Editor. If the edited data is not saved, confirmation dialog 
appears.

Model New... Creates new model information and parameter data. Select a prototype model for 
the new model information and parameter data in the appeared window. 
(Refer to page 7)

7
Edit... Edits an existing model information and parameter data. Select the model for 

editing in the appeared window.
(Refer to page 7)

Delete... Deletes a model from the FR Configurator model list. Select the model to be 
deleted in the appeared window.
(Refer to page 8)

8

Edit... Cut Cuts the selected area, and pastes it to the clipboard. Cell or entire row can be 
cut.

-

Copy Copies the selected area, and pastes it to the clipboard. Cell or entire low can be 
copied.

Paste Pastes an item stored in the clipboard. (Items from other applications may not be 
pasted correctly.)

Add Paste Inserts a row that has been cut or copied.
Add Inserts a blank row above the selected row. 
Del Deletes the selected row.
Functional List Code... Displays the list of the functional list category.

Select a category to be displayed in the functional parameter list, and click [OK].
10

Model info... Edits the model information. Model name, capacity, rated current, communication 
resource, and plug-in option can be set. (Refer to page 9)

9

Help Contents Displays Help window.
-

About... Displays the version information.
5



"Select a editing folder" window
2.3 "Select a editing folder" window

Select [Folder...] from the [File] menu to display the "Select a editing folder" window. 
Specify the folder containing the parameter file by selecting the drive first, then the folder. When a folder containing the
parameter file is selected, parameter files (*.vfd) in the folder are displayed in the right column.

No. Name Function and Description
A Drive selection Select a drive containing the parameter file.
B Folder selection Select a folder containing the parameter file.
C File display Displays parameter files, which are located in the selected folder.
D OK Click to start editing a parameter file of the selected folder.
E Cancel Closes the window without selecting the folder.

REMARKS
· If the install destination of FR Configurator is not changed, the parameter file is saved in 

C:\Program Files\MELSOFT\invsup3_e\en\param
· If you want to edit and share the parameter data stored in the system area, copy the data to a location where other users also

have file access, and edit the copied data. By overwriting the system area data with the data edited by other user, the edited
parameter data can be shared.

· If you want to directly edit the parameter data stored in system area while using Windows Vista, log on as an administrator and
start the software.

A

C

D

B

E

6



"New" and "Edit" windows
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2.4 "New" and "Edit" windows

· To add a new model, select [New...] from the [Model] menu. Select a prototype model for the new model in the  "New"
window.

· To edit an existing model, select [Edit] from the [Model] menu. Select the model in the "Edit" window to edit.
Select the inverter model name on the left and the capacity on the right, and then click "OK" to proceed to parameter editing
and model information editing.

When creating a new data

No. Name Function and Description
A Inverter Type Select the model for editing or for a prototype.
B Capacity Selection Select the capacity of the model for editing or for a prototype.
C OK Closes the window after reading the parameter information of the selected model.
D Cancel Closes the window without selecting the model.

REMARKS
· Standard models in FR Configurator cannot be edited. To edit a standard model, select [New...] on the [Model] menu, and create

a new model name, and  then edit the data.

A B

C D
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"Delete" window
2.5 "Delete" window

Select [Delete...] on the [Model] menu to display the "Delete" window. Select a model to be deleted from the model list in FR
Configurator, and click [OK] to close the window. Then select [Save...] on the [File] menu, and the selected model will be
deleted from the model list of FR Configurator.

No. Name Function and Description
A Inverter Type Select the model to be deleted.
B Capacity Selection Select the capacity of the model to be deleted.
C OK Closes the window with selecting the deleting model.
D Cancel Closes the window without selecting the model.

POINT
· Before deleting the data, make sure to backup the folder containing the parameter file. If a model is deleted by mistake, you can

overwrite the parameter file using the backup data. 

A B

C D
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"Model Information Editing" window and setting items
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2.6 "Model Information Editing" window and setting items

Select [Model Info...] on the [Edit] menu to display the "Model  Information Editing" window. Model name, capacity, rated
current, communication resource, and plug-in option can be set. After editing and adding the model information, click [OK].

Model Information Editing
No. Name Function and Description
A Inverter Type Set the name of the inverter model. After the hyphen, up to three one-byte characters can be entered.
B Inverter Capacity Displays the capacity. To edit or add, click [Edit] or [Add].

C Plug-in Option
Set the available plug-in options of the selected model. Communication options can be set only to 
"Option 3 Selection".

D Communication Resource
Set the available communication route of the selected model. At least one communication route must 
be selected.

E Edit Displays the "Inverter Capacity" window for the selected capacity in the inverter capacity table.
F Add Displays "Rated Capacity Adding" window. Rated capacity can be added.
G Delete Deletes the selected capacity in the inverter capacity table.
H OK Closes the window with the valid setting.
I Cancel Closes the window without the setting.
J Help Displays Help window.

Rated Capacity Adding and Rated Capacity Editing
No. Name Function and Description

K Inverter Capacity

Set the inverter capacity. One-byte characters can be entered.
Smaller capacity: 0.01 to 55.00kW
Larger capacity: 55.01 to 630.00kW

(The entered value will be rounded down to the third decimal place.)

L

Rated Current (SLD)
Rated Current (LD)
Rated Current (ND)
Rated Current (HD)

Enter the rated current.
Smaller capacity: 0.1 to 500.0A
Larger capacity: 0.1 to 3600.0A

(The entered value will be rounded down to the second decimal place.)
When editing a parameter file which will be used outside of Japan, the multiple rated capacity of SLD, 
LD, ND, and HD can be set. 

M Inverter Type Name Set the model name of the capacity up to 8 digits in one-byte alphabet and number.
N OK Closes the window with the valid setting.
O Cancel Closes the window without the setting.

A

E

D

F

G

H JI

B

C

K

N O

L

M

Rated Capacity Adding/

Editing window

(When adding a rated capacity)

Model Information Editing window

Display a window by 

clicking [Edit] or [Add].
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"Functional List Code" window and setting items
2.7 "Functional List Code" window and setting items

While selecting a parameter in the list, select [Functional List Code...] on the [Edit] menu to display the "Functional List Code"
window. Categorizing of the selected parameter into functional list is available. Check the boxes of the each categories which
you want to display in the Functional parameter list, and click [OK]. 

Example of a FR-A700 series inverter 

No. Name Function and Description
A Parameter Number Displays the editing parameter number.

B Functional List Code
Displays the total hexadecimal code of the selected functional list items. The code displayed 
here is entered to the "Func. Code" column of the parameter list.

C Func. Code Select functional parameter list items.
D OK Closes the window with the valid setting.
E Cancel Closes the window without the setting.
F Help Displays Help window.

A

B

D F

C

E
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"Functional List Code" window and setting items
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"Functional List Code" setting items

Items on the functional parameter list of FR-A700 series, FR-A701 series

Items on the functional parameter list of FR-D700 series, FR-E700 series, and FR-F700 series

Function Description
Basic Function Parameters related to basic functions
Frequency Setting Parameters related to frequency
Acc/Dec Setting Parameters related to acceleration/deceleration
V/F Characteristics Parameters related to V/F characteristics
Protection Parameters related to the protective function
Operation mode Parameters related to operation modes
Monitor Parameters related to the monitoring function
Braking Parameters related to braking frequency and braking time
Terminal Parameters related to control circuit terminals
Additional Function Other parameters
Maintenance Parameters related to maintenance
Magnetic flux vector Parameters related to Advanced magnetic flux vector control (General-purpose magnetic flux control)
Vector Parameters related to vector control

Calibration 
Parameters for calibrating terminals FM and AM and set bias/gain of frequency (speed) setting voltage and 
current

Communication Parameters related to communication
Option Parameters related to options

Function Description
Motor Torque Parameters related to a motor and torque
Frequency setting Parameters related to frequency
Acc/Dec Setting Parameters related to acceleration/deceleration
Protection Parameters related to the protective function
Monitor Parameters related to the monitoring function
Braking Parameters related to braking frequency and braking time
Terminal Alloc Parameters related to control circuit terminals
Magnetic flux vector Parameters related to Advanced magnetic flux vector control (General-purpose magnetic flux control)

Intelligent
Parameters related to the intelligent mode, which sets appropriate parameters automatically and drive the 
inverter

Calibration 
Parameters for calibrating terminals FM and AM and set bias/gain of frequency (speed) setting voltage and 
current

Option Parameters related to options

Special running
Parameters related to the special operation that requires parameters to be set before the actual use. Examples 
of the special operation are communication and programmed operations. 
11



"Position to Add the Type Information" window
2.8 "Position to Add the Type Information" window

After the editing of parameter data and model information data, select [Save...] on the [File] menu to display the "Position to
Add the Type Information" window.  Added model will be displayed on the selected position in FR Configurator model list.
Select the position for the added model by clicking [Upper] and [Lower]. After selecting the position, click [OK], and save the
data.

When creating a new data

No. Name Function and Description

A
Adding Inverter Type
Editing Inverter Type

Displays the added or edited model.

B Inverter Type
Displays a models list of FR Configurator. Select the position for the added or edited model in the 
list.

C Upper Moves up the added or edited model.
D Lower Moves down the added or edited model.
E OK Closes the window with the valid setting.
F Cancel Closes the window without the setting.

B

A

C

D

E F
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Adding a new model
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3 PARAMETER EDITING EXAMPLE

Examples of adding a new model (Refer to page 13), editing/changing an existing model (Refer to page 15), and deleting a
registered model from the model list in FR Configurator (Refer to page 17) are shown below. Before editing, make sure to
backup the folder containing the parameter file.
(The parameter file is saved in 

  C:\Program Files\MELSOFT\invsup3_e\en\param 
if the install destination of FR Configurator is not changed.)

3.1 Adding a new model

1) Select [Folder...] from the [File] menu to display the "Select 
a editing folder" window. 
Specify the folder containing the parameter file, and click 
[OK]. (Refer to page 6)

2) Select [New] on the [Model] menu to display the "New" 
window. (Refer to page 7)
Select a model and a capacity used as prototypes for the 
new data. 

3) Click [OK] in the "New" window to display the "Model 
Information Editing" window. (Refer to page 9)
Add or edit the model name, capacity, rated current, 
communication resource, and plug-in option settings.
To add a capacity, click [Add] and make settings on the 
"Rated Capacity Adding" window.
To edit a capacity, click [Edit] and change settings on the 
"Rated Capacity Editing" window.

Specify the folder containing the 

parameter file.

Parameter files in the 

folder are displayed.

Select the model for a 

prototype.

Select a capacity of the 

model.

Enter the dedicated model name 

after the hyphen. 

Set the available options.

Set the capacity, rated 

current, and capacity 

name of the each model.

Set the available 

communication route. 

Click [Add], and 

display the window.
13



Adding a new model
4) Edit parameters from the main window. 
(Refer to page 3 for setting items of parameters.)
To edit the functional list code of each parameter, select 
[Functional List Code...] on the [Edit] menu, and change 
settings on the "Functional List Code" window. 

5) After editing  parameters, click [Parameter Check] to sort 
parameter numbers and check each item for an error. 
When a parameter with an error exists, the parameter is 
displayed in red. Correct the setting for the parameter. 
(Refer to page 3)

6) After completing the parameter check, display the 
"Position to Add the Type Information" window by selecting 
[Save...] on the [File] menu. (Refer to page 12)
Select the position for the added model in FR Configurator 
model list, and click [OK]. Addition of the new model is 
completed.

7) The created parameter files can be also used in a different 
computer by exporting and importing them.

Edit parameters

Edit the functional list 

code of the selected 

parameter.

Select a parameter, and select 

[Functional List Code] on the 

[Edit] menu. 

Click [Parameter 

Check], and check 

the edited data.

Select the position of the added 

model which will be displayed in 

FR Configurator model list by 

clicking [Upper] and [Lower], and 

click [OK].
14



Editing and changing an existing model
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3.2 Editing and changing an existing model 

1) Select [Folder...] from the [File] menu to display the "Select 
a editing folder" window. 
Specify the folder containing the parameter file, and click 
[OK]. (Refer to page 6)

2) Select [Edit] on the [Model] menu to display the "Edit" 
window. (Refer to page 7)
Select a model and a capacity to be edited.

3) To add or edit a model capacity, select [Model Info...] on 
the [Edit] menu to display the "Model Information Editing" 
window. (Refer to page 9)
Add or edit the model name, capacity, rated current, 
communication resource, and plug-in option settings.
Click [Add] to add a capacity in the "Rated Capacity 
Adding" window, or click [Edit] to edit a capacity in the 
"Rated Capacity Editing" window.

4) Edit parameters from the main window.
(Refer to page 3 for setting items of parameters.)
To edit the functional list code of each parameter, select 
[Functional List Code...] on the [Edit] menu, and change 
settings on the "Functional List Code" window. 

Specify the folder containing the 

parameter file.

Parameter files in the 

folder are displayed.

Select the model for edit

Select the capacity 

of the model

Set the available options.

Set the capacity, rated 

current, and capacity 

name of the each model.

Set the available 

communication route. 

Click [Add] or [Edit] to 

display the window.

Edit parameters

Edit the functional list 

code of the selected 

parameter.

Select a parameter, and select 

[Functional List Code] on the 

[Edit] menu. 
15



Editing and changing an existing model
5) After editing parameters, click [Parameter Check] to sort 
parameter numbers and check each item for an error. 
When a parameter with an error exists, the parameter is 
displayed in red. Correct the setting for the parameter.
(Refer to page 3)

6) After completing the parameter check, display the 
"Position to Add the Type Information" window by selecting 
[Save...] on the [File] menu. (Refer to page 12)
Select the position for the edited model in FR Configurator 
model list, and click [OK]. Editing of the new model is 
completed.

7) The created parameter files can be also used in a different 
computer by exporting and importing them.

Click [Parameter 

Check], and check 

the edited data.

Select the position of the added 

model which will be displayed in 

FR Configurator model list by 

clicking [Upper] and [Lower], and 

click [OK].
16



Deleting a registered model
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3.3 Deleting a registered model

1) Select [Folder...] from the [File] menu, and display the 
"Select an editing folder" window. 
Specify the folder containing the parameter file to be 
deleted, and click [OK]. (Refer to page 6)

2) Select [Delete...] on the [Model] menu, and display the 
"Delete" window. (Refer to page 7)
Select a model and a capacity for deleting.

3) Select [Save] from the [File] menu. Deletion of the model is 
completed.

POINT
· Before deleting the data, make sure to backup the folder containing the parameter file. If a model is deleted by

mistake, you can overwrite the parameter file using the backup data. 

Specify the folder containing the 

parameter file.

Parameter files in the 

folder are displayed.

Select the model for deletion.

Select the capacity  

for deletion.
17
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REVISIONS
*The manual number is given on the bottom left of the back cover.
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Aug. 2009 IB(NA)-0600405ENG-A First edition

(For Version 1.01)
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