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How to read this guide
The following explains the symbols used in this guide and their descriptions.

Terms
The following shows the terms and abbreviations, such as function blocks, used in this guide.

Symbol Description Example

This symbol describes the 
information useful to know.

Select [View] → [Comment] (  key +  key).

The comment display/hide setting can be switched.

This symbol describes content 
that must be noted in 
operation.

When dismounting the module, the power must be 
turned off.

Buttons on the screen button

[ ]
Menu names on the menu bar 
([ ] → [ ] shows drop-down 
menus.)

Select [Project] → [New].

Keys on the keyboard key

( )

Another procedure 
corresponding to a drop-down 
menu (icons and keys on the 
keyboard)

Select [Compile] → [Rebuild All]. ( )

Term or abbreviation Description

FB Abbreviation of Function Block.

FB library

A collection of FB parts that are usable in GX Works3. In GX Works3, "Module FB", 
modularization of processing of each module, is available.

MELSOFT library releases the sample library for various modules/partner equipment. 
MELSOFT library can be used from Mitsubishi Electric FA site.

GX Works3 Engineering software that can perform from system design to maintenance. Generic 
product name of product type SWnDNC-GXW3 (n=Version No.)

Point
Ctrl F4

Caution
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Related manuals
This guide offers the basic procedures to introduce FB.
Refer to the manuals in the following table as required.
The manuals can be downloaded for free from Mitsubishi Electric FA site.

Manual name Manual number Description

GX Works3 Installation 
Instructions BCN-P5999 Explains the introduction of GX Works3, such as 

the operating environment of GX Works3.

GX Works3 Operating Manual SH-081215ENG

Explains the functions of GX Works3, such as 
system configurations, parameter settings of 
GX Works3 and the operation method of online 
functions, etc.

MITSUBISHI ELECTRIC FA 
Library BCN-P5999-0053J

Explains how to use a parts collection (MELSOFT 
Library) that can easily use PLC-related modules 
or HMI, and various device equipment connected 
to them.
2



Introduction
This guide explains clearly the basic introduction procedures for first-time FB (Function Block) users.
This guide helps you understand easily how to use FB.

Caution

This guide explains how to use FB Library and how to create FB using simple examples.
When designing/operating systems, read the manuals of the CPU module and other modules that
will be used, and use them safely.

Quick start 
guide

What is FB?

How to 
use FBs?

How to 
create an FB?

• Explains the overview of FB.

• Explains the preparations required prior to using 
  an FB library. 
• Explains the procedures for creating a simple 
  sequence program using an FB library.

• Explains the procedures for creating an FB with 
  examples.

• Explains the advantages and features of using FBs.

Programmable Controller Engineering Software
MELSOFT GX Works3 
FB Quick Start Guide

FBs P.4:

Using FB Libraries P.11:

Creating FBs P.35:
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FBs
FB is an abbreviation for a Function Block that is designed to convert a ladder block, which is used
repeatedly in a sequence program, into a component (FB) to be utilized in a sequence program.
This not only increases the efficiency of program development but also reduces programming 
mistakes to improve program quality.

Sequence program

Converting into Components

What does it mean when a sequence program is converted into a component?
The following section explains the process to convert a simple program into a component.

[Example] A program in which the output signal (Y12) is turned ON when the input signal (X1) is 
turned ON 12 times.

Converted into 
a component FB

Input

Input label Output label

Output

X1

X1
( Y12 )

[ >= D1  K12 ] (   Y12   )

[ INCP D1 ]

Internal device

Input
label

i_Count

Count_Num1
i_Count o_C_UP

Count_Num1
i_Count o_C_UP

Create input/output ladders (Setting parameter).

Output 
label

o_c_up

i_Count

[ >= m_Cnt  K12 ] (  o_C_UP  )

[ INCP  m_Cnt ]

Internal label

Count process 1

(3) When changing to an FB (4) Inserting the FB into a program

Input label Output label

(1) Program to be converted 
into a component

(2) Divide into input and output. In addition, 
replace the internal device with an internal label.
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Advantages of Using FBs

This section introduces advantages of creating programs by using FBs.

■ Easy programming
A sequence program can be created simply by pasting in an FB. This significantly reduces the 
program development man-hours. (Programming is made easier using FB libraries provided by
Mitsubishi Electric Corporation.)

■ Easy reading
Using an FB creates a simple program with only a 'box' (FB), inputs, and outputs to create an easy-
to-read sequence program.

Simply select an FB from the Function Block
Selection window and drag and drop to insert it.

Simply select an FB from the Function Block
Selection window and drag and drop to insert it.
5



■ Reusing
Converting a standard program into a component allows the program to be reused any number of times.
As a result, operations such as copying a sequence program and modifying devices becomes 
unnecessary.

■ Improving quality
Converting a standard program into a component as an FB to reuse the program allows 
development of programs of consistent quality, without relying on the technical skill of the program 
developers.
When developers A and B are developing sequence programs for different devices, using the same 
FB for the common processing enables creating sequence programs of consistent quality.

Converted into 
a component

FB for start 
control

FB for start 
control

FB for start 
control

FB for start 
control

Common 
FB

Individual process BIndividual process B

Individual process AIndividual process A

Common FBCommon FB

Common FBCommon FB

Developer A

Developer B
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■ Protecting assets
By setting up a block password, the created FB can be protected so that it cannot be viewed.
Once the block password has been set, the following operations are restricted:
• Displaying and editing of FB program
• Editing of FB local label
• Copying to other project

Setting Block Password
7



FB Libraries

An FB library is a collection of FB parts usable in GX Works3. Using these enables easy settings and 
operations of MELSEC iQ-R and MELSEC iQ-F Series partner products. 

<Example of iQ-R>

<Example of partner product>

CPU module

Rotary encoder, etc.

Module FB

FB FB FB

Setting of upper/lower limit 
value of a ring counter

Counter 
start/stop

Pulse measurement 
start/stop

• • •

Ethernet 

CC-Link

Laser displacement 
sensor

Partner product lineup

RFIDVision sensor

MELSOFT Library

FB

Vision 
sensor

FB

RFID

FB

Laser displacement 
sensor

• • •

HUB
8



■ FB Library Lineup
"Module FB" and "MELSOFT Library", etc. are in FB libraries.

FB libraries supporting various functions are released periodically.

■ How to Obtain FB Libraries
Contact your local Mitsubishi Electric representative to obtain the MELSOFT Library.

Module FB MELSOFT Library
• CPU • Data analysis
• Analog input/output module • RFID
• Counter module • Laser displacement sensor
• Positioning module • Vision sensor

…
…

…
…
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Development Tool

The following development tool is required to develop sequence programs using FBs.

FB Specifications and Precautions

For each FB library, refer to the restrictions and precautions of the reference manuals.

Tool Name Version

GX Works3 Supported from the first article (However, for MELSEC iQ-F Series, 
supported from Ver. 1.007H or later)

Point

Depending on the FB library, supporting versions of GX Works3 may differ.
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Using FB Libraries
This chapter explains the procedure to create a program by using an FB library.

Programs to be Created P.12

Creating New Projects P.15

Using Module Labels P.18

How to Use Module FB P.20

Setting Names of the Pasted FBs P.22

Creating Input and Output Ladders P.23

Performing Convert/Rebuild All P.26

Writing and Executing Sequence Programs P.27

Confirming Operations P.28

How to Use MELSOFT Library P.31
1111



Programs to be Created

This section explains how to use FB libraries using an example of reading pulse measurement 
values from the following module configuration.

[Example] Read the pulse measurement value of 1 phase 1 input into D10 from the pulse input to the 
input terminal when the switch (X10) is turned ON.

Point

When a rotary encoder is used, actual wiring is as shown in the figure below. 
For details, refer to MELSEC iQ-F FX5U User's Manual (Hardware).

Pulse 
(X0)

Rotary encoder, etc. Switch
 (X10)

FX5U-32MT/ES
Measuring speed; A maximum of 200kHz
Use CH1.

S/S

0 V

X0

24 V

L 24 V

Z phase

B phase

A phase

0 V

N

Fuse

Class D grounding

FX5U-32MT/ES

1.5kΩ

24 V DC

+

Rotary encoder
12
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Point

In the example, the parameters are set as follows. 
For details, refer to MELSEC iQ-F FX5 User's Manual (Application).

Setting of [High-Speed I/O]

Setting of [Input Response Time]

(4) Set [Pulse Input Mode] to [1-Phase 
      1-Input (SW Up/Down Switch)].

(3) Set [Use/Do Not Use Counter] 
      to [Enable].

(2) Select [High Speed Counter].

(1) In the Navigation window, 
     select [Parameter] → [FX5UCPU] 
     → [Module Parameter] 
     → [High Speed I/O].

(2) Set the input response time of X0 to 
      [No Setting].

(1) In the Navigation window, 
     select [Parameter] → [FX5UCPU] 
     → [Module Parameter] 
     → [Input Response Time].



With the use of FB libraries, the following program is created.

Create this program in the following section.

When the switch (X10) is turned ON, FB for reading pulse measurement data of the 
specified channel

Store the pulse measurement value in D10.

×10
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Creating New Projects

This section explains how to create a new project by starting GX Works3.

Operating procedure

1. Select [Start] → [All Programs] → [MELSOFT] → [GX Works3] → 
[GX Works3].

2. After starting, the GX Works3 main screen is displayed.
 

Menu bar

Navigation window

Element Selection 
window 

Project view
15



3. Select [Project] → [New].

4. The "New" window is displayed.

5. A project tree and the ladder screen are displayed.

(1) Select the series (FX5CPU).

(2) Select the module to use (FX5U). 

(3) Select the programming language 
     (Ladder) to be developed.
(4) Click the                button. 

(1) A project tree is displayed in 
     the Project view of the 
     Navigation window.  

(3) The Element Selection 
      window is displayed.

(2) The ladder screen is 
      displayed.
16



Point

If the Navigation window is not displayed, use the following procedure to display it.

If the Function Block Selection window is not displayed, use the following procedure to
display it.

(1) Select [View]→[Docking Window]. 

(2) Select [Navigation].

(1) Select [View]→[Docking Window].

(2) Select [Element Selection]. 
17



Using Module Labels

Module Labels are pre-defined labels such as input signals and buffer memories of the modules to 
be used. With the use of module labels, it is possible to create easy to reuse programs without 
concern to the internal addresses of the module.
Module labels are installed together with GX Works3 and cannot be added or rewritten by users.

Operating procedure
Make the module label usable in the project.

(1) In the Element Selection window, 
      right-click [Module] → [Module Label]
      → [FX5UCPU].

(2) Click [Add Module Label].

(3) The module label of FX5UCPU can be used.
18



Point

The module label of the PLC can be registered also when creating a new project.
Settings can be made from the confirmation window displayed when creating a new project.

Point

The module label can be used in an ordinary program like a global label.

PLC selected at the time of creation

Set "Use Module Label" to "Yes".

Click the                  button.

Drag & drop
Easy to understand as 
it is well-commented
19



How to Use Module FB

The Module FB can be used by drag & drop from the Element Selection window or the project view 
to the program window.

Operating procedure

1. From the Element Selection window, the Module FB list is displayed by 
[Module] →  [Module FB] → [FX5UCPU].
20



2. Drop [M+FX5UCPU-Counter_PulseMeasure] in the program window.

3. The "FB Instance Name" window is displayed.

The details of the input method is described in " Setting Names of the 
Pasted FBs" on the next page.

Drop
21



Setting Names of the Pasted FBs

When an FB library is pasted to the program window, a window to input the name of the pasted FB 
(FB instance name*) is displayed.

* Instance name is to distinguish the FB.
A temporary name is automatically set to the instance name. To use the name as it is, close the 

window by clicking   . Make sure that the same name does not exist in the same program 
when changing the name.
In this guide, it is set to the default.

Operating procedure

1. Input the FB instance name.

2. The FB is pasted to the program window.

Point

When inputting an instance name, be careful of the following points.
• Case-sensitive
• The maximum length for an instance name is 16 half-width characters.
• There are some symbols, such as !, ?, etc., that cannot be used.

For details, refer to GX Works3 Operating Manual.

An error occurs when clicking  with the following setting.

(1) Input the FB instance name
     ("M_FX5UCPU_Counter_PulseMeasure_00A_1" in the example).

(2) Click the            button. 

(When using letters that cannot be used)
22



Creating Input and Output Ladders

Create the input ladder section and the output ladder section of the pasted FB, and complete the 
program.
Insert FB bit input from the far left of the circuit screen like an ordinary ladder program. (Insert to the 
far right in the output part.)

Insert the module label applicable to the FB. The module label can be inserted by drag & drop from 
the Element Selection window.

Insert a contact (X10) 
and input to B:i_bEN.

Select 
[FX5CPU] 
here.
23



Insert FB word device input to the far left of the FB (To the far right for output).

Point

The module label can be also inserted by direct input.

When the cursor is 
on the circuit screen, 
the direct input screen is 
displayed by inputting 
instructions or devices 
by keyboard.
24



Repeat these procedures and input the circuit in the figure below.

Number Description

(1) FB execution command: X10

(2) Module label of module applicable to Module FB: FX5CPU

(3) Target CH: K1 (1CH)

(4) Execution status

(5) Normal completion

(6) Measured pulse value update flag

(7) Measured pulse value

(8) Error completion

(9) Error code

(1)

(2)

(3)

(7)

(8)

(9)

(4)

(5)

(6)

Input circuit section Output circuit section
25



Performing Convert/Rebuild All

Conversion is required to execute the created and completed program.
Rebuild all for the first time when the program is created.
The "convert" operation converts only the parts that have changed since the previous conversion.
The procedure to rebuild all is described as follows.

Operating procedure

1. Select [Convert] → [Rebuild All].

2. The following message is displayed.

3. All programs are converted and the results are displayed in the output window.

Point

When pasting a number of FBs that use device output with index modification (like OUT 
Y0Z9) internally, a double coil warning occurs at time of conversion, but there is no issue of 
functionality.

This completes the program creation.

Click the              button.
26



Writing and Executing Sequence Programs

Write the created program to the CPU module and run the program.

Operating procedure

1. Select [Online] → [Write to PLC].

2. The "Online Data Operation" window is displayed.

3. Writing to the PLC is performed.

Preparation to run the created program is now completed.

(2) Click the               button.

(1) Click the                         button.

(3) After finishing writing, click the                button.
27



Confirming Operations

Confirm the created program's operations.

Operating procedure

1. Select [Online] → [Monitor] → [Start Monitoring].

2. Turn the switch (X10) ON and confirm that the pulse measurement values 
have been read.

Turn the 
switch(X10) ON.

The present value of the pulse 
measurement value is displayed.
28



Point

Double-clicking the FB in the sequence program on the screen enables monitoring of the
sequence program status in the FB.

This concludes the explanation of how to use 
Module FBs.
29



Point

■How to use the reference manual
Confirm the details of the Module FB and MELSOFT Library in the reference manual.
Referable by registering MELSEC iQ-F FX5CPU Module FB Reference into e-Manual in 
advance. Various e-Manuals are available from your local Mitsubishi Electric 
representative.

The procedures to refer the reference manual by e-Manual Viewer are explained below.

Operating procedure

1. Select the FB you want to display the reference manual and right 
click → [Help].

2. e-Manual Viewer starts up and jumps automatically to the position 
of the appropriate FB.
30



How to Use MELSOFT Library

Before using an FB library, contact your distributors to obtain it.
(MELSOFT Library is not installed by installing GX Works3.)
If already registered into GX Works3, the following work becomes unnecessary.

Operating procedure

1. As the file obtained from your distributor is a zip file (example "fb-
dataanalysis_r.zip"), unzip the file. Then "DataAnalysis_R.mslm" is created.

2.  In GX Works3, open the project and select [Project] → [Library Operation] → 
[Register to Library List] → [Library].

Click [Library].
31



3. The confirmation dialog is displayed.

4. Select the "DataAnalysis_R.mslm" file decompressed earlier and open it.

5. The "Library" item is added to the "Library" on the Element Selection window.

Click the            button.

Select the library file to add.

Click the               button.

The "Library" item is added.
32
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6. With that, the library has been added. The added library can be used by drag 
& drop as with the Module FB.

7. To upgrade the library with an updated version, after deleting the library once, 
execute again from the operating procedure 1 and import.

With that, the preparation for using MELSOFT 
Library is ended.

Added FB list

Right-click the library you want to delete 
and "DataAnalysis_R" library can be deleted 
by [Delete from Library List].



MEMO
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Creating FBs
This chapter explains the procedure to create a new FB.

Create an FB with the following procedures.

FBs to be Created P.36

Creating New Projects P.37

Creating New Data P.39

Setting Labels P.41

Creating FB Programs P.43

Performing Convert/Rebuild All P.44

Protecting Created FBs P.46

How to Use User Libraries P.48

Techniques for Creating FBs P.51
3535



FBs to be Created

This section explains the procedure to create an FB from a simple program.

[Example] When input X1 is turned ON 12 times, output Y12 is turned ON.

Creating an FB for the above program and pasting it to the sequence program creates a simple 
program with only an FB, an input, and an output.

Create an FB in the following section.

[Timing chart]

Input (X1)

D1

Output (Y12)

[Sequence program]

1 2
11 12

Input Output

X1

(   Y12   )

[ INCP D1 ]

[>= D1  K12 ]

[Sequence program to which FB is pasted]

Input Output

X1
( Y12 )Count_Num_1

i_Count o_C_UP

When the input (X1) 
is turned ON 12 times,

The output (Y12) 
is turned ON.
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Creating New Projects

This section explains how to create a new project by starting GX Works3.

Operating procedure

1. Select [Start] → [All Programs] → [MELSOFT] → [GX Works3] → 
[GX Works3].

2. After starting, the GX Works3 main screen is displayed.

Menu bar

Navigation window

Element Selection 
window 

Project view
37



3. Select [Project] → [New].

4. The "New" window is displayed.

5. A project tree and the ladder screen are displayed.

(1) Select the series (FX5CPU).

(2) Select the module to use (FX5U). 

(3) Select the programming language 
     (Ladder) to be developed.
(4) Click the                button. 

(1) A project tree is displayed in 
     the Project view of the 
     Navigation window.  

(3) The Element Selection 
      window is displayed.

(2) The ladder screen is 
      displayed.
38



Creating New Data

After a GX Works3 project is created, create a new data file 
("Count_Num" is used as an FB name in this section).

Operating procedure

1. In the Navigation window, select [FB/FUN], and right-click and select 
[Add New Data] from the shortcut menu.

2. The "New Data" window is displayed.

Point

When entering an FB name, be careful of the following points.
• Case-sensitive
• The maximum number of characters for the FB name is 256.

(3) Select the program language to be 
     developed (ladder).

(2) Input "Count_Num" as the FB name 
     to be created.

(1) Data type to be created
     Select "Function Block".

(4) Click the              button.
39



3. The newly created FB (Count_Num) is added to the Navigation window and 
the Element Selection window.

"Count_Num" is added.
40



Setting Labels

Because FBs are utilized by being converting into components, devices are not used and input 
labels, output labels, and internal labels are used to create a program.
First, categorize the devices of the sequence program into, input device, output device, and internal 
device.
Next, set each label for the categorized devices.

 

The labels corresponding to the actual devices in the FB that is to be created are as shown in the 
following tables.

Set the input label, output label, and internal label to be used in the FB in the following section.

Device type Device name Label type (Class) Label name Data type

Input device X1 Input label 
(VAR_INPUT) i_Count bit

Output device Y12 Output label 
(VAR_OUTPUT) o_C_Up bit

Internal device D1
Internal label 

(VAR)
m_Cnt word [signed]

: Input device
  (Device that becomes 
  an input label)

: Output device
  (Device that becomes 
  an output label)

: Internal device
  (Device that becomes 
  an internal label) 
41



Operating procedure

1. Double-click "Local Label" of the added FB and display the Function/FB Label 
Setting screen.

 

2. The Function/FB Label Setting screen is displayed.

3. Set the labels as follows.

Point

The number of development man-hours can be reduced by creating the internal labels that

are used normally, as design data with Microsoft® Excel® in advance and entering them by
exporting and importing.

Double-click "Local Label".

Input label
Output label
Internal label
42



Creating FB Programs

This section explains how to create a sequence program in an FB using the set labels.

Operating procedure

1.  In the Navigation window, select [FB/FUN]→[FBFILE]→[Count_Num], and 
double-click [Program Body].

2. The "Count_Num[FB][LD]" window is displayed.

3. Create an FB sequence program.

Sequence program of the FB to be created is described as follows.

Double-click [Program Body].
43



Performing Convert/Rebuild All

In order to operate FBs, it is necessary to convert/rebuild all.
The procedures to rebuild all are explained below.

Operating procedure

1. Select [Convert] → [Rebuild All].

2. The following message is displayed.

3. All the programs are converted and the results are displayed in the Output 
window.

Click the              button.
44



The sequence program created by pasting the created FB is as follows.

This completes the creation of a new FB.
For the procedures to use created FB, refer to " How to use Module FB"

and later sections in "  Using FB Libraries".

When the input (X1) is 
turned ON 12 times,

The output (Y12) is 
turned ON.
45



Protecting Created FBs

Operating procedure

1. In the Navigation window, select [FB/FUN] → [FBFILE] → [Count_Num].
 

A created FB can be protected by setting up a 
block password.
Outflow of technological know-how can be 
prevented by using a password, as the 
password protection disables opening of 
programs in the FB.

This section explains how to set up a block 
password for the created FB.

Caution

If you forget the password, you cannot open the program in the FB.
Do not lose the password.

(1) Right-click the created FB 
      "Count_Num".

(2) Select [Block Password Setting]
46



2. The "Block Password Setting" window is displayed.

3. The "Register Password" window is displayed.
 

4. The block password is set to "Count_Num".

Point

■Locking an FB by using a block password is activated when the project is re-opened.
■The FBs for which the block passwords were set are displayed in the Project view as

follows.

■A block password can be changed by resetting the password. In this case, unlock the
password prior to change.

Click the                  button.

2) Click the              button.

1) Set "Password" and 
     "Re-enter Password".

Click the               button.

Key marks are added to the FB icons.
47



How to Use User Libraries

FBs can be utilized in other projects.
When FBs are utilized in other projects, it is necessary to register in the User Library.

This section explains how to use FBs in other projects by using the FB "Count_Num" created in this 
guide as an example.

Operating procedure

1. In the file to be registered in the library, select [Project] → [Library Operation] 
→ [Export Library].

 

2. The confirmation screen is displayed.

Click the              button.
48



3. Save the file with a new name.

4. Start up the project to use the saved user library and register the user library.

Here, the name is "MyLibrary".

(1) Right-click [User Library] 
      → Click [Register to Library List] 
      → [User Library].

(3) Select the library file created in 3.

(2) Click the            button.

(4) Click the               button.
49



5. "Count_Num" was registered in the User Library.
50



Techniques for Creating FBs

This section introduces techniques for creating FB sequence programs.

1. To transfer multiple bits to a word label
Multiple bits can be transferred to a word label by using BSET and BRST instructions and setting up 
ON/OFF information for each bit of the target word.

 

2. To use index registers in an FB
When using index registers in an FB, add a save program and restore program for the index 
registers to protect them.

[Example of creation]
The following shows an example of saving index registers Z7, Z8, and Z9 in the FB prior to executing 
a program and restoring the index when the program ends.

 

Label name Type Purpose

int_Z_tmp [0] Word For saving index register Z9

int_Z_tmp [1] Word For saving index register Z8

int_Z_tmp [2] Word For saving index register Z7

···
FB Program

···
51



Microsoft, Microsoft Access, Excel, SQL Server, Visual Basic, Visual C++, Visual Studio, Windows, 
Windows NT, Windows Server, Windows Vista, and Windows XP are either registered trademarks or 
trademarks of Microsoft Corporation in the United States and/or other countries.
Ethernet is a registered trademark of Fuji Xerox Co., Ltd. in Japan.
The company names, system names and product names mentioned in this manual are either 
registered trademarks or trademarks of their respective companies.

In some cases, trademark symbols such as 'TM' or '®' are not specified in this manual.
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Avenida Adelino Cardana, 293, 21 andar, Bethaville, Barueri SP, Brasil
MITSUBISHI ELECTRIC EUROPE B.V. German Branch
Mitsubishi-Electric-Platz 1, 40882 Ratingen, Germany
MITSUBISHI ELECTRIC EUROPE B.V. UK Branch
Travellers Lane, UK-Hatfield, Hertfordshire, AL10 8XB, U.K.
MITSUBISHI ELECTRIC EUROPE B.V. Irish Branch
Westgate Business Park, Ballymount, Dublin 24, Ireland
MITSUBISHI ELECTRIC EUROPE B.V. Italian Branch
Centro Direzionale Colleoni - Palazzo Sirio, Viale Colleoni 7, 20864 Agrate Brianza (MB), Italy
MITSUBISHI ELECTRIC EUROPE, B.V. Spanish Branch
Carretera de Rubi, 76-80-Apdo. 420, E-08190 Sant Cugat del Valles (Barcelona), Spain
MITSUBISHI ELECTRIC EUROPE B.V. French Branch
25, Boulevard des Bouvets, 92741 Nanterre Cedex, France
MITSUBISHI ELECTRIC EUROPE B.V. Czech Branch, Prague Office
Pekarska 621/7, 155 00 Praha 5, Czech Republic
MITSUBISHI ELECTRIC EUROPE B.V. Polish Branch
ul. Krakowska 48, 32-083 Balice, Poland
MITSUBISHI ELECTRIC EUROPE B.V. (Scandinavia)
Hedvig Mollersgata 6, 223 55 Lund, Sweden
MITSUBISHI ELECTRIC (RUSSIA) LLC St. Petersburg Branch
Piskarevsky pr. 2, bld 2, lit “Sch”, BC “Benua”, office 720; 195027 St. Petersburg, Russia
MITSUBISHI ELECTRIC TURKEY A.S Umraniye Branch
Serifali Mahallesi Nutuk Sokak No:5, TR-34775 Umraniye/Istanbul, Turkey
MITSUBISHI ELECTRIC EUROPE B.V. Dubai Branch
Dubai Silicon Oasis, P.O.BOX 341241, Dubai, U.A.E.
ADROIT TECHNOLOGIES 
20 Waterford Office Park, 189 Witkoppen Road, Fourways, South Africa
MITSUBISHI ELECTRIC AUTOMATION (CHINA) LTD.
Mitsubishi Electric Automation Center, No.1386 Hongqiao Road, Shanghai, China
SETSUYO ENTERPRISE CO., LTD.
6F, No.105, Wugong 3rd Road, Wugu District, New Taipei City 24889, Taiwan
MITSUBISHI ELECTRIC AUTOMATION KOREA CO., LTD.
7F to 9F, Gangseo Hangang Xi-tower A, 401, Yangcheon-ro, Gangseo-Gu, Seoul 07528, Korea
MITSUBISHI ELECTRIC ASIA PTE. LTD.
307 Alexandra Road, Mitsubishi Electric Building, Singapore 159943
MITSUBISHI ELECTRIC FACTORY AUTOMATION (THAILAND) CO., LTD.
12th Floor, SV.City Building, Office Tower 1, No. 896/19 and 20 Rama 3 Road, 
Kwaeng Bangpongpang, Khet Yannawa, Bangkok 10120, Thailand
MITSUBISHI ELECTRIC VIETNAM COMPANY LIMITED
Unit 01-04, 10th Floor, Vincom Center, 72 Le Thanh Ton Street, District 1, Ho Chi Minh City, Vietnam
PT. MITSUBISHI ELECTRIC INDONESIA
Gedung Jaya 8th Floor, JL. MH. Thamrin No.12, Jakarta Pusat 10340, Indonesia
MITSUBISHI ELECTRIC INDIA PVT. LTD. Pune Branch
Emerald House, EL-3, J Block, M.I.D.C., Bhosari, Pune-411026, Maharashtra, India
MITSUBISHI ELECTRIC AUSTRALIA PTY. LTD.
348 Victoria Road, P.O. Box 11, Rydalmere, N.S.W 2116, Australia

Tel/Fax

Tel  : +1-847-478-2100
Fax : +1-847-478-2253
Tel  : +52-55-3067-7512

Tel  : +55-11-4689-3000
Fax : +55-11-4689-3016
Tel  : +49-2102-486-0
Fax : +49-2102-486-7780
Tel  : +44-1707-28-8780
Fax : +44-1707-27-8695
Tel  : +353-1-4198800
Fax : +353-1-4198890
Tel  : +39-039-60531
Fax : +39-039-6053-312
Tel  : +34-935-65-3131
Fax : +34-935-89-1579
Tel  : +33-1-55-68-55-68
Fax : +33-1-55-68-57-57
Tel  : +420-255-719-200

Tel  : +48-12-347-65-00

Tel  : +46-8-625-10-00
Fax : +46-46-39-70-18
Tel  : +7-812-633-3497
Fax : +7-812-633-3499
Tel  : +90-216-526-3990
Fax : +90-216-526-3995
Tel  : +971-4-3724716
Fax : +971-4-3724721
Tel  : +27-11-658-8100
Fax : +27-11-658-8101
Tel  : +86-21-2322-3030
Fax : +86-21-2322-3000
Tel  : +886-2-2299-2499
Fax : +886-2-2299-2509
Tel  : +82-2-3660-9569
Fax : +82-2-3664-8372
Tel  : +65-6473-2308
Fax : +65-6476-7439
Tel  : +66-2682-6522
Fax : +66-2682-6020

Tel  : +84-28-3910-5945
Fax : +84-28-3910-5947
Tel  : +62-21-31926461
Fax : +62-21-31923942
Tel  : +91-20-2710-2000
Fax : +91-20-2710-2100
Tel  : +61-2-9684-7777
Fax : +61-2-9684-7245
New publication, effective  Feb. 2019
Specifications subject to change without notice.NG-C  1902(MEE)
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