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How to read this guide
The following shows the symbols used in this Quick start guide with descriptions and examples.

Terms
The following explains the terms and abbreviations, such as FB, used in this Quick start guide.

Symbol Description Example

This symbol explains information 
you need to know.

Select [View] → [Comment] (  key +  key). 
The comment display/hide setting can be switched.

This symbol describes content 
that must be noted in operation.

When dismounting the module, the power must be 
turned off.

Buttons on the screen  button

[ ]

Menu names on the menu bar

([ ] → [ ] shows drop-down 
menus.)

Select [Project] → [New].

Keys on the keyboard  key

( )

Another procedure 
corresponding to a drop-down 
menu (icons and keys on the 
keyboard)

Select [Compile] → [Rebuild All]. ( )

Term or abbreviation Description

FB Abbreviation of Function Block.

FB library 
A collection of FB parts that are usable in GX Works2 (Simple Project). 
Sequence programs to use MELSEC-Q/L series modules and partner 
products can be easily created.

GX Works2

A programming tool for the programmable controller. 
Programming using FB libraries is possible. 
Generic product name for SWnDND-GXW2-E and SWnDNC-GXW2-E. 
(n = version) 

GX Developer
A programming tool for the programmable controller. 
Product name for SWnD5C-GPPW-E. (n = version) 

Point
Ctrl F4

Caution
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Related manuals
This Quick start guide explains the basic procedures to introduce FB.

Refer to the manuals in the following table as required.

Manual name
Manual number
(Model code)

GX Works2 Version 1 Operating Manual (Common)
Explains the system configuration of GX Works2 and the functions common to 
Simple project and Structured project such as parameter setting, operation 
method for the online function.

 (Sold separately.)

SH-080779ENG

(13JU63)

GX Works2 Version 1 Operating Manual (Simple Project)
Explains methods for such as creating and monitoring programs in Simple project 
of GX Works2.

 (Sold separately.)

SH-080780ENG

(13JU64)

GX Works2 Version 1 Operating Manual (Simple Project, Function Block)
Explains methods for such as creating function blocks, pasting function blocks to 
sequence programs, and operating FB library in Simple project of GX Works2.

 (Sold separately.)

SH-080984ENG

(13JU72)
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Introduction
This Quick start guide explains the basic procedures for first-time FB (Function Block) users.

This guide will help with understanding how to use FBs.

Caution

This Quick start guide explains how to use FB libraries and how to create FBs using simple

examples.

When designing/operating systems, read the manuals of the CPU module that is to be used, that

in use, and use them safely.

Quick start guide

What is FB?

How to use 
FBs?

How to 
create an 
FB?

Explains the overview of FB.
Explains the advantages and features of using FBs.

Explains the preparations required prior to use an 
FB library.
Explains the procedures for creating a simple 
sequence program using an FB library.

Explains the procedures for creating an FB with 
examples.

FBs P.4:

Using FB Libraries P.11:

Creating FBs P.28:
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FBs
FB is an abbreviation for a Function Block that is designed to convert a ladder block, which is used 

repeatedly in a sequence program, into a component (FB) to be utilized in a sequence program.

This not only increases the efficiency of program development but also reduces programming 

mistakes to improve program quality.

Sequence program

Converting into Components

What does it mean when a sequence program is converted into a component?

The following section explains the process to convert a simple program into a component.

Example) A program in which the output signal (Y12) is turned ON when the input signal (X1) is 

turned ON 12 times.

Converted into 
a component

FB

Input

Input label Output label

Output

X1

X1

（ Y12 ）

（ Y22 ）

X2

［＞＝ D1  K12］ （   Y12   ）

［ INCP D1 ］

Internal device

Input

label

i_Count

Count_Num1

i_Count o_C_UP

Count_Num2

i_Count o_C_UP

Create input/output ladders (Setting parameter).

i_Count o_C_UP

Count_Num

Output 

label

o_c_up

i_Count

［ ＞＝ m_Cnt  K12 ］ （  o_C_UP  ）

［ INCP  m_Cnt ］

Internal label

Count process 2

Count process 1

Program to be converted into a 

component

When changing to an FB

Divide into input and output. In addition, 

replace the internal device with an internal label.

Pasting the FB to a program
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Advantages of Using FBs

This section introduces advantages of creating programs by using FBs.

■ Easy programming

A sequence program can be created simply by pasting in an FB. This significantly reduces the 

program development man-hours. (Programming is made easier using FB libraries provided by 

Mitsubishi Electric Corporation.)

■ Easy reading

Using an FB creates a simple program with only a 'box' (FB), an input, and an output to create an 

easy-to-read sequence program.

Only select an FB from the Element Selection 
window and drag and drop it to paste.
Only select an FB from the Element Selection 
window and drag and drop it to paste.
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■ Reusing

Converting a standard program into a component allows the program to be reused any number of 

times.

As a result, operations such as copying a sequence program and modifying a device, which had 

often been required in the past, will be unnecessary.

■ Improving quality

Converting a standard program into a component as an FB to reuse the program allows 

development of programs of consistent quality, without relying on the technological skill of the 

program developers.

When developers A and B are developing sequence programs for different devices, using the same 

FB for the common processing enables to create consistent quality of sequence programs.

Converted 

into a component

FB for 

start control

FB for 

start control

FB for 

start control

FB for 

start control

Common 

FB

Individual process BIndividual process B

Individual process AIndividual process A

Common FBCommon FB

Common FBCommon FB

Developer A

Developer B
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■ Protecting assets

By setting up a block password, the created FB can be protected so that it cannot be viewed.

Once the block password has been set, the following operations are restricted:

• Displaying and editing of FB program

• Editing of FB local label

• Copying to other project

Setting Block Password
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FB Libraries

An FB library is a collection of FB parts that are usable in GX Works2 (Simple project). Using an FB library 
enables easy setting and operation of MELSEC-Q/L modules and partner products.

<Example of MELSEC-Q/L module>

<Example of partner product>

FBs for module

 

FB FB FB

Analog input module

Analog

signal         

Level meter

Flow meter

Pressure meter

AD conversion

data read

Offset

setting

Gain

setting

Ethernet 

FBs for partner product

FB FB FB

Image read

trigger Job switching Data write

Partner product lineup

Vision sensor
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■ FB Library Lineup

In FB libraries, there are 'FBs for MELSEC-Q/L modules' and 'FBs for partner products'.

FB libraries supporting various functions are expected to be released sequentially.

■ How to Obtain FB Libraries

Please contact your local Mitsubishi Electric sales office or representative to obtain the FB Library.

FBs for MELSEC-Q/L modules FBs for partner products

-CPU -Vision sensor

-Analog input/output module

-Counter module

-Positioning module

··
··

··

··
··

··
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Development Tool

The following development tool is required to develop sequence programs using FBs.

FB Specifications and Precautions

The following specifications and precautions must be understood prior to using FBs.

1. An FB cannot be used in another FB.

2. Because an FB specific process is added when an FB is arranged, the number of steps 

increases when compared to a ladder created without using an FB.

3. FBs cannot be used in an interruption program.

4. FBs whose execution does not complete within 1 scan cannot be used in the FOR to NEXT 

instruction loops and subroutine programs.

Tool name Version

GX Works2 (Simple project) 1.12N or later

Point

Depending on the FB library, supporting versions of GX Works2 may differ.



11

①

②

③

④

⑤

⑥

⑦

⑧
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 Using FB Libraries
This chapter explains the procedure to create a program by using an FB library.

Programs to be Created P.12

Preparations Prior to Use of FB Libraries P.13

Creating New Projects P.16

Importing FB Library to Projects P.19

Pasting FBs P.21

Setting Names of the Pasted FBs P.22

Creating Input and Output Ladders P.23

Performing Conversion/Compilation P.24

Writing and Executing Sequence Programs P.25

Confirming Operations P.26

Caution

Before using FB libraries, read and agree to the terms of use indicated when obtaining an FB

library.
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Programs to be Created

This section explains how to use an FB library with an example of importing an analog value from an 

analog input module.

Example) Reading an analog value to D10 from the analog input module (Q64AD) when the switch 

(X10) is turned ON.

Program can easily be created by using an FB library as follows.

Create this program in the following section.

Q64AD QX40

Q64AD

  Mount to Slot 0.

  Current input (4 to 20mA, normal resolution)

  Use CH1.

Switch

(X10)

Current input

Pressure sensor, etc.

Point

In the example, the module is used

with the default setting.

When using in the actual system, set

data (parameter, switch setting) for

intelligent function module as

necessary.

When the switch (X10) is turned ON,
FB for reading AD conversion 

data of the specified channel

The analog value is stored in D10.
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Preparations Prior to Use of FB Libraries

Before using an FB library, contact your distributor to obtain it.

(FB libraries will not be installed when installing GX Works2.)

The following explains operation procedures using the FB library for Q64AD as an example.

Operating procedure

1. As the file obtained from your distributor is a zip format file, 
unzip "fb-q64ad_v102c.zip" and start installation.

2. The installation screen is displayed.

The screen for installation is displayed.

Follow the instructions and perform installation.

Double-click "setup.exe" in 

the unzipped folder.
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3. The following dialog is displayed when the installation is complete.

This completes the preparation prior to use of FB libraries.

Click the                 button 

to close the dialog. 
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Point

■ How to use the reference manual

For details of the installed FBs, refer to the reference manual.

The reference manual is installed along with the FB library.

The following explains how to access the reference manual.

Operating procedure

1. Select the FB for the reference manual to be displayed, and right-
click and select [Data Help] from the shortcut menu.

2. A help file in PDF format is displayed.

3. The page for the selected FB is displayed.

The reference manual for the selected FB is displayed.

Click the FB to 

be displayed.
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Creating New Projects

This section explains how to create a new project by starting GX Works2.

Operating procedure

1. Select [MELSOFT] → [GX Works2]*1 → [GX Works2] from Windows® Start*2.

*1 : Does not appear in Windows ® 8 or later.

*2 : Select [All apps] on the Start screen or [Start] → [All Programs]/[All apps].

2. After starting, the GX Works2 main screen is displayed.
  

To the next page

Navigation window

Element Selection window

Project view

Menu bar
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3. Select [Project] → [New].

4. The "New Project" dialog is displayed.

5. A project tree and the ladder screen are displayed.

Click the             button.

Select "Simple Project".

Select QCPU to be used.

Select a language to be 
used for development.

Check "Use Label" 
(always check this item).

Select "Series".
(In this example, QCPU 
(Q mode) is selected.)

A project tree is displayed in 

the Project view of 

the Navigation window.

The ladder screen is displayed.
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Point

If the Navigation window is not displayed, use the following procedure to display it. 

If the Element Selection window is not displayed, use the following procedure to display it. 

Select [Docking Window]. 

Select [Navigation].

Select [Docking Window]. 

Select [Element Selection].
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 Importing FB Library to Projects

This section explains how to import an FB library for analog input module (Q64AD) to be pasted to 

the program into a project.

Operating procedure

1. Select [Project] → [Library] → [Install]. 

To the next page.
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2. The "Import Library to Project" dialog is displayed.

3. The imported FBs are displayed in the Project view and the Element 
Selection window.

The FB library for Q64AD is now usable in GX Works2.
Next, create a program using the imported FB library.

Click the                    button.

Select "Q64AD".

Click the               button.

Check the library to import.

The imported FBs are
displayed in the Project
view and the Element 
Selection window.
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 Pasting FBs

This section explains how to drag and drop the FB to be pasted to the program window from the 
Element Selection window or Project view. (Drag and drop from the Project view is possible from GX 
Works2 1.24A or later.)

Operating procedure

1. Paste "M+Q64AD_ReadADVal" to the program window.

2. The "Input FB Instance Name" dialog is displayed.

For details of settings, refer to section '(4) Setting Names of the Pasted FBs' in the following page.

From the Element 
Selection window or 
Project view, drag and 
drop the FB to the place 
where FB will be pasted. 

Element Selection window

Project view
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 Setting Names of the Pasted FBs

When an FB library is pasted to the program window, a dialog to input a name of the pasted FB (FB 

instance name*) is displayed.

* Instance name is to distinguish the FB.

A temporary name is automatically set to the instance name. To use the name as it is, close the 

dialog by clicking . Make sure that the same name does not exist in the same program when 
changing the name.

Keep as the default in this procedure.

Operating procedure

1. Input the FB instance name.

2. The FB is pasted to the program window.

Point

When inputting an instance name, be careful of the following points.

- Case-sensitive

- Single-byte number cannot be selected for the first letter.

- The maximum number of characters for an instance name is 16 in single-byte.

An error occurs when clicking  with the following setting.

Input the FB instance name 

("ReadADVal_1" in the example).

Click the         button.

(When the first letter is a single-byte number). 
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Creating Input and Output Ladders

Create the input ladder section and the output ladder section of the pasted FB, and complete the 
program.

Refer to the following drawing and input the information.

Number Description

(1) FB execution instruction

(2) Module mounting XY address: 0

(3) Channel number: 1

(4) FB is running: ON

(5) Normal end: ON

(6) Error end: ON

(7) Stores the error code.

(8) Stores the analog value.

Input ladder section Output ladder section
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Performing Conversion/Compilation

Conversion/compilation is required to execute the completed program.

The following explains how to convert/compile all programs.

Operating procedure

1. Select [Compile] → [Rebuild All].

2. The following message is displayed.

3. All programs are converted/compiled and the result is displayed in the Output 
window.

This completes the program creation.

Point

When pasting multiple FBs that describe the device output (such as OUT Y0Z9) by using

index modification internally, duplicate coil warnings occur during compiling. However, this

is not a usage problem. 

Click the                  button.
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 Writing and Executing Sequence Programs
Write the created program to the CPU module and run the program.

Operating procedure

1. Select [Online] → [Write to PLC].

2. The "Online Data Operation" dialog is displayed.

3. Data are written to the programmable controller CPU.

Preparation to run the created program is now completed.

Point

Writing symbolic information using the Write to PLC function enables restoring to FB when

the program is read from the programmable controller. 

In addition, for universal model QCPU and L series CPU modules, program memory for the

programmable controller can be economized by changing the write destination of the

symbolic information to the CPU module built-in standard ROM.

Click the                             button.

Click the                  button.

 Click the                  button.
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 Confirming Operations

Confirm the created program's operations.

Operating procedure

1. Select [Online] → [Monitor] → [Start Monitoring]*1.

*1: When the following option is checked, select [Online] → [Monitor] → [Monitor Mode] from the 
menu.
[Tool] → [Options] → "Program Editor" → "Ladder" → "Ladder Diagram" →
"Use the Switching Ladder Edit Mode (Read, Write, Monitor, Monitor (Write))"

2. Monitoring status is displayed.

To the next page.
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3. Turn the switch (X10) ON and confirm that the analog value is read.

Double-clicking the FB in the sequence program on the screen enables monitoring of the sequence 

program status in the FB.

This concludes the explanation of how to use FB libraries.

The current analog 

value is displayed.

Turn the switch 

(X10) ON.
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①

②

③

④

⑤
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 Creating FBs
This chapter explains the procedure to create a new FB.

Create an FB with the following procedures.

FBs to be Created P.29

Creating New Projects P.30

Creating New Data P.32

Setting Labels P.33

Creating FB Programs P.35

Performing Conversion/Compilation P.36

Protecting Created FBs P.38

Utilizing FBs in Other Projects P.40

Techniques for Creating FBs P.42
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 FBs to be Created

This section explains the procedure to create an FB from a simple program.

Example) When input X1 is turned ON 12 times, output Y12 is turned ON.

Creating an FB for the above program and pasting it to the sequence program creates a simple 
program with only an FB, an input, and an output.

Create an FB in the following section.

[Timing chart]

Input (X1)

D1

Output (Y12)

[Sequence program]

1 2 11 12

(The current value of the incremented D1)

X1

D1  K12

INCP D1

Y12

Input Output

[Sequence program to which FB is pasted]

Input Output

Y12

X1

Count_Num_1

i_Count o_C_UP

When the input (X1) 

is turned ON 12 times,

The output (Y12) 

is turned ON.
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 Creating New Projects

This section explains how to create a new project by starting GX Works2.

Operating procedure

1. Select [MELSOFT] → [GX Works2]*1 → [GX Works2] from Windows® Start*2.

*1 : Does not appear in Windows ® 8 or later.

*2 : Select [All apps] on the Start screen or [Start] → [All Programs]/[All apps].

2. After starting, the GX Works2 main screen is displayed.

To the next page.

Navigation window

Element Selection window 

Project view

Menu bar
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3. Select [Project] → [New].

4. The "New Project" dialog is displayed.

5. A project tree and the ladder screen are displayed.

Click the             button.

Select "Simple Project".

Select QCPU to be used.

Select a language to be 
used for development.

Check "Use Label" 
(always check this item).

Select "Series".
(In this example, QCPU 
(Q mode) is selected.)

A project tree is displayed 

in the Navigation window.

The ladder screen is displayed.
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 Creating New Data

After a GX Works2 project is created, create a new data file ("Count_Num" is used as an FB name in 
this section).

Operating procedure

1. In the Navigation window, select "FB_Pool", and right-click and select [Add 
New Data] from the shortcut menu.

2. The "New Data" dialog is displayed.

3. The newly created FB (Count_Num) is added to the Navigation window and 
the Element Selection window.

Select "Function Block".

Click the               button.

Input "Count_Num" as 

the FB name to be created.

Select "Ladder".

Point

When entering an FB name, be careful of the

following points. 

-Case-sensitive

-The maximum number of characters for a FB name

is 32 in single-byte.

"Count_Num" is added.
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 Setting Labels

Because FBs are utilized by being converting into components, the actual devices are not used and 
input labels, output labels, and internal labels are used to create a program.

First, categorize the actual devices of the sequence program into, input device, output device, and 
internal device.

Next, set each label for the categorized actual devices.
 

The labels corresponding to the actual devices in the FB that is to be created are as shown in the 
following tables.

Set the input label, output label, and internal label to be used in the FB in the following section.

Device type Device name Label type (Class) Label name Data type

Input device X1
Input label 
(VAR_INPUT)

i_Count Bit

Output device Y12
Output label 
(VAR_OUTPUT)

o_C_Up Bit

Internal device D1 Internal label (VAR) m_Cnt Word [Signed]

 : Input device
   (Device that becomes 
   an input label)

 : Output device
   (Device that becomes 
   an output label)

 : Internal device
   (Device that becomes 
   an internal label)
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Operating procedure

1. Double-click "Local Label" of the added FB and display the Function/FB Label 
Setting screen.

 

2. The Function/FB Label Setting screen is displayed.

3. Set the labels as follows.

Creating design data in Excel or other format in advance for the internal labels that are used normally, 

and entering the label by copying and pasting from the data, reduces the development man-hours.

Double-click "Local Label".

Input label

Output label

Internal label
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 Creating FB Programs

This section explains how to create a sequence program in an FB using the set labels.

Operating procedure

1. Select Project view → "POU" → "FB_Pool" → "Count_Num", and double-click 
"Program".

2.  The [FB] Count_Num window is displayed.

3.  Create an FB sequence program.

Sequence program of the FB to be created is described as follows.
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Performing Conversion/Compilation

In order to operate an FB, a conversion/compilation process is required.

This section explains how to convert/compile all programs.

Operating procedure

1. Select [Compile] → [Rebuild All].

2. The following message is displayed.

3. All programs are converted/compiled and the result is displayed in the Output 
window.

This completes the creation of a new FB.
For details of the procedures to use the created FBs, refer to the section
'(3) Pasting FBs' in 'Using FB Libraries' onward. 

Point

When pasting multiple FBs, which describe the device output (such as OUT Y0Z9) by using

index modification internally, duplicate coil warnings occur while compiling. However, this is

not a usage problem. 

Click the                  button.
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The sequence program created by pasting the created FB is as follows.

When the input (X1) 

is turned ON 12 times,

The output (Y12) 

is turned ON.
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 Protecting Created FBs

Operating procedure

1. Select Project view → "POU"→ "FB_Pool" →  "Count_Num".
 

2. The "Set Block Password" dialog is displayed.

To the next page

A created FB can be protected by setting up a block 

password.

Outflow of technological know-how can be prevented 

by using a password, as the protection using a 

password disables opening of programs in the FB.

This section explains how to set up a block password 

for the created FB.

Caution

If you forget the password, you cannot open the program in the FB.

Do not lose the password.

Right-click the created 
FB "Count_Num".

Select [Block password] 
from the shortcut menu.

Click the                        button.
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3. The "Change Block Password" dialog is displayed.
 

4. The block password is set to "Count_Num".

Point

 Locking an FB by using a block password is activated when the project is re-opened.

 The FBs for which the block passwords were set are displayed in the Project view as

follows.

 A block password can be changed by resetting the password. In this case, unlock the

password prior to change.

 Click the                button.

Set "Password" and 

"Re-enter Password".

Click the                   button.

Key marks are added to the FB icons.
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 Utilizing FBs in Other Projects

FBs can be utilized in other projects.

When utilizing FBs in other projects, open the source and the destination projects respectively, and 
copy the FBs from the source project to the destination project. 

This section explains how to use FBs in other projects by using the FB "Count_Num" created in this 
Quick start guide as an example.

Operating procedure

1. Start another GX Works2, and open the project in which the FB "Count_Num" 
is utilized.

 

2. Drag and drop the FB "Count_Num" to the "FB_Pool" icon of the destination 
project.

To the next page.

Drag and dropDrag and drop
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3. The FB "Count_Num" is copied to the destination project.

Point

 If the programmable controller types of the source project and the destination project are

different, copying FBs will not be possible.

 FBs created in GX Developer can also be utilized in the GX Works2 projects.

Use the following procedure to copy FBs.

(1) Open the GX Developer source project with GX Works2.

Select [Project] → [Open Other Data] → [Open Other Project].

(For details, refer to the GX Works2 Version 1 Operating Manual (Common).)

(2) Start another GX Works2, and open the destination project.

(3) Drag and drop the FB from the source project to the destination project.

"Count_Num" is added.
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 Techniques for Creating FBs

This section introduces techniques for creating FB sequence programs.

1. To transfer multiple bits to a word label
Multiple bits can be transferred to a word label by using BSET and BRST instructions and setting up 
ON/OFF information for each bit of the target word.

 

2. To refer to multiple consecutive data in FBs
Continuous domain of the input and output labels of an FB can be imported to the FB internal label 
by the following method.
An example of an input label is explained below.

(1) Store values on D register from D1000 up to n point in the main program.
(2) Specify D1000 to the FB input label.
(3) In the FB, transfer to BMOV internal label from the input label (i_Write_Data) up to n point 

(required to secure arrays for up to n point).
 

In this case, however, if the input and output labels of the FB are omitted, an unexpected data file will 
be stored in the internal label, resulting unintentional operations such as overrun of a sequence 
program. Never omit the input and output labels.

n=i_Num_Write_Data

D1000

+1

+2

+3

+4

+5

+6

+(n-1)

i_Write_Data int_Write_Data[0]

[2]

[1]

[3]

[4]

[5]

[6]

[n-1]

[BMOV] (n word)
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3. To use index registers in an FB
When using index registers in an FB, add a save program and restore program for the index 
registers to protect them.

[Example of creation]
The following shows an example of saving index registers Z7, Z8, and Z9 in the FB prior to executing 
a program and restoring the index that will be saved at the time when the program is end.

 

 

Label name Type Purpose

int_Z_tmp[0] bit For saving index register Z9

int_Z_tmp[1] bit For saving index register Z8

int_Z_tmp[2] bit For saving index register Z7
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Excel and Windows are either registered trademarks or trademarks of Microsoft Corporation in the 
United States and/or other countries.

The company names, system names and product names mentioned in this manual are either registered 
trademarks or trademarks of their respective companies.

In some cases, trademark symbols such as 'TM' or '®' are not specified in this manual.
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