
 

 
 

 

This document is a guidebook for the MELSEC iQ-R series SFC programming. 
Shows the specifications and configuration of the SFC program, a simple program creation 
example, and the monitoring method. 

 

 

 
 

  

MELSEC iQ-R Series SFC Programming Guide 



1 
 

Contents 
 

1 Overview .......................................................................................................................................... 4 

1.1 Overview ................................................................................................................................... 4 

1.2 What is an SFC Program? ........................................................................................................ 5 

1.3 What are blocks in SFC programs? .......................................................................................... 6 

1.4 SFC Features ............................................................................................................................ 7 

1.5 What control is suitable for SFC programming? ...................................................................... 14 

2 SFC Program Basics ..................................................................................................................... 15 

2.1 Overall Program Configuration and SFC Program .................................................................. 15 

2.1.1 Performance specifications for the SFC program ............................................................. 15 

2.1.2 Processing the entire program.......................................................................................... 16 

2.2 Device List ............................................................................................................................... 18 

2.3 Configuring the SFC Program ................................................................................................. 19 

2.3.1 Basic Operation of SFC .................................................................................................... 19 

2.4 About SFC Elements ............................................................................................................... 20 

2.5 Steps ....................................................................................................................................... 22 

2.5.1 Step Type ......................................................................................................................... 23 

2.5.2 Normal Step (no attributes)............................................................................................... 25 

2.5.3 Initial step ......................................................................................................................... 27 

2.5.4 Coil HOLD Step [SC] ........................................................................................................ 29 

2.5.5 Operation HOLD Step (no Transition Check) [SE] ........................................................... 31 

2.5.6 Operation HOLD Step (with Transition Check) [ST] ......................................................... 33 

2.5.7 Reset Step [R] .................................................................................................................. 35 

2.5.8 Block Startup Steps (With Exit Check) [BC] ..................................................................... 36 

2.5.9 Block Startup Step (No Exit Check) [BS] .......................................................................... 37 

2.5.10 End step ......................................................................................................................... 38 

2.5.11 Instructions that cannot be used for operation output ..................................................... 40 

2.6 Transition Conditions............................................................................................................... 41 

2.6.1 Types of Transition Conditions ......................................................................................... 42 

2.6.2 Series Sequence .............................................................................................................. 43 

2.6.3 Selective Sequence (Divergence/ Convergence) ............................................................. 43 

2.6.4 Simultaneous Sequence (Divergence/ Convergence) ...................................................... 46 

2.6.5 Jump Sequence ................................................................................................................ 50 

2.6.6 Instructions that can be used in transition conditions ....................................................... 52 

2.7 SFC control instruction ............................................................................................................ 53 



2 
 

2.8 Information Device for SFC ..................................................................................................... 55 

2.8.1 Block START/END bit ....................................................................................................... 56 

2.8.2 Step transition bit .............................................................................................................. 58 

2.8.3 Block PAUSE/RESTART bit ............................................................................................. 59 

2.8.4 Block stop mode bit .......................................................................................................... 60 

2.8.5 Continuous transition bit ................................................................................................... 61 

2.8.6 Number of Active Steps Register ...................................................................................... 64 

2.9 SFC Program Processing Order ............................................................................................. 65 

2.9.1 Execution order of each Block .......................................................................................... 65 

2.9.2 Execution order of each Step ........................................................................................... 66 

3 Create an SFC Program ................................................................................................................ 68 

3.1 Target system configuration .................................................................................................... 68 

3.2 Creating Programs .................................................................................................................. 69 

3.2.1 New Project ...................................................................................................................... 69 

3.2.2 Operation screen for creating SFC program ..................................................................... 72 

3.2.3 Overview of the system program ...................................................................................... 73 

3.2.4 Program Creation ............................................................................................................. 75 

3.3 SFC Configuration ................................................................................................................. 102 

3.3.1 SFC program start mode setting ..................................................................................... 103 

3.3.2 Start condition setting ..................................................................................................... 105 

3.3.3 Output mode setting at block stop .................................................................................. 106 

3.4 SFC Block Configuration ....................................................................................................... 108 

3.4.1 Operation setting at block dual start ............................................................................... 108 

3.5 Creating an SFC Diagram ..................................................................................................... 108 

3.6 Writing an SFC Program to the CPU ..................................................................................... 112 

4 Run the SFC program .................................................................................................................. 114 

4.1 Using Monitor Operations to Monitor SFC ............................................................................ 114 

4.2 Modifying a program during CPU operation (Writing during RUN) ........................................ 118 

4.3 Controlling Blocks with Information Devices for SFCs .......................................................... 119 

5 Control blocks with SFC control instructions ................................................................................ 123 

5.1 Creating Programs Using SFC Control Instructions .............................................................. 123 

5.1.1 Add New Program .......................................................................................................... 123 

5.1.2 Create Program .............................................................................................................. 124 

5.1.3 Setting Parameters and CPU Writing ............................................................................. 125 

5.2 Control of SFC Program by SFC Control Instruction ............................................................. 126 

5.2.1 Block and step active state monitoring by activation check command ........................... 126 

5.2.2 Forced termination of block by SFC control instruction .................................................. 127 



3 
 

5.2.3 Suspension of blocks by SFC control command (block stop) ......................................... 128 

Appendix 1.1: Practical Programming Tasks Using Demo Test Equipment ................................... 129 

1.1 Description of equipment....................................................................................................... 129 

1.1.1 Skill Test Equipment ....................................................................................................... 130 

1.1.2 Input/Output wiring diagram ............................................................................................ 131 

1.2 Programmable controller ....................................................................................................... 132 

1.2.1 RX40C7 Type DC Input module ..................................................................................... 132 

1.2.2 RY40NT5P Transistor Output module ............................................................................ 133 

1.3 Wiring .................................................................................................................................... 134 

1.3.1 Precautions ..................................................................................................................... 134 

1.4 Practical Test 1...................................................................................................................... 135 

1.4.1 Flowchart Example ......................................................................................................... 136 

1.5 Practical Test 2...................................................................................................................... 137 

1.6 Practical Test 3...................................................................................................................... 139 

1.6.1 Flowchart Example ......................................................................................................... 141 

1.7 Examples of answers ............................................................................................................ 142 

1.8 SFC Program for Emergency Stop ........................................................................................ 143 

 
  



4 
 

1 Overview 
 

1.1 Overview 

This document describes the specifications, functions, instructions, programming, and monitoring 
methods for programming using the SFC programming language. 

 

SFC stands for Sequential Function Chart, which is a graphical programming language that 
represents each process in a series of control operations as a single step and enables the 
execution order and execution conditions of programs to be clearly expressed. This makes the 
program easy to understand visually and structurally. It also makes it easier to understand the 
correspondence between the processing flow and program control, which reduces the load on 
debugging and maintenance.  
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1.2 What is an SFC Program? 

The SFC program consists of steps that represent units of operations in a series of machine 
operations. 

In each step, the actual detailed control is programmed. 

 

  

An SFC program starts at an initial step, executes an action of the next step in due order every time 
the relevant transition becomes TRUE, and ends a series of operations at an end step. 
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1.3 What are blocks in SFC programs? 

In the SFC program, a set of steps from the initial step to the end step is expressed as a block, and 
up to 320 blocks*¹ from Block0 to Block319 can be created. 

One block is programmed for each process (Processing, assembly, inspection, etc.), product (For 
product A processing, product B processing, etc.), and control unit such as automatic/manual 
operation. 

Multiple blocks are created, and the actual machine is controlled by starting specific blocks 
according to the purpose and application, or by interrupting or terminating processing. 

  

*¹ For R00CPU, R01CPU, and R02CPU, the maximum number of blocks is 128. 

Operation of the SFC program 

1. When starting a block, the initial step (1) is activated first and then the action (2) is 
executed. After execution of the action (2), the program checks whether the next 
transition (3) has become TRUE. 

2. The program executes only the action (2) until the transition (3) becomes TRUE. 
When the transition (3) becomes TRUE, the program ends the action (2), deactivates 
the initial step (1), and activates the next normal step (4). 

3. After execution of the action of the normal step (4), the program checks whether the 
next transition has become TRUE. If the next transition does not become TRUE, the 
program repeats the execution of the action of the normal step (4). 

4. When the transition becomes TRUE, the program ends the action, deactivates the 
step (4), and activates the next step (5). 

5. Every time the transition becomes TRUE, the program activates the next step and 
ends the block when it finally activates the end step (6). 

320 blocks*1 
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1.4 SFC Features 

1. Easy system design and maintenance 

The entire equipment, the mechanical equipment of each station, and the actual control of 
each machine can be associated with each block and each step of the SFC program on a 
one-to-one basis. 

Therefore, even with little experience with sequence programs, you can pursue work such as 
system design and maintenance to a considerable depth. 

In addition, since the control contents of each block and each step are easy to understand, it 
can be easily deciphered even by a program designed by another person compared to a 
sequence program. 
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2. Easily divide and edit blocks and steps according to the control object 

 You can create up to 320 blocks*¹ for the entire SFC program. 
 You can create up to 16384 steps*² for the entire SFC program, and up to 512 steps in 1 block. 
 The operation output can be created up to approximately 32K sequence steps in 1 block. 

(There are no constraints per step.) 
 You can create only one circuit block for each transition condition. 

 

By dividing the blocks and steps as follows, you can reduce the tact time and facilitate 
debugging and trial operation. 

 To successfully divide a block by an operation unit of a machine. 
 To successfully divide steps in a block. 

  

 

*1 For R00CPU, R01CPU, and R02CPU, the maximum number of blocks is 128. 

*2 For R00CPU, R01CPU, and R02CPU, the maximum number of steps is 1024 for all blocks and 128 for 1 block. 
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3. Rich step attributes make program design easy 

Each step can have various step attributes. SFC programs can be designed easily by using 
attributes according to control or by using them in combination. 

For details, see 2.5 Steps. 

 

4. Easy-to-read display with comments 

You can enter comments from "Device Comment Editor" in the "Step Properties" and 
"Transition Condition Properties" windows. 

By displaying comments, you can make the SFC program easier to understand. 

 

5. Floating Zoom side-by-side with SFC diagram and compare 

Double-click a transition condition or behavior output to display Zoom. 

By double-clicking this tab, you can float Zoom and compare it to the SFC diagram to see 
the transition conditions and behavior output program. 

  

 

6. Automatic scroll function makes it easy to check where mechanical trouble occurs. 

When a step that is not visible on the screen is activated during monitoring, the system 
automatically scrolls to display the activated step on the screen again. This monitoring 
function enables you to search for trouble spots even if you are not familiar with sequence 
programs. 
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7. Multiple ways to control the same functionality for different purposes 

You can control the start, end, pause, and resume of each block, the start of a step (active), 
and the end of a step (inactive) in several ways. 

 

 How to Start a Block 
This table describes how to start a block. 

 

Items Startup Method Remarks 

Automatic startup with 
CPU parameters 

(Block0 only) 

If you set "Start condition setting" to 
"Automatically start Block0" in the SFC settings 
of the CPU parameters, Block0 starts 
automatically when the SFC program starts, 
and processing starts from the initial step. 

Set this option when 
Block0 is used as a 
management block, 
preprocessing block, 
or always-on 
monitoring block. 

Starting with the block 
start step 

For each block in the SFC program, use the 
block start step [BC or BS] to start another 
block. 

This is useful when 
the order of control is 
clear. 

Start by SFC control 
instruction 

Starts the block specified by the SFC control 
instruction from the operation output of the SFC 
program or from another sequence program. 

•To execute the command from the initial step 
of the specified block, use the SET [BL] 
command (block start). 

•To execute the command from the specified 
step of the specified block, use the SET [S/ 
BL\S] command (step start). 

This is useful for 
starting error recovery 
processing blocks or 
executing interrupt 
processing when an 
error is detected. 

Booting by information 
device for SFC 

The specified block is started by turning on 
"block start end bit" set for each block as an 
SFC information device. 

It can be started from 
an external device, so 
it is useful for 
debugging and trial 
operation in block 
units. 

Launching with 
engineering tools 

Activates the specified block by turning on the 
SFC block device. 

This is useful for 
debugging and trial 
operation. 
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 How to End a Block 
Describes how to end a block. 

 

Items Exit Method Remarks 

End by End Step 
Executing an end step in a block 
terminates the processing of the block and 
makes it inactive. 

Useful when stopping 
operation by automatic 
operation cycle stop. 

Termination by SFC 
control instruction 

Terminates the block specified by the RST 
[BL] instruction (block start) from the 
operation output of the SFC program or 
from another sequence program and 
deactivates the block. 

(The block is also terminated when all the 
active steps in the specified block are 
deactivated by the RST [BL\S] 
command (step termination).) 

This is useful for stopping 
processing regardless of 
the operating status, such 
as emergency stop. 

Termination by information 
device for SFC 

Terminates the specified block by turning 
off "block start end bit" set for each block 
as an SFC information device. 

It can also be terminated 
from an external device, so 
it is useful for debugging 
and trial operation in block 
units. 

Exit with Engineering 
Tools 

Terminates the specified block by turning 
off the SFC block device. 

This is useful for 
debugging and trial 
operation. 
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 How to Stop a Block 

Describes how to stop a specified block while an SFC program is running. 

Items Stopping Method Remarks 

Stop by SFC control 
command 

Temporarily stops execution of the block 
specified by the PAUSE [BL] command 
(block stop) from the operation output of the 
SFC program or from another sequence 
program. 

This is useful for 
temporarily stopping the 
machine and manually 
repairing the abnormal 
area when an error is 
detected. 

Stopping by information 
device for SFC 

The specified block is stopped by turning on 
"block stop restart bit" set for each block as an 
SFC information device. 

Since it can be stopped 
from an external device, 
it is useful for debugging 
and control while 
checking during trial 
operation. 

 

The operation at block stop/restart depends on the combination of the SM325 (output mode 
setting at block stop), setting of the block stop mode bit of the SFC information device, and 
HOLD/non-HOLD of steps. 

 

 How to Resume a Block 

Describes how to resume processing of blocks that were paused while the SFC program 
was running. 

Items Resume Method Remarks 

Resume by SFC 
control instruction 

Resumes the block specified by the RSTART 
[BL] command (block restart) from the 
operation output of the SFC program other than 
the stopped block or from another sequence 
program. 

This is useful for 
returning to automatic 
operation after manual 
control is completed 
during a pause. 

Resume by Information 
Device for SFC 

Resumes the specified block by turning off 
"block stop restart bit" set for each block as an 
SFC information device. 

It can be started from an 
external device, so it is 
useful for debugging and 
trial operation in block 
units. 

 

The operation at block stop/restart depends on the combination of the SM325 (output mode 
setting at block stop), setting of the block stop mode bit of the SFC information device, and 
HOLD/non-HOLD of steps. 
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 Method for starting (activating) step 

Describes how to activate a step. 

Items Startup Method Remarks 

Start with transition 
condition satisfied 

When the previous transition condition is satisfied, 
the next step starts automatically. 

- 

Start by SFC control 
instruction 

Starts the step specified by the SET [S/BL\S] 
command (step start) from the operation output of 
the SFC program or from another sequence 
program. 

- 

launching with engineering 
tools 

•The specified step is started by turning on the step 
relay. 

•Activates the step selected from the menu Debug > 
SFC Step Control. 

This is useful for 
debugging and 
trial operation. 

 

 Step End (deactivate) Method 

Describes how to end (deactivate) a step. 

Items Exit Method Remarks 

Termination due to 
establishment of transition 
conditions 

The system terminates automatically when the next 
transition condition of the step is satisfied. 

- 

Exit with reset step [R] 
When the reset step [R] is activated, the step 
specified for the attribute specification destination 
ends. 

This is useful 
when you want to 
end the HOLD 
step [SC, SE, ST], 
for example, 
when the SFC 
program selection 
branch moves to 
the error 
processing step. 

termination by SFC control 
instruction 

Terminates the step specified by the RST 
[S/BL\S] command (step termination) from the 
operation output of the SFC program or from 
another sequence program. 

If all steps of the 
specified block 
are disabled by 
the RST 
command, the 
block is also 
terminated. 

Exit with Engineering 
Tools 

•Terminates the specified step by turning off the 
step relay. 

•Deactivates the step selected from the menu 
Debug > SFC Step Control. 

This is useful for 
debugging and 
trial operation. 
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1.5 What control is suitable for SFC programming? 

Since the SFC program can program the operation control of the machine as it is, it is suitable for 
the control with clear flow to some extent. 

 

1. Example of Programmable Control in an SFC Program 

 Transportation control of automatic warehouse, transfer equipment, etc. 
 Assembly line 
 Semiconductor manufacturing equipment such as polishing, cleaning, and inspection 
 Batch processing of chemicals and pulp 

 

2. Examples of Controls Difficult to Program in SFC Programs 

 Control such that signals enter at random, as in a transformer machine 
 Controls that require constant monitoring, such as emergency stop signals and interrupt 

signals*. 
 

*By using SFC control instructions and SFC information devices in program files other 
than SFC, it is possible to support control that requires constant monitoring. 

 

3. Programming of manual circuits 
 

By programming manual circuits and individual operation circuits with the SFC program, you 
can easily understand what kind of work is being done at that time. 

By combining SFC control instructions and block information to stop, clear, and forcibly start 
blocks, manual circuits and individual operation circuits can be programmed with SFC 
programs. 
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2 SFC Program Basics 

2.1 Overall Program Configuration and SFC Program 

2.1.1 Performance specifications for the SFC program 

 

Indicates the performance specifications for the SFC function. 
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2.1.2 Processing the entire program 

Possible Execution Types 

Describes whether the execution type of the SFC program can be specified. 

  

 

 

 

Precautions 

When no scan execution type SFC program exists (only standby type program), do not execute an 
SFC control instruction and monitoring for an SFC program.  
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Changing the Execution Type by Instruction 

The execution type of a program can be changed by using a program control instruction. 
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2.2 Device List 

Indicates the transition conditions for the SFC program and the devices that can be used in the 
operation output. 

Classification Category Device name Symbol Range 
Parameter Setting 

Range 
Notation 

User Devices 

Bit Input X 12K Point *5 
Cannot change 

16 digits 

Bit Output Y 12K Point *5 16 digits 

Bit Internal Relay M 12K Point *5 

Modifiable 

10 digits 

Bit Link Relay B 8K Point 16 digits 

Bit Annunciator F 2K Point 10 digits 

Bit Link Special Relay SB 2K Point 16 digits 

Bit Edge Relay V 2K Point 10 digits 

Bit Step Relay*3 S 0 Point 10 digits 

Bits/Word Timer T 1K Point *5 10 digits 

Bits/Word Retentive Timer ST 0 Point 10 digits 

Bit/Double Word Long Timer LT 1K Point *5 10 digits 

Bit/Double Word Long Retentiive Timer LST 0 Point 10 digits 

Bits/Word Counter C 512 Items*5 10 digits 

Bit/Double Word Long Counter LC 512 Items*5 10 digits 

Word Data Register D 18K Point*5 10 digits 

Word Link Register W 8K Point 16 digits 

Word Link Special Register SW 2K Point 16 digits 

Bit Latch Relay L 8K Point 10 digits 

System Devices 

Bit Function Input FX 16 Point 

Cannot change 

16 digits 

Bit Function Output FY 16 Point 16 digits 

Word Function Register FD 5 items x 4 words 10 digits 

Bit Special Relay SM 4K Point 10 digits 

Word Special Register SD 4K Point 10 digits 

Link Direct Device 

Bit Link Input Jn\X Up to 160 K Point*1*6 

Cannot change 

16 digits 

Bit Link Output Jn\Y Up to 160 K Point*1*6 16 digits 

Bit Link Relay Jn\B Up to 640 K Point*1*6 16 digits 

Bit Link Special Relay Jn\SB Up to 5120 Point*1*6 16 digits 

Word Link Register Jn\W Up to 2560 K Point*1*6 16 digits 

Word Link Special Register Jn\SW Up to 5120 Point*1*6 16 digits 

Module Access Device Word Module Access Device Un\G Up to 268435456 Point*1 Cannot change 
10 digits 

CPU Buffer Memory 

Access Device 
Word CPU Buffer memory access device 

U3En\G Up to 268435456 Point*1 Cannot change 10 digits 

U3En\HG Up to 12288 Point Modifiable 10 digits 

Index Register 
Word Index Register Z 20 Point Modifiable 10 digits 

Double Word Long Index Register LZ 2 Point Modifiable 10 digits 

File Register Word File Register R/ZR 0 Point Modifiable 10 digits 

Refresh Data Register Word Refresh Data Register RD 512 K Point Modifiable 
10 digits 

Nesting - Nesting N 15 Point Cannot change 10 digits 

Pointer 
- Pointer P 8192 Items*2 Modifiable 10 digits 

- Interrupt Pointer I 1024 Point Cannot change 10 digits 

Other Devices 

- Network Number Designation Device J - 

Cannot change 

10 digits 

- I/O No. Designated Device U - 16 digits 

- SFC Block Device*3 BL 320 Items*5 10 digits 

- SFC Transition Device*3*4 TR 0 Point 10 digits 

*1 Maximum value that the CPU module can handle. Actual values vary by module. 
*2 16384 points for R120CPU, R120ENCPU, R120CPU, and R120SFCPU. 
*3 Can be collected on CPU module that can use the SFC feature. 
*4 Can be used as a device comment in the SFC program. 
*5: For R00 CPU, R01CPU, and R02CPU, the default points are as follows: 

 Input (X), Output (Y), Internal Relay (M): 8K point 
 Timer: 2K point 
 Long Timer (LT), Long Counter (LC): 0 points 
 Counter (C): 1K point 
 Data register (D): 12K point 
 SFC Block Device (BL): 128 

*6: The maximum number of points depends on the "Link Direct Device Settings" of the engineering tool. " If you use "Link Direct Device Configuration", 
check the version of the CPU module and engineering tool. 
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2.3 Configuring the SFC Program 

The following describes the SFC diagrams, SFC control instructions, and SFC information 
devices used to configure SFC programs. 

2.3.1 Basic Operation of SFC 

The SFC program starts with the initial step, executes the next step each time the transition 
condition is satisfied, and ends the series of operations at the end step. 

 

 

 

 

 

 

 

 

 

 

 

 

 

1. When the block starts, the initial step (1) is activated first, and the operation output (2) is 
executed. After the operation output (2) is executed, check whether the following transition condition 
(3) is satisfied. 

2. Only action output (2) is executed until the transition condition (3) is satisfied. If the transition 
condition (3) is satisfied, the operation output (2) is terminated, the initial step (1) becomes inactive, 
and the next normal step (4) is activated. 

3. After the operation output in step (4) is executed, check whether the following transition 
conditions have been satisfied. If the following transition conditions are not satisfied, repeat the 
execution of the action output in step (4). 

4. If the transition condition is satisfied, the operation output ends, step (4) becomes inactive, and 
the next step (5) becomes active. 

5. Each time the transition condition is satisfied, the next step is activated, and the block ends when 
the end step (6) is activated. 

1. Initial Step 

2. Operation Output 

3. Transition Conditions 

4. Normal Step 

5. Normal Step 

6. End Step 

Point 
 You can create up to four operation outputs per step. If multiple action outputs are 

created, they are executed in order from the top. 
 You can change the type of initial and normal steps by adding attributes. 
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2.4 About SFC Elements 

Indicates which elements are available in the SFC program. 

For the number of blocks/elements that can be created, their behavior, and details about 
each element, see the following: 

MELSEC iQ-R Programming Manual (Program Design Edition) 

  

Items Specifications 

Step 

 
(1) Step Name 
(2) Step No. (S) 
(3) Step Attributes 
(4) Step Attribute 
Specification Destination 

Initial Step 

 

Indicates the beginning of a block, which is required 
for each block. 
If multiple processes are executed in parallel, you 
can create multiple initial steps. 
You can change the behavior of a step by specifying 
step attributes. For details, see the following: 
MELSEC iQ-R Programming Manual (Program 
Design Edition) 

Normal Step 

 

When the next transition condition of the step is 
satisfied, the activity shifts to the next step. 
You can change the behavior of a step by specifying 
step attributes. For details, see the following: 
MELSEC iQ-R Programming Manual (Program 
Design Edition) 

End Step 

 

Indicates the end of the block. 
Only the end step cannot be assigned a step 
number. 

Transition Conditions 

 
(1) Transition Condition 
Name 
(2) Transition Condition 
No. (TR) 

Series 
Transition 

 

Move from the previous step to the next step. 

Selective 
Transition 

 

Refers to a branch that is displayed as a single line 
and selects one action. 
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Parallel 
Transition 

Jump and 
connection line can 
be switched. 

Indicates a branch that is displayed as a double line 
and performs multiple processes in parallel. 

Jump Transition 

Jumps the execution to the specified step in the 
same SFC block. 
 

Operation Output 
 

 
(1) N: Qualifier 
(2) Operation Output Name 

When the step is activated, the allocated operation 
output is executed. 
N indicates that the step is being executed while it is 
active. You cannot set anything other than N. 
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2.5 Steps 

A step is the basic unit of a block. 

 

 

 

 

 

 

 

 

The following table shows the number of steps that can be used per block. 

CPU module type Maximum number of steps per block Maximum number of blocks in all blocks 

R00CPU, R01CPU, R02CPU Up to 128 steps Up to 1024 steps 

CPU module other than the above Up to 512 steps Up to 16384 steps 

 

 

Steps have the following characteristics: 

 When the step is activated, the associated operation output is executed. 
 A step number is assigned to each step. Step No. is used to monitor execution steps or to 

forcibly start or stop an execution by using an SFC control instruction. 
 The step name and step number are unique within each block. 

 

 

 

 

 

  

 

 

 

(1) Step name 

(2) Step No. 

(3) Attribute 

(4) Attribute specification destination 

Point 
 You can change the step name, step number, attribute, and attribute specification destination 

from the step property window. 
 Select a step and select [Edit]-> [Properties] from the menu to display the step properties 

screen. 
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2.5.1 Step Type 

Indicates the type of step. 

Items Contents 

Initial Step 

 

Indicates the beginning of the block. 
When a step is active, the next transition 
condition is always checked, and when the 
transition condition is satisfied, the activity shifts 
to the next step. 
Attributes of SC, SE, ST, and R can be added. 
You can choose not to create operation output. 

Normal Step 

 

The basic steps that make up a block. 
When a step is active, the next transition 
condition is always checked, and when the 
transition condition is satisfied, the activity shifts 
to the next step. 
Attributes of SC, SE, ST, R, BC, BS can be 
added. 
You can choose not to create operation output. 

End Step 

 

The step to end the block. 
You cannot create operation output. 

 

 
Indicates the attributes of the step. 
 

Items Items Contents 

SC 
Coil HOLD step 
[SC] 

 

This is a step to hold the output of the 
coil which is turned on by the 
operation output even after the 
activation is transferred. 

SE 

operation 
HOLD step 
(no transition 
check) [SE]  

This is the step of continuing to 
execute the operation output even 
after the activity has shifted. 
After the transition condition is 
satisfied and the next step becomes 
active, the transition condition is not 
checked. 

ST 

operation 
HOLD step 
(with Transition 
Check) [ST]  

This is the step of continuing to 
execute the operation output even 
after the activity has shifted. 
After the transition condition is 
satisfied and the next step becomes 
active, the transition condition is 
checked repeatedly. 

R Reset Step [R] 
 

Deactivates the specified step. 

BC 
Block Startup 
Step with Exit 
Check [BC]  

This step activates the specified 
block. 
When the specified block becomes 
inactive and the transition condition is 
satisfied, the activity shifts to the next 
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step. You cannot create operation 
output. 

BS 
Block Startup 
Step (No Exit 
Check) [BS]  

This step activates the specified 
block. 
When the transition condition is 
satisfied, the activity shifts to the next 
step. 
You cannot create operation output. 

 

 

 

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

Point 
 You can change the step type by changing the "attribute" setting on the step property screen. 
 For the reset step [R], block start step (with end check) [BC], and block start step (without end 

check) [BS], specify the step name or block number in "Attribute specification destination" on 
the property screen. increase. 
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2.5.2 Normal Step (no attributes) 

A normal step (with no attributes) is the basic step that constitutes a block. When a step is active, 
the next transition condition is always checked, and when the transition condition is satisfied, the 
activity shifts to the next step. 

 

(1) Operation output of the step 

The operation output status of each step differs depending on the instruction used. 

 

 When using OUT instruction (except OUT C instruction) 

When the activity shifts to the next step and the corresponding step becomes inactive, the 
output by the OUT command is automatically turned OFF. Similarly, the timer clears the 
current value and turns the contact OFF. However, output by OUT commands used in ST 
language selection statements or repeated statements is not automatically turned off. 

 

 

 

 

 Using SET, basic, and applied commands 

Even if the activity shifts to the next step and the corresponding step becomes inactive, data 
stored in the ON state or device/label is retained. 
To turn off the device/label in the ON state or clear the data stored in the device/label, use 
the RST command in another step. 

 

 

 

 

 

If Y0 is turned ON by the OUT command 
in the operation output of step (1), Y0 is 
automatically turned OFF when the 
transition condition (2) is satisfied. 

If Y0 is turned ON by the SET command 
in the operation output of step (1) (2), Y0 
remains ON even if the transition 
condition (3) is satisfied and the 
operation proceeds to step (4). 
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 When using OUT C instruction 

If the execution condition of the counter in the operation output is already ON and the transition 
condition is satisfied and the step is activated, the count is performed once. 

If activation moves to the next step before executing the counter reset command, the current value 
of the counter and the ON state of the contact are retained even if the step becomes inactive. 

To reset the counter, execute the RST command in another step. 

 

 

 When using PLS and rise commands as the operation output 

Even if the contact point of the execution condition is always ON, the command is executed every 
time the step changes from inactive to active. 

 

 

 

 

The drop command is executed the same as the PLS command and the rise command. 

 

 

 

If step (1) is active and X10 is already 
ON, the counter C0 counts once when 
the transition condition (2) is satisfied, 
and the process proceeds to step (3). 

C0 retains its value even if the transition 
condition is satisfied. 

Reset the counters in a separate step. 

Even if the execution condition contact is 
always ON (1), the PLS instruction is 
executed every time Step (2) becomes 
active. 

Normal Step (no attributes) 

 During step execution, always check the transition conditions described next to the applicable 
step, and when the transition conditions are satisfied, move the activity to the next step. 

 Note the difference in operation when using counters when using SET, basic, and applied 
commands when using OUT commands 

 When the interlock of the execution condition is ON, the PLS command and the rise command 
are executed every time the corresponding step becomes active. 
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2.5.3 Initial step 

An initial step is a step that indicates the beginning of each block, and a maximum of 32 initial steps 
can be specified for each block. 

Only selective joins are allowed when there are multiple initial steps. The initial step is executed in 
the same way as any other step. 

The following attributes can be added to the initial step: SC (coil HOLD), SE (operation HOLD (no 
transition check)), ST (operation HOLD (transition check)), and R (reset). 

If you assign an attribute to an initial step, the action is the same as for steps other than the initial 
step, except that the action is automatically activated when the block starts. 

 

(1) Active step at block activation 

If the initial step consists of multiple steps, the activation steps for starting a block are 
as follows, depending on the activation method. 

 

Operation of the active step Startup Method 

All the initial steps are activated 

When starting by the block start step 

When starting by block start instruction of SFC control instruction 

Forced start is attempted by the block start end bit of the SFC 
information device. 

When Block0 starts due to the automatic start setting of Block0 

Activate only the specified step 
When any of the initial steps is specified by the step control instruction 
of the SFC control instruction 
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(2) Transition processing when multiple initial steps are activated 

 

  

 

When blocks with multiple initial steps active are selectively combined, if any one of 
the transition conditions immediately before the combination is satisfied, the step 
immediately after the combination is activated. 

In the above example program, step8 (S8) is activated when any of the transition 
conditions t4 to t7 is satisfied. If the step immediately after binding (S8 in the above 
example program) is activated and another transition condition immediately before 
binding (t4 to t7 in the above example program) is satisfied, the step immediately 
after binding is activated again. 

 

 

 

 

 

 

 

  

 

 

 

Initial Step 

 Step to indicate the beginning of the block 
 Up to 32 initial steps can be written per block 
 By creating multiple initial steps, it is possible to easily describe the process of executing 

multiple processes and merging them. 
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2.5.4 Coil HOLD Step [SC] 

A step that holds the outputs of a coil that has been turned on by the action even after the active 
state transitions. 

After the transition condition is satisfied and the process moves to the next step, no calculation is 
performed in the operation output. Therefore, the coil output state does not change even if the input 
condition in the operation output changes. This is useful when you want to keep the output until the 
block ends, for example, when you want to output a hydraulic motor or a passage confirmation 
signal. 

 

 

(1) Timing of coil output OFF 

Below indicates the timing when the coil output that is held ON turns OFF in the coil HOLD 
step [SC] after the transition: 

a) You performed a block end step. (Except when SM327 is ON) 
b) The block is forcibly terminated by the RST instruction (block termination) of the SFC 

control instruction. 
c) When the step is reset by the RST instruction (step end) of the SFC control instruction. 
d) When the device specified in the block start end bit of the information device for SFC is 

reset. 
e) When the reset step [R] set to reset the coil HOLD step [SC] is activated. 
f) SM321 (start/stop of SFC program) is turned OFF. 
g) The coil is reset programmatically. 
h) When the stop output mode is OFF, and a stop command is executed. 
i) S999 is specified for the reset step [R] in the block. 

 

  

 

 

 

 

 

 

 

 

 

Y10 (1), which is turned ON by the OUT 
command, remains ON (3) even if the 
transition condition (2) is satisfied. 
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(2) Operation at block stop/restart 

The following describes the processing performed when a block is stopped. The operation at 
block stop/restart depends on the combination of the SM325 (output mode setting at block 
stop), setting of the stop mode bit of the SFC information device, and HOLD/non-HOLD of 
steps. 

Setting the 
Output Mode at 
Block Stop 

Setting the Blocking 
Stop Mode Bit 

Operation 

Active steps other than HOLD (Including SC, SE, and ST 
for which transition conditions have not been met) 

HOLD Step 

Coil HOLD step [SC] 

SM325 = OFF 
(Coil Output 
OFF) 

OFF or not set 
(stop immediately) 

Immediately after a stop request is received, the coil output 
of the operation output is turned off and stopped. The state 
remains active. 

Immediately after a stop 
request is made, the coil 
output of the operation 
output is turned off, and it 
becomes inactive. 

ON 
(Stop after 
transition) 

After the transition is completed, the process terminates the 
step, and at the same time, the transition destination step 
becomes active and stops before the operation output is 
executed. 

SM325 = ON 
(Keep Coil 
Output) 

OFF or not set 
(stop immediately) 

Immediately after a stop request is made, the motor stops 
while maintaining the coil output of the operation output. The 
state remains active. 

Immediately after a stop 
request is made, the 
motor stops while 
maintaining the coil 
output of the operation 
output. The state remains 
active. 

ON 
(Stop after 
transition) 

The operation is the same as usual until the transition is 
completed. After the transition is completed, the process 
terminates the step, and at the same time, the transition 
destination step becomes active and stops before the 
operation output is executed. 

Resume Normal operation returns. 

When the coil output is 
OFF: it is inactivated and 
cannot be restarted. 
When HOLD coil output: 
Resumes while HOLD. 

 

(3) Precautions when specifying the coil HOLD step 

Note the following when specifying the coil HOLD step: 

 Normally, the PLS and PLF commands are turned ON for only one scan of the designated 
device and then turned OFF. However, if the designated device is turned ON at the same time 
as the transition of the coil HOLD step [SC] is completed, the PLS and PLF commands remain 
ON.  
In this case, if the coil output of the coil HOLD step [SC] is turned OFF, or if the step is activated 
again, it is turned OFF. 

 If the transition condition is satisfied in the coil HOLD step [SC], if the step is stopped with the 
setting for HOLD the SM325 (output mode at block stop), or if the coil output is only held but 
no operation is being performed, the operation of each instruction at the time of resuming the 
operation is in the non-execution state, and the operation depends on the execution condition 
before the non-execution. 

 Count is not performed even if the count input condition is turned ON/OFF after the next step. 
 When the timer coil is ON and the transition condition is satisfied and the step shifts, the timer 

stops measurement and retains the current value. 

Coil holding step 

 Even if the transition condition is satisfied, the coil output turned on by the OUT command is 
retained. 

 After the transition condition is satisfied, the circuit is not operated and is not affected by 
ON/OFF state of the interlock condition. 

 OFF the output held by the end step, SFC control command, SFC information device, etc. 
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2.5.5 Operation HOLD Step (no Transition Check) [SE] 

A step which continues the operation of the action even after the active state transitions. 

After the transition becomes TRUE and the next step is activated, the transition is not checked. 

When the transition condition is satisfied, the operation in the operation output continues even after 
the next step is completed. Therefore, the state of the coil changes when the input condition 
changes. 

After the transition condition is satisfied and the next step becomes active, the system does not 
check the transition condition, and if the transition condition is satisfied again, the system does not 
move to the next step. 

The operation HOLD step (no transition check) is useful when the corresponding block repeats the 
same operation while the cylinder is active, such as moving forward or backward. 

  

 

(1) Timing of inactivation 

Indicates when the operation HOLD step (no transition check) [SE] is deactivated. 
a) You performed a block end step. 
b) The block is forcibly terminated by the RST instruction (block termination) of the SFC control 

instruction. 
c) When the step is reset by the RST instruction (step end) of the SFC control instruction. 
d) When the device specified in the block start end bit of the information device for SFC is 

reset. 
e) When the Reset Step [R] which is set to reset the operation HOLD step (no transition check) 

[SE] is activated. 
f) SM321 (start/stop of SFC program) is turned OFF. 
g) S999 is specified for the reset step [R] in the block. 

 

  

 

 

 

 

 

If you move from step (1) to step (2), 
step (1) is being held. 

During HOLD, the transition check is not 
performed, but the operation output (3) 
continues to be executed. 

In this case, Y10 turns ON/OFF 
according to the ON/OFF state of X0. 
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(2) Operation at block stop/restart 

The operation at block stop/restart depends on the combination of the SM325 (output mode 
setting at block stop), setting of the stop mode bit of the SFC information device, and 
HOLD/non-HOLD of steps. 

 

Setting the 
Output Mode at 
Block Stop 

Setting the Blocking 
Stop Mode Bit 

Operation 

Active steps other than HOLD 
(Including SC, SE, and ST for which transition conditions 
have not been met) 

HOLD Step 
operation HOLD step 
(no transition check) [SE] 

SM325 = OFF 
(Coil Output 
OFF) 

OFF or not set 
(stop immediately) 

Immediately after a stop request is received, the coil output 
of the operation output is turned off and stopped. The state 
remains active. 

Immediately after a stop 
request is received, the 
coil output of the 
operation output is turned 
off and stopped. The 
state remains active. 

ON 
(Stop after 
transition) 

After the transition is completed, the process terminates the 
step, and at the same time, the transition destination step 
becomes active and stops before the operation output is 
executed. 

SM325 = ON 
(Keep Coil 
Output) 

OFF or not set 
(stop immediately) 

Immediately after a stop request is made, the motor stops 
while maintaining the coil output of the operation output. The 
state remains active. 

Immediately after a stop 
request is made, the 
motor stops while 
maintaining the coil 
output of the operation 
output. The state remains 
active. 

ON 
(Stop after 
transition) 

The operation is the same as usual until the transition is 
completed. After the transition is completed, the process 
terminates the step, and at the same time, the transition 
destination step becomes active and stops before the 
operation output is executed. 

Resume Normal operation returns. 
To the operation output in 
the HOLD state 
Restart execution. 

 

 

 

 

 

 

 

 

 

 

 

Operation HOLD Step (No Transition Check) 

 If the transition condition is satisfied, the operation output of the step is continued. 
 Once the transition condition is satisfied and the next step is activated, do not check the 

transition condition. 
 OFF the output held by the end step, SFC control command, SFC information device, etc. 
 When the operation output flag (SM325) is ON/OFF, the coil output is switched ON/OFF when 

the block is stopped. 
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2.5.6 Operation HOLD Step (with Transition Check) [ST] 

The operation HOLD step (with the transition check) is a step that continues to execute the action 
output even after the activity shifts. 

When the transition condition is satisfied, the operation in the operation output continues even after 
the next step is completed. Therefore, the state of the coil changes when the input condition 
changes. 

After the transition condition is satisfied and the next step becomes active, the transition condition is 
checked repeatedly. When the transition condition is satisfied again, the next step is activated again 
and the operation in the operation output continues. 

 

  

 

(1) Timing of inactivation 

The timing at which the Operation HOLD Step (with transition check) becomes inactive is 
shown below. 

a) You performed the end step for the block. 
b) When the corresponding block is forcibly terminated by the SFC control instruction RST 

instruction (block termination). 
c) When the step is reset by the SFC control command RST command (step end). 
d) When the device specified as the block start-end device of the information device for SFC is 

reset. 
e) When the reset step [R] which is set to reset the operation HOLD step (with transition check) 

[ST] is activated. 
f) When SM321 (start/stop of SFC program) is turned OFF 
g) S999 is specified for the reset step [R] in the block. 

If you move from step (1) to step (2), 
step (1) is being held. 

The operation output (3) continues to be 
executed even during the active step. 

In this case, Y10 turns ON/OFF 
according to the ON/OFF state of X0. 

A transition check is also performed, and 
the next step is activated when the 
transition condition is satisfied. 
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(2) Operation at block stop/restart 

The operation at block stop/restart depends on the combination of the SM325 (output mode setting 
at block stop), setting of the stop mode bit of the SFC information device, and HOLD/non-HOLD of 
steps. 

(3) Cautionary Notes 

 In the operation HOLD step (with transition check) [ST], the next step of each scan is started 
while the next transition condition is satisfied. To prevent transition every time a scan is 
performed, use a startup execution command such as a PLS command as a transition 
condition. 

 

 If the SM328 (clear processing mode upon arrival of END step) is ON, make sure that the 
transition condition immediately after the operation HOLD step (with transition check) [ST] is 
not always satisfied. The block cannot be terminated because the next step is always in the 
active state of not HOLD. 

Setting the 
Output Mode at 
Block Stop 

Setting the Block 
Stop Mode Bit 

Operation 

Active steps other than HOLD 
(Including SC, SE, and ST for which transition conditions 
have not been met) 

HOLD Step 
operation HOLD step 
(no transition check) [SE] 

SM325 = OFF 
(Coil Output 
OFF) 

OFF or not set 
(stop immediately) 

Immediately after a stop request is received, the coil output 
of the operation output is turned off and stopped. The state 
remains active. 

Immediately after a stop 
request is received, the 
coil output of the 
operation output is turned 
off and stopped. The 
state remains active. 

ON 
(Stop after 
transition) 

After the transition is completed, the process terminates the 
step, and at the same time, the transition destination step 
becomes active and stops before the operation output is 
executed. 

SM325 = ON 
(Keep Coil 
Output) 

OFF or not set 
(stop immediately) 

Immediately after a stop request is made, the motor stops 
while maintaining the coil output of the operation output. The 
state remains active. 

Immediately after a stop 
request is made, the 
motor stops while 
maintaining the coil 
output of the operation 
output. The state remains 
active. 

ON 
(Stop after 
transition) 

The operation is the same as usual until the transition is 
completed. After the transition is completed, the process 
terminates the step, and at the same time, the transition 
destination step becomes active and stops before the 
operation output is executed. 

Resume Normal operation returns. 

Resumes the operation 
output in the retained 
state, and also checks the 
transition conditions. 

By using the transition condition as the 
condition for starting the rise pulse operation, 
step (1) is started only for one scan at the time 
X0 turns ON. 

Even if you move from step (1) to step (2) and 
step (1) becomes inactive, step (1) does not 
start unless X0 turns OFF → ON again. 

Operation HOLD Step (With Transition Check) 

 If the transition condition is satisfied, the operation output of the step is continued. 
 Check transition conditions immediately after step 
 Transition conditions use instructions for startup execution, such as PLS instructions 
 OFF the output held by the end step, SFC control command, SFC information device, etc. 
 When the operation output flag (SM325) is ON/OFF, the coil output at block stop is switched 

to ON hold/OFF. 
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2.5.7 Reset Step [R] 

 The reset step [R] deactivates the specified step in the local block before executing the scan 
operation outputs every time. This is the same as a normal step (no attribute) except that the 
specified step is reset. 

 If the specified step No. is S999, all the HOLD steps [SC, SE, ST] held in the local block are 
deactivated. In this case, only the HOLD step [SC, SE, ST] that is being held can be 
deactivated. If the operation HOLD step [SE, ST] is not held, it is not disabled. 

 The local step No. cannot be specified as the specified step No. 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  

 

 

Reset Step 

 Step of deactivating holding step* 
 
*Holding step: a step in which the step attribute is set to coil holding step [SC], operation holding step (no 
transition check) [SE], operation holding step (transition check) [ST], and the transition condition is 
satisfied, and the step is held. 
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2.5.8 Block Startup Steps (With Exit Check) [BC] 

The block start step (with completion check) activates the specified block. 

When the specified block becomes inactive and the transition condition is satisfied, the activity shifts 
to the next step. 

The block start step (with end check) can be used to subdivide blocks. This is useful, for example, 
when a machining process is set as a separate block on a machining line, and when machining is 
completed, the process returns to the starting source and moves to the next process. 

  

 

 

(1) Simultaneous block startup 

When a block is started at the same time or when a block that has already been started is 
started, the operation settings for dual block start are used. 

For details, see 3.4.1 Operation setting for block dual start. 

Only one block can be specified. To start multiple blocks at the same time, use a parallel 
branch and use multiple block start steps. 

 

(2) Cautionary Notes 

 Action output cannot be created for block start step (with end check) [BC]. 
 Block start step (with end check) [BC] cannot be created immediately before parallel join. Use 

the block start step (no end check) [BS] to create a parallel join immediately before joining it. 
 

Block start step (with end check) When [BC] is 
activated, block (BL1) is started (1). 

No processing is performed until execution of 
the startup block (BL1) ends and the system 
becomes inactive, and the transition condition 
(2) is not checked. 

When block (BL1) finishes executing and 
becomes inactive, only the transition condition 
(2) is checked, and when the transition 
condition (2) is satisfied, the process proceeds 
to the next step. 

Block start step (with exit check) 

 Step of activating the specified block 
 Start checking the transition conditions after the startup block becomes inactive. 
 Identical blocks cannot be started at the same time 
 Parallel branching allows multiple blocks to be started simultaneously 
 Cannot be created immediately before joining parallel joins 
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2.5.9 Block Startup Step (No Exit Check) [BS] 

The block start step (no end check) activates the specified block. 
When the transition condition is satisfied, the activity shifts to the next step. 
This block start step (no end check) can be used for asynchronous processing.  

 

  

(1) Simultaneous block startup 

When a block is started at the same time or when a block that has already been started is 
started, the operation settings for dual block start are used. 

For details, see 3.4.1 Operation setting for block dual start. 

Only one block can be specified. To start multiple blocks at the same time, use a parallel 
branch and use multiple block start steps. 

 

(2) Cautionary Notes 

 Action output cannot be created for block start step (no end check) [BS]. 
 You can create a block start step (no end check) immediately before a parallel join. 

 

 

 

 

 

After the block (BL1) is started by the 
block start step (no end check) [BS], 
only the transition condition (2) is 
checked, and if the condition is 
satisfied, the process proceeds to the 
next step without waiting for the start 
block (BL1) to finish. 

Block start step (with exit check) 

 Step of activating the specified block 
 After starting the specified block, only the transition condition is checked. 
 Identical blocks cannot be started at the same time 
 Parallel branching allows multiple blocks to be started simultaneously 
 Can be created just before joining parallel joins 
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2.5.10 End step 

The end step is to terminate the block. 

 When the activity shifts to the end step and there is no active step other than the HOLD step 
in the block, all the HOLD steps [SC, SE, ST] in the block are deactivated and the block is 
terminated. 

 If an active step other than the one being held exists in the block, the following processing is 
performed according to the status of SM328 (clear processing mode upon arrival of END step). 
 

Status of the SM328 Contents 

OFF (default) 
Performs clearing processing. 
Kills all active steps remaining in the block and terminates the block. 

ON 
Does not perform clearing processing. 
Continues execution of the block without terminating the block. 

 

 When clearing processing is executed, all coil output by OUT command is turned off. 
However, for the coil output of the HOLD step [SC, SE, ST], the following processing is 
performed according to the status of SM327 (output when the END step is executed). 
 

Status of the SM327 Contents 

OFF (default) Turns OFF all output of the HOLD step [SC, SE, ST]. 

ON 

Retains all output of the HOLD step [SC, SE, ST]. 
The setting of the SM327 is valid only for the HOLD step [SC, SE, ST] that is 
being held. The output of all the hold steps [SC, SE, ST] whose transition 
conditions have not been satisfied and are not held are turned OFF. Even when 
the SM327 is ON, the step is inactive. 
However, in the case of forced termination by a block termination command, the 
coil output of all steps is turned off. 

  

 Indicates how to start the block again after the block ends. 
 

Items Contents 

Block0 

For Block0 in the SFC setting 
of the parameter 
Set the start condition to "start 
automatically" 

The initial step is automatically reactivated and repeated 
processing is executed. 

For Block0 in the SFC setting 
of the parameter 
Set the start condition to "Do 
not start automatically" 

Restart the specified block when a start request is made in 
the following way: 

 Activate the block activation step in another block. 
 Execute the SET command (block start) of the SFC 

control command. 
 Turn ON the block start end bit of the SFC 

information device. 
non-Block0 
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(1) Cautionary Notes 

 Operation output cannot be created at the end step. 
 The setting of SM327 (output when the END step is executed) takes effect only when the 

activity shifts to the end step. In case of forced termination by RST command (block 
termination), the coil output of all steps is turned OFF. 

 If only the HOLD step [SC, SE, ST] remains when the activity shifts to the end step, the 
HOLD step [SC, SE, ST] becomes inactive even if the SM328 (clear processing mode when 
the END step arrives) is ON. If you do not want to turn off the coil output of the HOLD step 
[SC, SE, ST], turn on the SM327. The operation relationship between the SM328 and the 
HOLD step [SC, SE, ST] is shown below. 
 

When the normal active step remains or the HOLD 
step [SC, SE, ST] where the transition has not been 

established remains (non-HOLD) 
Remaining active steps during HOLD 

 If the SM328 is OFF, it is cleared and the 
block is terminated. 

 If the SM328 is ON, processing continues 
without clearing. 

 Clears and terminates the block regardless 
of the SM328 setting. 

 

 If the SM328 is ON, processing returns to the original block when the block started by the 
block start step no longer contains a non-HOLD active step. 

 Make sure that the transition condition after the operation HOLD step (with transition check) 
[ST] is not always satisfied. If the transition condition immediately after the operation HOLD 
step (with transition check) [ST] is always satisfied, the next step is always in the active 
state, and blocks cannot be terminated when the SM328 is turned on. 

 

  

End Step 

 When there is no active step other than the holding step in the block, all the holding steps [SC, 
SE, ST] in the block are deactivated and the block is terminated. 

 By using SM327 (output during END step), coil output during holding step is maintained. 
 Regarding block restart, Block0 can be automatically started after the end step is executed, 

but Block1~319 must be started programmatically. 
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2.5.11 Instructions that cannot be used for operation output 

Some instructions cannot be used in the operation output. The following instructions cannot be 
used: 

Classification Instruction 

Master control instruction 
MC *1 
MCR *1 

Termination instruction 
FEND 
END 

Program branch instruction 

CJ *1 
SCJ *1 
JMP *1 
GOEND 

Program execution control instruction IRET 

Structured instruction 
BREAK *1 
RET 

Transition condition dummy output TRAN 

 

*1 Available in function/function blocks in operation output. 

 

  

Point 

Be sure to create a contact for each instruction input condition in the circuit in the detailed representation.
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2.6 Transition Conditions 

The transition condition is the basic unit for constructing a block, and when the condition is satisfied, 
the activity shifts to the next step. 

  

a) Transition Condition Name 
b) Transition Condition No. 
c) Detailed representation of transition conditions 
d) Direct representation of transition conditions 
e) Transition Criteria Labels/Devices 

 

Detailed expressions for transition conditions can be created in ladder, ST, and FBD/LD languages. 
For ladder language, you can switch between detailed expressions and MELSAP-L (Instruction 
format). 
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2.6.1 Types of Transition Conditions 

The types of transition conditions are as follows: 

Items Contents 

Series 
Sequence 

 

When the transition becomes TRUE, the active state 
transitions from the preceding step to the 
subsequent step. 

Selective 
Sequence 
(Divergence/ 
Convergence) 

 

Divergence: A step branches to multiple transitions, 
and only the step in the line where the transition 
becomes TRUE first is activated. 
 
Convergence: The next step is activated when the 
transition immediately before convergence, which is 
in the line where the transition becomes TRUE first, 
becomes TRUE. 

Simultaneous 
Sequence 
(Divergence/ 
Convergence) 

 

Divergence: All the steps branched from one step 
are activated simultaneously. 
 
Convergence: When all the steps immediately before 
convergence are activated and the common 
transition becomes TRUE, the active state transitions 
to the next step. 

Jump 
Sequence 

 

When the transition becomes TRUE, the active state 
transitions to the specified step in the same block. 

 

 

  

Point 

For the operation of transition to the step, which is already activated, refer to the following. 3.4.1 
Operation setting at block dual start. 
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2.6.2 Series Sequence 

When the transition becomes TRUE, the active state transitions from the preceding step to the 
subsequent step.  

  

 

 

2.6.3 Selective Sequence (Divergence/ Convergence) 

A step branches to multiple transitions, and only the step in the line where the transition becomes 
TRUE first is activated. The next step is activated when the transition immediately before 
convergence, which is in the line where the transition becomes TRUE first, becomes TRUE. 

Items Contents 

Divergence 

 

When the step (1) is active, the step (4) or 
(5) is activated depending on which of the 
transition (2) and transition (3) becomes 
TRUE first. 
The step (1) becomes inactive. However, if 
it is a HOLD step [SC, SE, ST], the step 
holds the coil output or action according to 
its attribute. 
・If multiple transitions become TRUE 

simultaneously, the condition to the left will 
take precedence. 

・Subsequent processing will proceed 

from step to step in the selected column 
until another convergence occurs. 

Convergence 

 

When the transition (1) or transition (2) on 
the activated branch becomes TRUE, the 
step (5) is activated. 
The activated step (3) or step (4) becomes 
inactive. However, if it is a HOLD step [SC, 
SE, ST], the step holds the coil output or 
action according to its attribute. 

 

  

 

When the transition (2) becomes TRUE 
while the step (1) is active, the step (1) 
is deactivated, and the step (3) is 
activated. 
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In selective transition, you can branch to a maximum of 32 transition conditions. 

If multiple transition conditions are satisfied at the same time, the transition conditions on the left 
have priority. 

 

 

 

 

 

 

 

 

You can also create SFC diagrams with different number of branches and joins for selection 
transition. However, you cannot create SFC diagrams of a combination of selective branches and 
parallel joins, or a combination of parallel branches and selective joins. 

In selection transition, you can skip joins by jump transition and end steps. 

  

 

 

 

 

Point 

The above program can be created by changing the steps other than the left end of the selected branch 
to the end step and changing the end step at the left end of the selected branch to the jump transition. 
For the operation method to change the step, refer to the following manual. 
GX Works3 Operating Manual 

If the transition conditions (1) and (2) 
are satisfied at the same time, the 
operation output of step (3) is executed. 

If the transition condition (2) is satisfied during the operation output 
of step (1), steps (3) to (4) are executed in order. When the 
transition condition (5) is satisfied, the jump transitions to step (1). 
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(1) Actions appropriate for selective transition 

Select transition is used when the previous operation is common, and you want to change the work 
from the middle of the process according to conditions. 

For example, a conveyor can be used to transport multiple types of parts to a machining table, and 
the machining method is controlled differently depending on the type of parts delivered to the 
machining table. 

 

 

 

 

 

  

 

Selective transition 

 Of multiple steps connected in parallel, only the step for which the transition condition is satisfied 
earliest is activated. 

 Up to 32 steps can be selected. 
 If multiple transition conditions for the selected step are satisfied at the same time, priority is 

given to the transition conditions on the left side. 
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2.6.4 Simultaneous Sequence (Divergence/ Convergence) 

In parallel transition, activity moves from one step to all the multiple branched steps at the same 
time. If all the steps immediately before the connection are activated, the activation moves to the 
next step when the common transition conditions are satisfied. 

Items Contents 

Divergence 

 

When the transition (2) becomes TRUE 
while the step (1) is active, both step (3) 
and step (4) are activated at the same 
time. 

The step (1) becomes inactive. However, if 
it is a HOLD step [SC, SE, ST], the step 
holds the coil output or action according to 
its attribute. 

Processing will proceed to step (7) when 
transition (5) becomes TRUE, and to step 
(8) when transition (6) becomes TRUE. 

Convergence 

 

When the transition (3) and transition (4) 
become TRUE while the step (1) and step 
(2) are active, the step (5) and step (6) are 
activated. 

After the step (5) and step (6) immediately 
before the convergence become active, 
the transition (7) is checked and then 
becomes TRUE, the step (8) is activated. 

The step (5) and step (6) become inactive. 
However, if it is a HOLD step [SC, SE, 
ST], the step holds the coil output or action 
according to its attribute. 
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The simultaneous sequence allows transitions to up to 32 steps. 

If another block is started by the simultaneous sequence, the START source block and START 
destination block will be executed simultaneously. 

A simultaneous convergence is always performed after a simultaneous branch. 

 

(1) Cautionary Notes 

When the steps connected by a convergence include HOLD steps [SC, SE, ST] that hold 
operations, the operation is performed as follows. 

Items Contents 

Coil HOLD step [SC] 

Like the inactive step, it does not move to the next step. Operation HOLD step (without 
transition check) [SE] 

Operation HOLD step (with 
transition check) [ST] 

If the other connected steps are active, the process moves to the 

next step. 

 

In the simultaneous convergence, a block start step (with END check) [BC] cannot be created 
immediately before the convergence. Use a block start step (without END check) [BS]. 
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(2) Processing Suitable for Parallel Transition 

Parallel transition is used to reduce the interlock condition when the previous transition condition is 
satisfied and multiple operations are started at the same time, and the termination conditions for 
each operation are different. 

For example, a part is set on a machining table, and multiple drilling operations are performed on 
the same part. 

By using parallel transition, you can create programs that are easier to see and reduce interlocks. 

 

(a) Without parallel transition 
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(b) When using parallel transition 

 

 

 

 

 

  

Parallel Transition 

 When the transition condition is satisfied, all steps connected in parallel are executed. 
 Up to 32 simultaneous steps 
 Need to align the number of branches and joins 
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2.6.5 Jump Sequence 

When the transition becomes TRUE, the active state transitions to the specified step in the same 
block. 

  

 

There are no restrictions regarding the number of jump sequences. 

A jump sequence in the simultaneous sequence is possible only in the same branch. A jump 
sequence to another branch within a simultaneous branch, a jump sequence for exiting from a 
simultaneous branch, or a jump sequence to a simultaneous branch from outside a simultaneous 
branch cannot be created. 

 

Example of jump sequence that can be specified in the simultaneous branch  

 

  

 

 

 

 

 

 

When the transition (2) becomes TRUE 
while the step (1) is active, the step (3) 
is activated. 
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(1) Cautionary Notes 

Under the following conditions, a step cannot be specified as the destination of jump sequence. 

 When a step at the position escaping from a simultaneous sequence is specified 
 When a step at the position entering a simultaneous sequence is specified 
 When a step immediately before the preceding transition is specified 
 When current step is specified 

 
(2) Processes suitable for jump transitions 

Jump transition is used to perform the same task repeatedly without restarting the system by 
performing block end processing each time. 

For example, if the continuous operation command is ON when one cycle of work is completed, the 
initial step can be used again. 

  

 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

Jump Transition 

 When the transition condition is satisfied, the activity shifts to the specified step in the same 
block. 

 Jump transitions within parallel transitions can only be used within the same branch 
 Jump transition to own step is prohibited 

Block end 
processing is 
performed when 
cycle stop is ON. 

If continuous operation 
is ON, jump to S0 (Initial 
Step). 

Joint Operation Cycle Stop 
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2.6.6 Instructions that can be used in transition conditions 

The following table lists the instructions that can be used in transition programs. Classification 
instruction symbol 

Classification Instruction symbol 

Contact instruction 

LD, LDI, AND, ANI, OR, ORI 

LDP, LDF, ANDP, ANDF, ORP, ORF 

LDPI, LDFI, ANDPI, ANDFI, ORPI, ORFI*1 

Association instruction 

ANB, ORB 

INV 

MEP, MEF 

EGP, EGF*1 

Comparison operation 
instruction 

LD, LD_U, AND, AND_U, OR, OR_U 

LDD, LDD _ U, ANDD, ANDD _ U, ORD, ORD _ U 

Real number instruction 
LDE, ANDE, ORE 

LDED, ANDED, ORED 

Character string processing 
instruction 

LD$, AND$, OR$ 

Creating a dummy transition 
condition 

TRAN*2 

 

*1 The EGP and EGF instructions cannot be used in a transition program created in ST or FBD/LD. 

*2 The LDPI, LDFI, ANDPI, ANDFI, ORPI, ORFI, and TRAN instructions cannot be used in a 
transition program created in MELSAP-L (instruction format).  
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2.7 SFC control instruction 

SFC control instructions are used to check a block or step operation status (active/inactive), or to 
execute a forced start, end, or others. If SFC control instructions are used, SFC programs can be 
controlled from the actions of sequence programs and SFC programs. 

The following table lists the SFC control instructions. 

Instruction name Instruction symbol Processing 

Checking the status 
of a step 

LD, LDI, AND, ANI, OR, ORI [S]*1 Checks whether the specified step is 
active. LD, LDI, AND, ANI, OR, ORI [BL \S] 

Checking the status 
of a block 

LD, LDI, AND, ANI, OR, ORI [BL] Checks whether the specified step is 
active. 

Batch-reading the 
status of steps 

MOV (P) [K4S] *1 Batch-reads (in units of 16-bit binary 
data) the status (active or inactive) of 
steps in a specified block and stores the 
read data in a specified device. 

MOV (P) [BL\K4S] 

DMOV (P) [K8S] *1 Batch-reads (in units of 32-bit binary 
data) the status (active or inactive) of 
steps in a specified block and stores the 
read data in a specified device. 

DMOV (P) [BL\K8S] 

BMOV (P) [K4S] *1 Batch-reads (in units of the specified 
number of words starting from a 
specified step) the status (active or 
inactive) of steps in a specified block. 

BMOV (P) [BL\K4S] 

Starting a block SET [BL] 
Activates a specified block and 
executes a step sequence starting from 
an initial step. 

Ending a block RST [BL] Deactivates a specified block. 

Pausing a block PAUSE [BL] 
Temporarily stops a step sequence in a 
specified block. 

Restarting a block RSTART [BL] 

Releases the temporary stop and 
restarts the sequence from the step 
where the sequence was stopped in the 
specified block. 

Activating a step 
SET [S] *1 

Activates a specified step. 
SET [BL\S] 

Deactivating a step 
RST [S] *1 

Deactivates the specified step. 
RST [BL\S] 

Switching a block BRSET 
Specifies a target block No. of SFC 
control instruction. 

 

*1 When using in a sequence program, Block0 is the target block. When using in a SFC program, 
current block is the target block. 
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For details on the SFC control instructions, refer to the following: 

MELSEC iQ-R Programming Manual (CPU Module Instructions, Standard Functions/Function 
Blocks)  

 

(1) Cautionary Notes 

 Do not use the SFC control instructions in interrupt programs. 
 Execute the SFC control instruction only when SM321 (SFC program start/stop) is on. 
 Step relay can be used only with the following instructions. 

o Step activation check, batch reading of activated steps, step start, step end 
 Step relay specifies the step in the running block. Therefore, to specify a step for a specific 

block, use BL\S. 
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2.8 Information Device for SFC 

SFC information device is the device or label which operates the forced start/termination and 
pause/restart direction to a block, check of the status of transition and the number of active steps, or 
direction of continuous transition operation of a transition. 

SFC information device is set every block. 

[Navigation window] > [Program] > SFC program file > Properties of block to be set 

 

The following shows the types of information devices for SFC and the devices that can be used. 

Items Contents 
Available Data 

Device 
Data Type 
(Label) 

Block 
START/END Bit 

Sets the device or label to check whether the block is active. 
Setting the bit to ON can start the block and setting it to off can 
end the block. 

Bit: Y, M, L, F, 
V, B 
Word: Bit 
specification of 
D, W, RD 

Bool, 
Boolean 
array, INT bit 
specification, 
Word bit 
specification 

Step Transition Bit 

Sets the device or label to check whether the transition of the 
step being executed becomes TRUE. 
This bit turns on when the transition to the next step becomes 
TRUE after execution of the action of each step. 

Block 
PAUSE/RESTART 
Bit 

Sets the device or label to pause or restart an active block. 
Setting the bit to on stops the block at the step-in execution 
and setting it to off restarts executing the block from the step 
where the block was stopped previously. 

Block Stop Mode 
Bit 

Sets the device or label that decides the timing for stopping a 
block. 
Setting the bit to on stops the block after transition of each step 
and setting it to off stops all steps immediately. 

Continuous 
Transition Bit 

Sets the device or label that decides the continuous transition 
action when the transition becomes TRUE. 
Setting the bit to on enables continuous transition and 
accordingly the action of the next step is executed in the same 
scan. Setting the bit to off disables continuous transition and 
accordingly one step is executed every scan. 

Number of Active 
Steps Register 

Sets the device or label in which the number of currently active 
steps of a block is to be stored. 

D, W, R, ZR, 
RD 

INT, WORD 

 

You can specify global or local labels as well as global or local devices for the SFC information 
device. You cannot use indirect specification, digit specification, or index qualification (Z, LZ). 
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2.8.1 Block START/END bit 

This bit is a device or label to check whether the block is active. 
Setting the bit to ON can start the block and setting it to off can end the block. 
If a program to start a block is not available or because the START/END of a block can also be 
controlled from the engineering tool, this device or label can be used for debugging or test operation 
in units of block. 

 When the set block starts, the block START/END bit is automatically turned on. While the set 
block is active, the block START/END bit stays on. 

 When the set block becomes inactive, the block START/END bit is automatically turned off. 
While the set block is inactive, the block START/END bit stays off. 

 

M0 is specified in the block START/END bit of Block1 (BL1).  

 

 

 

 

 

 

 

 

 When the block START/END bit is turned on while the set block is inactive, the block is 
started independently. 

 When the block START/END bit is turned off while the set block is active, the block is ended. 
 
The block START/END bit can also be turned on or off by the test operation of the engineering tool. 
(GX Works3 Operating Manual) 
 
When the block START/END bit is turned off to make the set block inactive, processing will occur as 
follows: 
 
 Execution of the set block is stopped, and the outputs of the step being executed are all turned off. However, the 

devices turned on by using the SET instruction will not be turned off. 

 If another block has been started by a block start step in the set block, the set block ends but the start destination 
block will remain active and continue processing. 

 

 

 

 

(1) Block1 (BL1) starts and M0 turns on. 

(2) Block1 becomes inactive and M1 turns off. 

Selective transition 

By changing the current value of BL or BL\S from watch window of the engineering tool, the status 
of a block (START/END) or a step (active/inactive) can be changed. 
Also, the status of the specified step (active/inactive) is changed from the menu [Debug] > [Control SFC 
Steps]. (GX Works3 Operating Manual) 
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(1) Cautionary Notes 

The following table shows the restart operation after the set block is deactivated. 

Set Block  Contents 

Block0 

When the start conditions setting of 
is "Auto-start Block0" in the SFC 
setting of the CPU parameter. 

Operation is restarted from the initial step 
following end step processing. 

When the start conditions setting of 
is "Do not auto-start Block0" in the 
SFC setting of the CPU parameter. 

The block is deactivated after end step 
processing, and processing is restarted 
from the initial step when another start 
request occurs for that block. Other than Block0 

 

When the SFC program ends, all block START/END bits that have been set in the SFC information 
devices are turned off. However, only when a resume start is enabled with the resume start setting, 
all blocks START/END bits are restored when the SFC program starts. 

If the block to which the block start end bit is set is being written during the SFC inactive block RUN, 
start is ignored. Therefore, do not turn ON the block start end bit while writing during the SFC 
inactive block RUN. 

 

 

 

 

 

 

 

 

 

 

  

 

Block START/END bit 

 Can be used as a device to check the active status of a specified block 
 Can also be used to start and end specified blocks 

o By creating an SFC program by dividing blocks for each device and setting block start 
and end bits, it is possible to check and debug the operation on a per-device basis. 
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2.8.2 Step transition bit 

This bit is a device or label to check whether the transition of the step being executed becomes 
TRUE. 
This bit turns on when the transition to the next step becomes TRUE after execution of the action of 
each step. 
A step transition bit which is on is automatically turned off when processing of the specified block is 
performed again. 

Example: M1 is specified in the step transition bit of Block0  
 

 

If the continuous transition bit is turned on and set to "Continuous transition", the step transition bit 
will remain on during the action of the next step after the transition becomes TRUE. It will also 
remain on following the execution of multiple steps, even if the transition becomes FALSE. In these 
cases, the step transition bit will be turned off when the specified block is executed in the next scan. 

 

When multiple active steps exist in the block, the step transition bit turns on when one of the 
transitions becomes TRUE. 

(1) Cautionary Notes 

 When the end step is executed, the step transition bit of the block is turned on. The step 
transition bit remains on until the block is reactivated next. 

 The step transition bit is not turned off when the SFC program starts or ends. 
 

If transition (2) becomes TRUE after execution of step (1), M1 is 
on during execution of another block. 
M1 is turned off at the time of Block0 processing in the next scan. 
If transition (4) does not become TRUE after execution of step 
(3), M1 stays off. 
If transition (4) becomes TRUE, M1 is on during execution of 
another block. 
If transition (6) does not become TRUE after execution of step 
(5), M1 stays off. 

If transition (2) becomes TRUE after execution of 
step (1), M1 is turned on. 
Even if transition (4) does not become TRUE, M1 
stays on. 
M1 is turned off at the time of Block0 processing in 
the next scan. 
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2.8.3 Block PAUSE/RESTART bit 

This bit is a device or label to pause or restart an active block. 

Setting the bit to on stops the block at the step-in execution and setting it to off restarts executing 
the block from the step where the block was stopped previously. 

Settings Contents 

OFF → ON When OFF → ON is selected, the specified block stops at the step being executed. 

ON → OFF When ON → OFF is selected, execution of the specified block resumes from the 
operation output of the stopped step. 

 The operation HOLD step (without transition check) [SE] or the operation HOLD step 
(with transition check) [ST] stopped in the operation HOLD state resumes execution 
in the operation HOLD state. 

 If the coil HOLD step [SC] is stopped by setting the coil output OFF (SM325 = OFF), 
it becomes inactive and cannot be resumed. When the tester is stopped with the coil 
output hold setting (SM325 = ON), the HOLD status is maintained even after the 
tester resumes operation to maintain the HOLD status. 

 

 

 If another block has been started by a block start step, turning on the block PAUSE/RESTART 
bit stops the specified block, but the start destination block will remain active and continue 
processing. To stop the start destination block at the same time, the start destination's block 
PAUSE/RESTART bit must also be turned off. 

 When the block PAUSE/RESTART bit specified in an inactive block is turned on, the block does 
not operate in inactive state and is put in the stopped state immediately when it becomes active. 

 Even after the specified block is forcibly terminated, the state of the block PAUSE/RESTART bit 
remains held. If the block is forcibly terminated while it is stopped and the status of the block 
PAUSE/RESTART bit is not changed, the block is put in stopped state immediately after the 
restart. 
 

Operation when the block is paused or restart depends on the combination of the SM325 (Output 
mode at block stop) status, block stop mode bit setting of the SFC information device, and step hold 
status.  
 
(1) Cautionary Notes 

The block PAUSE/RESTART bit is not turned off when the SFC program starts or ends. 

 

 

 

 

Stop restart bit 

 When the block stop restart bit is turned on, the corresponding block is paused. 
 When the block stop restart bit is turned off, the pause of the corresponding block is released. 
 Operation in conjunction with block stop instruction (PAUSE [BL]) and block resume instruction 

(RSTART [BL]) of SFC control instruction. 
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2.8.4 Block stop mode bit 

This bit is a device or label that determines the timing for stopping a block. 

Setting the bit to on stops the block after transition of each step and setting it to off stops all steps 
immediately. 

Settings Contents 

OFF (immediate stop) When a stop request is issued, the system immediately enters the stop status. 

When ON (stop after 
transition) 

After a stop request is received, the transition conditions for the step being 
executed are satisfied, and the process stops when it is migrated. 

The operation output of the step after transition is not executed. 

If there are multiple active steps in a block, the process stops sequentially, starting 
with the step for which the transition was completed. 

The held step stops immediately after the stop request is made, regardless of the 
setting of the block stop mode bit. 

 

Operation when the block is paused or restart depends on the combination of the SM325 (Output 
mode at block stop) status, block stop mode bit setting of the SFC information device, and step hold 
status.  

(1) Cautionary Notes 

The block stop mode bit is not turned off when the SFC program starts or ends. 

 

 

 

 

 

 

 

  

 

Mode bit at block stop 

 When the block stop mode bit is OFF, a stop request is issued to the block. 
o Stop Block Now 

 When the block stop mode bit is ON, a stop request is issued to the block. 
o When the transition condition of the step being executed is satisfied and the process is 

moved, the process stops. 
 The holding step stops immediately after the stop request regardless of the setting of the block stop 

mode bit. 
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2.8.5 Continuous transition bit 

This bit is a device or label that determines the continuous transition action when the transition 
becomes TRUE. 

Setting the bit to on enables continuous transition and accordingly the action of the next step is 
executed in the same scan. Setting the bit to OFF disables continuous transition and accordingly 
one step is executed every scan. 

Settings Contents 

Off (no continuous 
transition) 

When the transition becomes TRUE, the action of the transition destination 
step is executed in the next scan. 

On (continuous 
transition) 

When the transition becomes TRUE, the action of the transition destination 
step is executed within the same scan. 
When the transition of the steps become TRUE continuously, the actions are 
executed within the same scan until the transition becomes FALSE or reaches 
the end step. 

 

Example: The continuous transition bit of an SFC information device is specified. 

 

Scan Contents 

Scan 1 After execution of the sequence program (1), steps (2) to (5) of the SFC program are 
executed continuously. 

Scan 2 and after After execution of the sequence program (1), the action of step (2) is executed until 
the transition (6) becomes TRUE. 

 

 When the continuous transition bit is set, a continuous transition is disabled while the set bit device 
is off and is enabled when the bit device is on, regardless of the on/off state of SM323 (All-blocks 
continuous transition status). When the continuous transition bit is not set, a continuous transition 
is disabled while SM323 is off and is enabled when it is on.  

 SM324 (Continuous transition disable flag) is turned on automatically by the system at SFC 
program execution but is off during continuous transition. Use of SM324 under the AND condition 
in a transition disables a continuous transition.  
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(1) Behavior with/without Continuous Transition 

The SFC program transition conditions are "With Continuous Transition" and "Without Continuous 
Transition". 

The setting with or without continuous transition depends on the setting of the continuous transition 
bit of the SFC information device and the SM323 (with or without full block continuous transition). 

Continuous 
Transition 
bit 

SM323 Contents 

No setting OFF No 
Continuous 
transition 

When the transition condition is satisfied, the operation output of 
the transition destination step is executed for the next scan. 

ON With 
Continuous 
Transition 

When the transition condition is satisfied, the operation output of 
the transition destination step is executed within the same scan. 
If the transition conditions of the steps are satisfied continuously, 
the processes are executed in the same scan until the transition 
conditions fail or the end step is reached. 

OFF ON/OFF No 
Continuous 
transition 

When the transition condition is satisfied, the operation output of 
the transition destination step is executed for the next scan. 

ON ON/OFF With 
Continuous 
Transition 

When the transition condition is satisfied, the operation output of 
the transition destination step is executed within the same scan. 
If the transition conditions of the steps are satisfied continuously, 
the processes are executed in the same scan until the transition 
conditions fail or the end step is reached. 

 

 

 

 

When M0 is on, one scan causes continuous transitions from 
steps (1) to (3). 
Since SM324 is added as the AND condition to the transition (4), 
the transition (4) after execution of step (3) does not become 
TRUE. 
In the next scan, SM324 is turned on after step (3) and therefore 
a transition to step (5) occurs within the scan. 

Point 

 You can shorten the operating time by setting "With Continuous Transition". This eliminates the wait 
time between the completion of the transition condition and the execution of the operation output at 
the destination step. 

 However, setting "With Continuous Transition" may slow down other block or sequence programs. 
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(2) Cautionary Notes 

 If the continuous transition bit is turned on, execution of actions (from a transition becoming 
TRUE to destination step) takes priority over the other processing. This can shorten a takt 
time. In this case, however, the operations of the other blocks and sequence program may 
become slower. 

 The continuous transition bit is not turned off when the SFC program starts or ends. 
 When a jump transition or selective convergence causes the active state to transition from 

multiple steps to one step, the action of one step may be executed twice in a single scan. 
 

  

 If the transition after the step becomes TRUE with the setting of "Continuous transition", a step 
is started or ended within one scan. In this case, since the END processing has not been 
executed, the input/output refresh of coil output by using the OUT instruction in the action is 
not reflected and therefore other programs cannot detect ON of the coil. In the case of output 
(Y), for example, output (Y) is not output while END processing is unexecuted and other 
programs cannot detect output (Y) ON. Accordingly, ON of the step relay cannot be detected, 
either. To reflect the I/O refresh of the OUT instruction, create a program so that one step is 
executed in multiple scans.  

 

 

  

 When creating a program that uses a jump sequence for looping, eliminate continuous 
transitions or prevent all transitions in the loop from becoming TRUE during execution. If all 
transitions in the loop become TRUE during execution with continuous transitions enabled, an 
infinite loop occurs in a single scan. 

 

 

When the transition (1) and (2) become TRUE, the following is 
executed in one scan. 
 The action of step (3) is executed. 
 As the transition (1) becomes TRUE, the action of step (3) is 

turned off. 
 Step (3) becomes inactive, and step (4) becomes active. 
 As continuous transitions are enabled, the action of step (4) 

is executed. 
 As the transition (2) becomes TRUE, the action of step (4) is 

turned off. 
 Step (4) becomes inactive, and step (5) becomes active. 
 As continuous transitions are enabled, the action of step (5) 

is executed. 
 As the transition (6) does not become TRUE, the action of 

step (5) is not turned off. 

When the setting is "Continuous 
transition", step (1) is executed twice 
in a single scan. 
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2.8.6 Number of Active Steps Register 

This register is a device or label in which the number of active steps of a block is to be stored. 
The number of active steps stored in the number of active steps register includes the following 
steps. 

 Normal active step 
 Coil HOLD step [SC] that holds the operation 
 Operation HOLD step (with transition check) [ST] that holds the operation 
 Operation HOLD step (without transition check) [SE] that holds the operation 
 Steps that stop each operation 

 
(1) Cautionary Notes 

 When a block ends, the number of active steps register becomes 0. 
 The register does not become 0 when the SFC program ends but becomes 0 when the 

program starts. 
 

 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Number of Active Steps Register 

 Stores the number of currently active steps in the block 
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2.9 SFC Program Processing Order 
2.9.1 Execution order of each Block 

While the SFC program is running, the actions of each step are executed sequentially starting from 
the initial step of an active block. 
 
An SFC program containing multiple blocks checks the state (active/inactive) of the blocks in 
ascending order of block numbers (Block0 → Block1 → Block2). 
An active block executes the actions of active steps in the block. 
 
An inactive block checks for existence of a start request. If a start request exists, the block is 
activated and the active steps in the block are executed.  
 

 

In the following order: 

(1) Begins processing Block0 (BL0). 

(2) Perform the steps in Block0 (BL0). 

(3) Performs processing for Block1 (BL1). 

(4) Perform the initial step for Block1 (BL1). 

(5) Processes the following blocks: 

 

Only Block0 can be started automatically when the Block0 AutoStart is specified in the start 
condition setting of the SFC setting. With this setting, even when Block0 reaches the end step and 
becomes inactive, it is started again in the next scan. 

A request for END, PAUSE, RESTART of a block is processed immediately before execution 
processing in the block. 

Execution order of each block  
 Check the activity in order from the young number block to the old number block. 
 Active block executes the operational output of the active step in the block. 
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2.9.2 Execution order of each Step 

In the SFC program, the actions of all active steps are processed within one scan.  

 

When the action of each step is finished, whether the transition to the next step becomes TRUE or 
not is checked. 

 When the transition has not become TRUE: The action of the same step is executed again in 
the next scan. 

 When the transition has become TRUE: The outputs of the executed actions by using the 
OUT instruction are all turned off. When the next scan is executed, the action of the next 
step is executed. The step executed previously is deactivated and the action becomes 
inactive. 

 
Even when the transition becomes TRUE, if coil HOLD step [SC] is set in the step attribute, the step 
is not deactivated but performs processing according to the attribute.  
 

 
 
(1) Execution of sequence program 
(2) Execution of action 
(3) Checking the transition to the next step (FALSE) 
(4) END processing 
(5) Checking the transition to the next step (TRUE) 
(6) The next action is executed. 
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Example: The continuous transition bit of an SFC information device is not specified.  

 

Scan Contents 

1st scan Activate step (1) and execute operation output (2). 

Second scan Activate step (3) and execute operation output (4). 

Third scan Activate Step (5) and execute the operation output (6). 

4th scan Activate step (7) and execute operation output (8). 

5th scan or later Step (7) is activated, and the operation output (8) is executed until the transition 
condition (9) is satisfied. 

 

(1) Cautionary Notes 

 As a step for which the transition becomes TRUE at the first execution is deactivated in a 
single scan, the I/O refresh of coil output is not reflected and therefore other programs cannot 
detect that the coil output is on. To reflect the I/O refresh, create a program so that one step 
is executed in multiple scans. 

 The actions of active steps in a block are executed simultaneously (within the same scan). For 
this reason, do not create SFC programs which depend on the execution sequence of actions.  
 

 

The execution order of the operation output in (1), (2), and (3) is undefined. 

 

Execution order of each Step  
 Process the operation output of the active step and the status of the transition condition to the next 

step 
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3 Create an SFC Program 

In this chapter, you will create a simple SFC program to understand the basic operations. 

 

3.1 Target system configuration 

Here is an example system configuration for illustration purposes: 

  

 

  

 

 

 

 

 

 

 

Ethernet Cable 
USB Cable 

R08CPU 
R61P 

GOT2000 

Y40 ~ Y7F X0 ~ X3F 
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3.2 Creating Programs 

This is explained from the screen after starting GX Works3. 

 

3.2.1 New Project 

[Procedure] 

Select Project > New (Alternatively, click Ctrl+N) 

 

After the above operation, the following dialog box appears. Specify the Series, Model (Type), and 
Programming Language to be used. 
 
[Settings] 

 Series:    RCPU 
 Type:    R08CPU 
 Programming Language:  SFC 
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When the following dialog box appears, click the OK button. 

 

Click the [OK] button in the following dialog box. 

 

From the Project view in the navigation window, double-click "Parameters" → "R08CPU" → "CPU 
Parameters". 
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Double-click "Memory/Device Settings" in "CPU Parameters" → "Device/Label Memory Area 
Settings" → "Device Settings". 

  

Set "1K" for the number of step relays. For details about the CPU parameters, see 3.3 SFC settings. 

  

Then, click “Apply”. 
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3.2.2 Operation screen for creating SFC program 

Next, the operation window of GX Works3 is described for creating the SFC program. 

  

 

 

(1) Navigation Pane 
Lists the projects in the same way as a regular ladder program. 

(2) Toolbar 
SFC elements, FB/LD elements, and tools necessary for creating programs are placed. 

(3) SFC Diagram Edit Area 
Place SFC elements and create an SFC diagram. 

 

To display the SFC toolbar: 

[Procedure] 

Select View > Toolbars > SFC 

 

  

 

(3) Navigation Window 

(2) Tool Bar 

(1) SFC Diagram Editor 
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3.2.3 Overview of the system program 

This project simulates an automated operation program of the transport device system shown 
below. 

 

 

 

[Operation Overview] 

(1) When the work truck stops in front of the conveyor, the alarm buzzer sounds for 3 seconds. 
(2) The conveyor starts automatically after the buzzer stops sounding. 
(3) Six products are sent to the work truck to stop the conveyor. 
(4) Work Carts Deliver Products to the Next Process by Automatic Operation 
(5) After unloading, empty and return to the front of the conveyor 

 

The assignment of devices to be used are as follows: 

X0 Operation permission switch M0 Operation command 
X1 Stop switch M1 Driving memory 
X2 Work trolley origin sensor M10 Operation permission 
X3 Work sensor M11 Operation permission memory 
X4 Work trolley forward end   
  T0 Alarm timer 
Y70 Buzzer output   
Y71 Conveyor operation C0 Work count 
Y72 Work Trolley Forward   
Y73 Work Trolley Reverse   
Y74 Work delivery   
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The following is a flowchart of the operation of the device. 

 

 

Start

Did the work trolley arrive 
at the origin?

Operation command/Buzzer 
ringing

Has 3 seconds passed 
since the work trolley 

was detected?

Conveyor start/Buzzer stop

Was 6 products sent?

Conveyor stop

Work trolley advance

Did the work trolley reach 
the forward end?

Work removal operation

Has work removal been 
completed?

Work trolley retreat

No

Yes

No

Yes

No

Yes

No

Yes

No

Yes

Driver permission 
switch on
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3.2.4 Program Creation 

Creation of SFC Program. 

In the SFC program, the blocks are divided by process, product, and control content, and 
programming makes debugging and trial operation easier. This time, the program is created by 
dividing "conveyor control" and "work truck control" into two blocks. 

The procedure for creating an automatic control program for the device described in 3.2.3 Overview 
of Creation Programs is as follows: 

(1) Block information setting 

3.2.1 In the Project view of the navigation window created in Creating a new project, right-click 
"Program" → "MAIN" → click "Open SFC Block List". 

  

 

The following block list opens: 

 

 

 

Point 

The block list can also be displayed using View > Open SFC Block List. 
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Right-click the block line you want to set in the block list and select "Properties". 

You can set block information from the properties screen. 

 

 

In the Properties window, enter the following settings: 

Block Setting 1 – Conveyor Control Block Setting 2 – Work Trolley Control 
Block No. 0 Block No. 1 
Block START/END Bit M100 Block START/END Bit M200 
Step Transition Bit M101 Step Transition Bit M201 
Block PAUSE/RESTART 
Bit 

M102 Block PAUSE/RESTART 
Bit 

M202 

Block Stop Mode Bit M103 Block Stop Mode Bit M203 
Continuous Transition 
Bit 

M104 Continuous Transition 
Bit 

M204 

Number of Active Steps 
Register 

D100 Number of Active Steps 
Register 

D200 

  

After the block information is set, the block list is displayed as follows, block No.0 and block No.1 
have been set. 

 

 

*There is no problem if the block title is not set. However, it is recommended that you set a title 
because it makes it easier to manage multiple blocks. 

*There is no problem even if the information device for SFC is not set, but by setting it, debugging 
and trial operation can be performed efficiently. 
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(2) Device Comment Settings 

Enter a device comment. Double-click "Device" → "Device Comment" → "Common Device 
Comment" in the Project view to display the device comment screen. 

 

Enter the desired device name in "Device name" and press Enter. 

Click the entry field, and then enter a comment for each device. 

  

 

  

 

 

 

 

 

 

 

 

 

 



78 
 

(3) Program to create 
 

Block No.0 "conveyor control" is as follows: 

No. Title startup 
termination 

Transition Stop 
Resume 

Stop 
mode 

Continuous Number of 
active steps 

0 Conveyor 
Control 

M100 M101 M102 M103 M104 D100 

 

  

 

Block No.1 "Work Trolley Control" is as follows. 

No. Title startup 
termination 

Transition Stop 
Resume 

Stop 
mode 

Continuous Number of 
active steps 

1 Work Trolley 
Control 

M200 M201 M202 M203 M204 D200 
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(4) Creating an SFC Diagram (Block No.0) 
 

The following shows the procedure for creating an SFC diagram when creating a program for block 
No.0. 

From the block list, select No.0 "conveyor control". 

Click the View > Open SFC Diagram menu or double-click the block you want to view. 

 

 

The SFC diagram for Block0 opens. 

 

 

*When a new SFC program is created, the above steps and serial transitions are automatically 
entered. 

Add a step using Edit > Insert > Step. You can insert different elements depending on the 
selection. 

Please refer to the following manual for details. GX Works3 Operating Manual 

  

 

 

 

 

 

 



80 
 

(a) Delete the operation output of "Initial". 

 

(b) Move the cursor to "Initial" and press Enter to open the step properties. 

 

 

Specify the following settings, and then click the OK button. 
 
[Settings] 
Data Name:   Initial 
Step No (Sn):   S0 
Device Comment:  Wait for Driver Permission 
 
*Change the attributes when the block start step (with end check), block start step (without end 
check), reset step, coil hold step, operation hold step (without transition check), and operation hold 
step (with transition check) are used. 

Point 

 Opens when you move the cursor over an already placed SFC diagram and press Enter. 
 In the Step Properties window, you can change the data name, step number, device comment, 

and attribute. 
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(c) Move the cursor to "Transition0" and press Enter to open the transition condition 
properties. 

 

 

 

 

Specify the following settings, and then click the OK button. 

[Settings] 
Data Name:    Transition0 
Type:     Detailed expression 
Transition No. (TRn):   TR0 
Device comment:   Operation permission switch ON 
  

 

 

 

 

 

 

Transition Condition Properties Window 

 Opens when you move the cursor over an already placed SFC diagram and press Enter. 
 In the transition condition properties, you can change the data name, type, transition condition, 

and device comment. 



82 
 

In the New Data window, change the program language to Ladder, and then click the OK button. 

 

 

Zoom*¹ is displayed. Enter the program in Ladder Programming Language. 

 

[Procedure] 
1. Move the cursor to the insertion point. 
2. Enter "X0" and click OK. 
3. Move the cursor to the next insertion point, enter "TRAN (dummy transition condition 

output)", and click OK. 
 
*¹: You can also double-click the action output name/transition condition name that has been set on 
the SFC diagram. 
 

(d) Click Step () on the toolbar to add a step.  

Then, delete the unnecessary "Step0" operation output. 

 

Move the cursor to “Step0” and press [Enter] to open the step properties. 

 

Point 

Double-click an unset action output name or transition condition name to display the New Data window. 
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Specify the following settings, and then click the OK button. 
 
[Settings] 
Data Name:   Step0 
Type: Normal   Step 
Step No. (Sn):  S1 
Device Comment:  Waiting for trolley detection 
 

(e) Move the cursor to "Transition1" and press Enter to open the transition condition 
properties. 

 

 

Specify the following settings, and then click the OK button. 
 
[Settings] 
Data Name:    Transition1 
Type:     Detailed expression 
Transition Condition No.:  TR1 
Device Comment:   Trolley Detection 
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In the New Data window, change the program language to Ladder, and then click the OK button. 

 

 

Enter the program in Ladder Programming Language. 

[Procedure] 
1. Move the cursor to the insertion point. 
2. Enter "X2" and click OK. 
3. Move the cursor to the next insertion point, enter "TRAN", and click OK. 

 

(f) Click Step () on the toolbar to add a step.  

Move the cursor to "Step1" and press Enter to open the step properties. 

 

 

Specify the following settings, and then click the OK button. 
 
[Settings] 
Data Name:  Step1 
Type:    Normal Step 
Step No. (Sn):  S2 
Device Comment:  Buzzer output 
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Next, set the operation output of "Step1". 

 

Press Enter to open the properties of the operation output. 

 

Set the following and click the OK button. 

[Settings] 
Data Name:  Action0 
Type:  Detailed expression 
Qualifier:  N 
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In the New Data window, change the program language to Ladder, and then click the OK button. 

 

 

Enter the program in Ladder Programming Language. 

[Procedure] 
1. Move the cursor to the insertion point. 
2. Enter "SM400" and click OK. 
3. Move the cursor to the next insertion point, enter Y70, and click OK. 
4. Create a vertical border, enter "OUT T0K 30", and click OK. 
5. Create a vertical border, enter "= K6C0", and click OK. 
6. Move the cursor to the next insertion point, enter "RST C0", and click OK. 
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(g) Move the cursor to "Transition2" and press Enter to open the transition condition 
properties. 

 

 

Set the following and click the OK button. 

[Settings] 
Data Name:    Transition2 
Type:     Detailed expression 
Transition No. (TRn):   TR2 
Device comment:   End of buzzer output 
 

In the New Data window, change the program language to Ladder, and then click the OK button. 

 

 

Enter the program in Ladder Programming Language. 

[Procedure] 
1. Move the cursor to the insertion point. 
2. Enter "T0" and click OK. 
3. Move the cursor to the next insertion point, enter "TRAN", and click OK. 
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(h) Select "Transition2" and click the Selection branch on the toolbar to add a step.  

Move the cursor to "Step2" and press Enter to open the transition condition properties. 

 

 

Set the following and click the OK button. 

[Settings] 
Data Name:    Step2 
Type:     Normal Step 
Step No. (Sn):   S3 
device comments:   Conveyor Operation 
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Next, set the operation output of "Step2". 

 

Press Enter to open the properties of the operation output. 

 

Set the following and click the OK button. 

[Settings] 
Data Name:  Action1 
Type:   Detailed expression 
Qualifier:  N 
 

In the New Data window, change the program language to Ladder, and then click the OK button. 

 

Enter the program in Ladder Programming Language. 

[Procedure] 
1. Move the cursor to the insertion point. 
2. Enter "SM400" and click OK. 
3. Move the cursor to the next insertion point, enter "Y71", and click OK. 
4. Create a vertical border, enter "X3", and click OK. 
5. Move the cursor to the next insertion point, enter "OUT C0K6", and click OK. 
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(i) Move the cursor to "Transition3" and press Enter to open the transition condition properties. 

 

 

Set the following and click the OK button. 

[Settings] 
Data Name:    Transition3 
Type:     Detailed expression 
Transition No. (TRn):   TR3 
Device Comment:   End Product Count 
 

In the New Data window, change the program language to Ladder, and then click the OK button. 

 

 

Enter the program in Ladder Programming Language. 

[Procedure] 
1. Move the cursor to the insertion point, enter "C0", and click OK. 
2. At the next insertion point, select the b contact and enter "X1". Click the OK button after 

entering. 
3. Move the cursor to the next insertion point, enter "TRAN", and click OK. 
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(j) Click Step () on the toolbar to add a step.  

Then, delete the unnecessary "Step3" operation output. 

 

Move the cursor to "Step3" and press Enter to open the step properties. 

 

 

Set the following and click the OK button. 

[Settings] 
Data Name:   Step3 
Type:    Normal Step 
Step No.   S4 
Device Comment:  Trolley Control Block Start 
Attributes:   BC 
Attribute Target: BL1 
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(k) Move the cursor to "Transition5", then right-click and select Edit > Toggle Jump 
Symbol and Connection Line. Select the step name "Step0" and press Enter. 

 

Move the cursor to "Transition 5" and press Enter to open the transition condition properties. 

 

 

Set the following and click the OK button. 

[Settings] 

Data Name:    Transition5 
Type:     Detailed expression 
Transition No. (TRn):   TR5 
Device Comment:   End of Trolley Control Block 
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In the New Data window, change the program language to Ladder, and then click the OK button. 

 

Enter the program in Ladder Programming Language. 

[Procedure] 
1. Move the cursor to the insertion point. 
2. Enter "SM400" and click OK. 
3. Move the cursor to the next insertion point, enter TRAN, and click OK. 

 

(l) Move the cursor to "Transition 4" and press Enter to open the transition condition properties. 

 

 

  

Set the following and click the OK button. 

[Settings] 
Data Name:    Transition4 
Type:     Detailed expression 
Transition No. (TRn):   TR4 
Device comments:   Stop Switch On 
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In the New Data window, change the program language to Ladder, and then click the OK button. 

 

 

Enter the program in Ladder Programming Language. 

[Procedure] 
1. Move the cursor to the insertion point. 
2. Enter "X1" and click OK. 
3. Move the cursor to the next insertion point, enter "TRAN", and click OK. 

 

m) When you are finished creating the SFC diagram, click Convert - > Convert All in the menu. 

 

 

 

 

 

 

  

 

 

 

 

 

 

 

 

 

 

 

Point 

If you want to convert only blocks in an SFC diagram, use Convert > Block Conversion from the menu.  
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(5) Creating an SFC Diagram (Block No.1) 
 

The following shows the procedure for creating an SFC diagram when creating a program for block 
No.1. From the block list, select No.1 "Work trolley control". 

Click the View > Open SFC Diagram menu or double-click the block you want to view. 

 

The SFC diagram for Block1 opens. 

(a) Select "Initial" and specify the following settings: 

 

[Settings] 
Data Name:   Initial 
Step No:   S0 
Device Comment:  Work Carriage Forward 
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Next, set the operation output of "Initial" as follows. 

 

[Settings] 
Data Name:  Action0 
Type:   Detailed expression 
Qualifier:  N 
 

In the New Data window, change the program language to Ladder, and then click the OK button. 

 

Enter the program in Ladder Programming Language. 

[Procedure] 
1. Move the cursor to the insertion point. 
2. Enter "SM400" and click OK. 
3. Move the cursor to the next insertion point, enter "Y72", and click OK. 
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(b) Select "Transition0" and set as follows: 

 

[Settings] 
Data Name:   Transition0 
Type:    Detailed expression 
Transition No. (TRn):  TR0 
Device Comment:  Work Trolley Forward End 
 

In the New Data window, select the ladder for the program language and click the OK button. 

 

 

Enter the program in Ladder Programming Language. 

[Procedure] 
1. Move the cursor to the insertion point. 
2. Enter "X4" and click OK. 
3. Move the cursor to the next insertion point, enter "TRAN", and click OK. 
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(c) Add a step and set "Step0" as follows: 

 

[Settings] 
Data Name:   Step0 
Type: Normal   Step 
Step No. (Sn):  S1 
Device Comment:  Work Export 
 
Next, set the operation output of "Step0" as follows: 

 

[Settings] 
Data Name:  Action1 
Type:   Detailed expression 
Qualifier:  N 
 

In the New Data window, change the program language to Ladder, and then click the OK button. 

 

Enter the program in Ladder Programming Language. 

[Procedure] 
1. Move the cursor to the insertion point. 
2. Enter "SM400" and click OK. 
3. Move the cursor to the next insertion point, enter "Y74", and click OK. 
4. Create a vertical border and enter "OUT T1 K30". Click the [OK] button. 
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d) Select "Transition1" and set as follows: 

 

[Settings] 
Data Name:   Transition1 
Type:    Detailed expression 
Transition No. (TRn): TR1 
Device Comment:  Work Export Time 
 

In the New Data window, change the program language to Ladder, and then click the OK button. 

 

 

Enter the program in Ladder Programming Language. 

[Procedure] 
1. Move the cursor to the insertion point. 
2. Enter "T1" and click OK. 
3. Move the cursor to the next insertion point, enter "TRAN", and click OK.  
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e) Add a step and set "Step1" as follows: 

 

[Settings] 
Data Name:   Step1 
Type:    Normal Step 
Step No. (Sn):  S2 
Device Comment:  Trolley Reverse 
 

Next, set the operation output of "Step1" as follows. 

 

[Settings] 
Data Name:  Action2 
Type:  Detailed expression 
Qualia File:  N 
 

In the New Data window, change the program language to Ladder, and then click the OK button. 

  

Enter the program in Ladder Programming Language. 

[Procedure] 
1. Move the cursor to the insertion point. 
2. Enter "SM400" and click OK. 
3. Move the cursor to the next insertion point, enter "Y73", and click OK. 
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(f) Select "Transition2" and set as follows: 

 

[Settings] 
Data Name:    Transition2 
Type:    Detailed expression 
Transition Condition No.:  TR2 
Device Comment:   Work Trolley Origin LS 
 

In the New Data window, change the program language to Ladder, and then click the OK button. 

 

 

Enter the program in Ladder Programming Language. 

[Procedure] 
1. Move the cursor to the insertion point. 
2. Enter "X2" and click OK. 
3. Move the cursor to the next insertion point, enter "TRAN", and click OK. 

 

When you are finished creating the SFC diagram, click Convert - > Convert All in the menu. 
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3.3 SFC Configuration 

In the CPU parameters and SFC block settings, set the start conditions for the SFC program. 

Note that the default settings remain for all programs created in 3.2 Creating Programs. 

 

(1) CPU Parameters 
 

The following is a list of SFC settings: 

Type Items Contents 

SFC 
Configuration 

SFC Program Start Mode 
Setting 

Set whether to start with initial status (Initial Start) or to start 
HOLD the previous execution status (Resume Start) at the 
start-up of SFC program. 

Start Conditions Setting Set whether to automatically start and activate Block0 or to 
keep it inactive until a start request is issued, when starting the 
SFC program. 

Output Mode Setting at 
Block Stop 

Set whether to turn off the coil output or to hold it when 
stopping a block. 

 

 

 

(2) SFC Block Settings 
 

Set operation settings for block double start. (3.4.1 Operation Setting for Dual Block Startup) 

 

 

 

 

 

 

Point 

Keep the certain number of step relay (S) points before using the SFC program. (Default 
number of step relay (S) points are 0.) 
Set the number of step relay (S) points in units of 1024 points in [CPU Parameter] > 
[Memory/Device Setting] > [Device/Label Memory Area Setting] > [Device Setting]. 
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3.3.1 SFC program start mode setting 

The SFC program start mode sets whether to start the SFC program in the initial state (initial start) 
when the SFC program starts (SM321 OFF → ON) or to start it while maintaining the previous 
execution state (continued start). 

Set from [CPU Parameters] > [SFC Settings] > [SFC Program Start Mode Settings]. 

 

Type Contents 

Initial Start 
(default) 

The program is started after the active state at a previous stop is cleared. 

The operation after a start is performed according to the start condition setting of the 

SFC setting. (エラー! 参照元が⾒つかりません。) 

Continue Start The program starts while HOLD the active state at a previous stop. 

 

Whether to start an SFC program with initial status or the previous execution status is determined 
by the combination of the SFC program start mode setting and the SM322 (SFC program start 
mode) status. 

Operation 

SFC program start mode 
setting: Initial Start 

SFC program start mode setting: 
Resume Start 

SM322: OFF 
(Initial status) 
*¹ 

SM322: ON 
(When the 
setting is 
changed) 

SM322: ON 
(Initial status) 
*¹ 

SM322: OFF 
(When the setting 
is changed) 

(1) SM321 is turned off and on. 

Initial Start 

Resume Start 

Initial Start 

(2) 
CPU module is powered off and 
on. 

Resume 
Start/Initial 
Start*⁴ 

(3) 

SM321 is turned on and off, or 
CPU module is powered off and 
on after changing the operating 
status from RUN to STOP. 

Resume Start 

(4) 
CPU module is reset, and the 
operating status is changed to 
RUN. 

Resume 
Start/Initial 
Start*⁴ 

(5) 

SM321 is turned on and off, or 
CPU module is reset, and the 
operating status is changed to 
RUN after RUN to STOP. 

Resume Start 

(6) 
Operating status is changed from 
STOP to RUN. 

Resume Start*³ 

(7) 
Operating status is STOP, write 
a program, and the status is 
changed to RUN. 

Initial Start*² 
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*1 The initial status of SM322 is determined when the operating status of the CPU module is 
changed from STOP to RUN according to the setting of the SFC program start mode. 

*2 When the Resume Start is set for the SFC program start mode, a program is resumed 
unless there is any change before and after program writing. 

*3 The on/off state of an action is determined according to the setting of "Output Mode at STOP 
to RUN" of parameter setting. 

*4 Depending on the timing, a program cannot be resumed and starts with initial status.  
 

(1) Cautionary Notes 

 When a program is resumed, the SFC program stop position is held but the status of the label 
or device used for an action is not held. Therefore, if labels or devices are required to be held 
to start with previous status, set them to be latched. 

 When a program is resumed with conditions other than the ones ((1), (3), (5) in the table) 
where the coil output of the coil HOLD step [SC] is turned off, the coil HOLD step [SC] that 
holds the operation is restarted but the output is not turned on. To continue the output, set the 
labels and devices required to be held to be latched. The on/off state of the output at the time 
of changing STOP to RUN is determined according to the setting of "Output Mode Setting at 
STOP to RUN" of CPU parameter setting. (MELSEC iQ-R CPU Module User's Manual 
(Application)) 

 At power-off or reset, the intelligent function module is initialized. To resume a program, 
creating an initial program for the intelligent function module in the block which is always active 
or in a sequence program is recommended. 

 At power-off or reset, labels and devices are also cleared. When the SFC information device 
is set, the values are held only when latch setting is performed. 

 Depending on the timing, a program may not be resumed after power-off or reset. If a program 
is started with initial status while the start mode is set to Resume Start, an event indicates that 
a program cannot be resumed is stored in the event history. To resume a program without fail, 
turn off SM321 or switch the operating status of the CPU module from RUN to STOP, and then 
power off or reset the CPU module. 

  

 

 

 

 

 

 

 

 

 

 

 

 

- 
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3.3.2 Start condition setting 

Set whether to automatically start and activate Block0 or to keep it inactive until a start request is 
issued, when starting the SFC program. 

Set from [CPU parameter] > [SFC Setting] > [Start Conditions Setting] 

 

Settings 
Contents 

At SFC Program START At the end of Block0 

Auto-start Block0 

(default) 

Block0 is started automatically and 
starts execution from its initial step. 

Block0 is restarted automatically 
and restarts execution from its 
initial step. 

Do not auto-start 
Block0 

Block0 is activated by a start 
request resulting from the SET 
(Starting a block) instruction or a 
block start step, in the same 
manner as other blocks. 

Block0 is not restarted 
automatically and remains inactive 
until another start request is 
issued. 

 
Use the start condition setting when it is desired to specify the start block at the start of SFC 
program according to the product type. 
"Auto-start Block0" is useful when Block0 is used as described below. 

 Management block 
 Preprocessing block 
 Continuous monitoring block 

 

(1) Cautionary Notes 

 To execute the SFC program when "Do not auto-start Block0" is set, execute the SET 
instruction (Starting a block) from the sequence program or turn on the block START/END 
bit that is set in the SFC information device. 

 When "Auto-start Block0" is set, be sure to create Block0. 
 

 

 

 

 

 

 

 

 



106 
 

3.3.3 Output mode setting at block stop 

Set whether to turn off the coil output or to hold it when stopping a block. 

Set from [CPU parameter] > [SFC Setting] > [Output Mode Setting at Block Stop] 

 

Type Contents 

OFF (default) Turns off the coil output. 

Leave ON Keeps the coil output in the state just before stopping. 

 The settings made are reflected to the initial value of SM325 (Output mode at block stop) at 
power-on, reset, or switching from STOP to RUN, and follow the settings of SM325 when the 
SFC program operates. CPU parameter settings are ignored. 

 

 Operation at the time of block scheduled restart 
Operation when the block is paused or restart depends on the combination of the SM325 (Output 
mode at block stop) status, block stop mode bit setting of the SFC information device, and step hold 
status. 

The following table lists the operations at block PAUSE/RESTART. 

Output mode 
setting at block 
stop 

Setting of 
block stop 
mode bit 

Operation 

Active step other than step that holds 
operation 
(Including SC, SE, and ST whose 
transition does not become TRUE) 

HOLD Step 

Coil HOLD step 
[SC] 

Operation 
HOLD step 
(without 
transition 
check) [SE] 

Operation 
HOLD step 
(with transition 
check) [ST] 

SM325=OFF 
(Coil output 
OFF) 

OFF or not set 
(Immediate 
Stop) 

Immediately after a stop request is made, 
the coil output of the action is turned off 
and the block is stopped. The status 
remains active. 

Immediately 
after a stop 
request is made, 
the coil output of 
the action is 
turned off and 
the block is 
deactivated. 

Immediately after a stop 
request is made, the coil output 
of the action is turned off and 
the block is stopped. The 
status remains active. 

ON 
(Stop after 
transition) 

After the transition becomes TRUE, step 
end processing is performed and 
simultaneously the transition destination 
step becomes active, and the block is 
stopped before execution of the action. 

SM325=ON 
(Coil output 
held) 

OFF or not set 
(Immediate 
Stop) 

Immediately after a stop request is made, 
the block is stopped with the coil output 
of the action being held. The status 
remains active. 

Immediately after a stop request is made, the block 
is stopped with the coil output of the action being 
held. The status remains active. ON 

(Stop after 
transition) 

Normal operation is performed until the 
transition becomes TRUE. After the 
transition becomes TRUE, step end 
processing is performed and 
simultaneously the transition destination 
step becomes active, and the block is 
stopped before execution of the action. 

At restart Returns to normal operation. 

Coil output is off: 
Becomes 
inactive and 
restart is 
disabled 
Coil output is 
held Restarts 
with the hold 
state 

Restarts the 
execution of 
the action in 
a HOLD 
status. 

In the hold 
status, the 
action is 
restarted, and 
the transition is 
also checked. 

(2) Cautionary Notes 
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 When the block specified with the LD instruction (Checking the status of a block) has stopped, 
the coil output is turned on. Also, when the step specified with the LD instruction (Checking 
the status of a step) has stopped, the coil output is turned on. 

 If the block is started while the PAUSE/RESTART bit of the SFC information device is on, the 
initial step stops before it becomes active. If the SET instruction (Activating a step) is executed 
for an inactive block, the specified step stops before it becomes active. 

 When SM325 (Output mode at block step) is on, the block can be stopped while HOLD the 
coil output. Even when SM325 is turned on and off in stopped state, the state of the coil output 
does not change. When a block restart request is issued, the coil output restarts while keeping 
the hold state. 

 If the block is stopped when SM325 is on, the coil HOLD step [SC] in the hold state keeps its 
state even after restart but the step operation does not restart. To make the coil HOLD step 
[SC] inactive, execute the RST instruction (Deactivating a step). 

 When a stop request is issued in the action to the block, the step being executed currently is 
executed until it ends, and then the stop request is executed. Therefore, when the block stop 
mode bit is off (immediate stop), the step being executed does not stop even if a stop request 
is issued within the step. If the block stop mode bit is changed to on (stop after transition) 
afterwards in the same step, a stop request is executed in stop mode after transition. 

Block PAUSE/RESTART when the RST instruction (Deactivating a step) is used 

 
 If the block stop mode bit (stop after transition mode) is turned off while a step in a state that 

is waiting to stop operation after transition exists, the step remains in that state. To immediately 
stop after clearing this state, restart the block and issue a stop request again while the block 
stop mode bit is off. 

 When the step transition destination is an end step in stop after transition mode, end step 
processing is executed and therefore the step is not put in the stopped state. 

 To check that a stop request has been issued, monitor the block list display of the engineering 
tool, or monitor the bit that has been set in the block PAUSE/RESTART bit. However, whether 
the step is in stop state or operating to wait to stop cannot be checked from the monitor of the 
engineering tool. 

 The stop after transition state can be cleared by turning off the block PAUSE/RESTART bit or 
executing the RESTART instruction before the transition becomes TRUE. If a restart request 
is issued while steps that is already stopped and steps that is waiting to stop operations coexist, 
the former starts, and the latter continues the operation. The stop request is cleared. 

  

(1) When M0 is turned on, Block0 is stopped. 
(2) When M1 is turned on, a termination request 
is executed for step No. 0 and BL0\S0 of the 
step relay is turned off, but step No. 0 is left 
active on the monitor of the engineering tool. 
(3) BL0\S0 is turned off, so Y0 is also turned off. 
(4) When M2 is turned on while M0 and M1 are 
off, Block0 restarts and step No. 0 ends. 
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3.4 SFC Block Configuration 

3.4.1 Operation setting at block dual start 

Set the operation mode to stop the operation of the CPU module when a start request is issued by 
the block start step (with end check) [BC] or block start step (without end check) [BS] for an already 
active block. For the setting range, set the range of the block to be stopped. 

Set from [Navigation window] > [Program] > [Properties of SFC program file to be set]

 

(1) Set the range of blocks you want to stop. 
 

Settings Contents 

No setting 

(default) 
Standby 

CPU module operation continues, and standby until the start 
destination block becomes inactive while the transition becomes 
TRUE. 
When the start destination block is deactivated, the block is 
reactivated. 
If a transition in standby state, the previous step is deactivated, the 
output is switched OFF, and the action will not be executed. 

Block stop range is set. Stop An error results. 

 

 

 

(1) Cautionary Notes 

 When the SET instruction (Activating a block) is executed for the block that is already active, 
the start request is ignored and the processing of the SFC program is continued as is. 

 If an attempt to transition to an active block start step is made, the activation of the block start 
step is ignored. The block is not executed again from the initial step. 

 

 

3.5 Creating an SFC Diagram 

Shows the basic procedure for creating an SFC diagram. 
You can insert different elements depending on the selection. 
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The size and position of each element/connection line are determined automatically and cannot be 
changed freely. 
 
1. Cautionary Notes 

If any of the following items is entered or selected, a red frame appears in the edit box, and you 
cannot set it. 

 Duplicate Step Name/Step No./Transition Condition No. 
 Invalid step attribute 
 Step name that cannot be specified as jump destination 

 
2. Insert Initial Step 

When a new SFC program is created, one initial step is inserted. 
To execute multiple processes in parallel, add an initial step. 
Select Edit > Insert > Step () on the empty cell.  
An SFC diagram consisting of initial steps, transition conditions, and end steps is inserted. 

 
3. Insert Normal Step 

Select Step > Transition Conditions > Jump and select Edit > Insert > Step ().  
 
4. Insert Transition Criteria 

Select Step > Transition Conditions > Jump and select Edit > Insert > Transition Conditions (). 
 

 
5. Insert operation output 

Select Step > Operation Output and select Edit > Insert > Operation Output ().  
You can insert multiple operation outputs in a step. 

 

 

 

 

 

 

  

 

(6) Insert Jump 

Point 

 Setting CPU parameters enables only Block0 to be started automatically when the SFC program 
starts. In this case, when the end step is activated and the Block0 is finished, the Block0 is 
automatically restarted and execution of steps is started again from the initial step. (Start condition 
setting) 

 If a start request is issued to a step in an inactive block by using the SET instruction (activating a 
step), the block is activated to execute processing from the specified step. 
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Insert position Procedure 

 

1. Select the transition condition and select Edit > 
Insert > Jump ().  
2. Select the name of the step you want to jump to. 

 

1. Select the transition condition and select Edit > 
Modify > Toggle Jump Symbol and Connection Line. 
2. Select the name of the step you want to jump to. 
All SFC diagrams below the inserted jump are 
deleted. 

 

(7) Insert a branch under a step/transition condition 

Select Step > Transition Condition and then select Edit > Insert > Insert Selected Branch () > Insert 

Parallel Branch ().   
If you insert a selected branch or a parallel branch, the SFC elements that are not sufficient for the 
correct SFC diagram are automatically inserted. 
 
(8) Add a selection branch to the right of the transition condition/selection branch 

Select the transition/selection branch to add and select Edit > Insert > Add Selection (). (Multiple 
selections allowed) 
 

  
 
  
 
 
 
(9) Add a parallel branch to the right of the step/parallel branch 

Select the step/parallel branch where you want to add it, then select Edit > Insert > Add Parallel 
Branch (). (Multiple selections allowed) 
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3.6 Writing an SFC Program to the CPU 

After preparing the switch settings, write the program created in 3.2.4 Program Creation to the CPU. 
After writing, monitor and test. 

（1） Switch Settings 

Make sure that the RUN/STOP switch is set to STOP. 

 

RUN/STOP Switch

 

（2） Specify connection destination 

Click the Online > Current Destination menu. 
In the Connection Settings window, input the connection settings. 
Selected “Connection Test”. If successful, the PLC Type will be filled and click “OK”. 
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（3） Deleting data from programmable controller 

Click the Online > Delete PLC Data menu and click the Select All button. 
Click the Execute button to delete the programmable controller data. 

 

（4） Writing Programs 

Click the Online > Write to PLC menu (on the toolbar ), then click the Select All button. Click the 
“Execute” button to write the program to the CPU. 
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4 Run the SFC program 
4.1 Using Monitor Operations to Monitor SFC 
Use the SFC diagram to monitor the operation and control status of CPU module and perform test 
operations. 

[Procedure] 

 When monitoring 
Online > Monitor > Monitor Mode menu or F3 

 Stopping the monitor 

Online > Monitor > Stop Monitor menu or  Alt + F3 

 When restarting the monitor 

Online > Monitor > Start Monitor menu or , F3 key 

[Screen] 
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(1) The status of a monitored SFC element is displayed as follows: 

 

(2) To monitor Zoom, select View > Zoom, open Zoom, and then monitor it. 

(3) The SFC block list monitor displays the current block information on the SFC block list. 

Select View > Open SFC Block List to open the SFC block list before monitoring. You can display 
the SFC diagram of a specified block by double-clicking the block field during monitoring. 

 

  

 

 

 

 

 

 

 

Active 

Inactive 

Retained 

Point 

 Automatic scroll monitor 
When a step that is not visible on the screen is activated during monitoring, the system automatically 
scrolls to display the activated step on the screen again. 

Click Scroll or select Online > Monitor > SFC Auto-Scroll Monitor.  
If multiple steps are active, steps close to the initial step column are displayed with priority. 
The automatic scroll monitor stops when you open the screen for writing while automatic scrolling or 
writing while monitoring. When you restart the monitor, the automatic scroll monitor also resumes. 

 Displaying the Destination Block During Automatic Scrolling Monitor 
 You can set the target block to be displayed automatically by selecting Tools > Options > "Monitor" > 

"SFC Diagram Editor" > "Auto Scroll Monitor Settings" > "Block Startup Opens and Monitors a New 
Window". 

 When the active step moves to the block start step during automatic scroll monitoring, you can 
automatically open the SFC diagram editor of the block to start and start monitoring. 
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[Operation of the actual machine] 

Perform the following operations while viewing the SFC monitor screen. 

(1) Display operations on the monitor screen 

To monitor the currently active steps, click  Scroll Monitor, or use Online - > Monitor - > SFC 
Auto-Scroll Monitor to turn it on. 
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(2) Procedure 

[Operation of Block0] 
 
(1) Operation in step 0 (S0) 

When X0 (operation permission switch) is turned on, the transition condition is satisfied, and 
the process moves to Step 1 (waiting for detection of the work truck). 
 

(2) Operation in step 1 (S1) 
When X2 (work truck origin) is turned on, the transition condition is satisfied and the 
operation proceeds to Step 2 (buzzer output). 
 

(3) Operation in Step 2 (S2) 
The alarm buzzer for starting the conveyor sounds, and the transition condition is 
established by the time up of T0 (alarm timer), and the operation proceeds to Step 3 
(conveyor operation). 
 

(4) Step 3 (S3) 
The OFF → ON operation of X3 (work sensor) is repeated 6 times, and when a 
predetermined number of workpieces are carried to the work truck, the transition condition is 
satisfied, and the process proceeds to Step 4 (start of Block1). 

 
[Operation of Block1] 
 
(5) Operation in step 0 (S0) 

When Y 72 (conveyor advance) is turned on and X 4 (work truck advance end) is turned on, 
the transition condition of step 0 is established and steeped. 
Go to step 1 (work export). 
 

(6) Operation in step 1 (S1) 
Y 74 (work carryout) is turned on, and the transition condition is established by the time up of 
T1 (carryout time), and the process proceeds to Step 2 (work truck retraction). 
 

(7) Operation in Step 2 (S2) 
When Y 73 (Work Trolley Retraction) is turned ON and X 2 (Work Trolley Origin) is turned 
ON, the transition condition is established and the block end and returns to Block0. 
 

(8) The transition condition in Step 4 is satisfied by the operation in (7), and the process moves 
to Step 1 by the jump command. 
Repeat steps (2) through (7). (Cycle Operation) 

 
(9)  If X1 (operation switch) is turned on during conveyor operation, conveyor operation stops 

and becomes a block end. (Block0 reactivates the initial step.) 
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4.2 Modifying a program during CPU operation (Writing during RUN) 

This command corrects an operation output/transition condition program written to the 
programmable controller CPU once while the CPU is running. 
For example, change the timer T0 setting from K30 (3 seconds) to K60 (6 seconds). 
 
(1) Double-click the action output name/transition condition name on the SFC diagram to open the 
ladder program you want to modify. 
Click  to change to monitor (write mode). 
When the following dialog box appears, click the OK button. 
 

 
  
(2) Perform a program modification operation 
Program modifies the timer (T0) setting used in the operation output from 3 seconds to 6 seconds. 
 

(a) Double-click the timer (T0) of the operation output program in step 2 (S2) of Block0. 
 

 
  

(b) Change the T0 setting from K30 (3 seconds) to K60 (6 seconds) and click OK. 
(c) Click the Convert > Convert + Write during RUN menu. 

When the "NOTICE" message appears, confirm the contents, and click the [Yes] button. 
 
(3) Check the actual machine. 
Check that the lighting time of Y70 in [Operation] has changed from 3 seconds to 6 seconds. 
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4.3 Controlling Blocks with Information Devices for SFCs 

By turning on/off the SFC information device that was set when the SFC diagram was created using 
a program or GX Works3 test operation, you can suspend or terminate (deactivate) the 
corresponding block. 
This section describes block control using information devices for SFCs. 
 
(1) Block termination by block start termination bit 

When the specified block starts, the block start end bit is automatically turned on. 
When the specified block is active, turning off the block start end bit stops the execution of the 
specified block, turns off the output of all the steps being executed, and terminates the block. 
The block start/end bit can also be turned ON/OFF from engineering tool test operations. 

 
Confirm the end of the block as follows: 

(a) Set the screen to SFC automatic scroll monitor by operating 4.1 monitor operation to monitor 
SFC. 

(b) To do so: 
(i) Turn on X0 and X2 and move the activation step to other than the initial step (0 step). 

  

 
  
 

(ii) Turn off X0, X2 and select Debug > Device Test with Execution Condition > Register. 
(iii) In the device test registration window with execution conditions, set the following 

settings, and then click the [Forced OFF] button. 
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[Settings] 
Device/Label:   M100 
Data types:   Bit 
Program blocks:  ProgPou 
Step No:   0 
Execution timing:  Before executing instruction  
 

(iv) Check that the activation step has returned to the initial step. 
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(2) Pausing blocks with stop restart bits 
When the bit with the block stop restart bit set is ON, the block is stopped at the step being 
executed and the active block is paused. 
If the block stop restart bit is set to OFF, execution of the block resumes from the stopped 
step. 
 

Confirm the block pause as follows: 
(a) Select "SFC Auto Scroll Monitor". 
(b) To do so: 

(i) Turn on X0 and X2 to activate Step 3 (S3). 
 

 
 
  
 

(ii) Select Debug > Device Test with Execution Condition > Register. 
(iii) In the device test registration window with execution conditions, set the following 

settings, and then click the [Force ON] button. 
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[Settings] 
Device/Label:  M102 
Data types:  Bit 
Program blocks:  ProgPou 
Step No:   0 
Execution timing:  Before executing instruction  
 

(iv) Check to see if it has been paused. 
o Output Y71 (conveyor operation) is OFF. 
o Even if the input X3 (counter input) is turned ON/OFF, the current value of the 

counter C0 does not change. 
(v) When (iv) confirms that it has been paused, turn off the block stop restart bit to release 
the stop. 

o Select [Debug] > [Device Test with Execution Conditions] > [Register] on the 
monitor screen in the same way as in and turn OFF [M102] forcibly. 

(vi) Verify that the pause has been released. Output Y71 (conveyor operation) is ON. 
o When the input X3 (counter input) is turned ON/OFF, the current value of the 

counter C0 is increased. 
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5 Control blocks with SFC control instructions 

By using SFC control instructions, you can check the active status of blocks and steps, forcibly start 
them, and terminate them. 

The active state of a block or step can also be handled by a contact command. 

This chapter describes how to create a program file for controlling blocks in an SFC and how to 
execute the control. 

 

5.1 Creating Programs Using SFC Control Instructions 

5.1.1 Add New Program 

(1) From the Project view, select a program, right-click and click New Data. 

 

(2) Enter "SFC control" for the data name, select "ladder" *¹ for the program language and click the 
[OK] button. 

 

  

*1: The SFC control instruction can also be used in the SFC program. In this chapter, you will create 
a program that uses SFC control instructions in addition to the SFC program so that you can 
practice how to set up the SFC program and other programs. 

 

  

 



124 
 

5.1.2 Create Program 

The following programs are created: 

 

 

a. Press the F5 key, enter "X5" and click the OK button. Then press the F8 key, enter "RST 
BL0" and click the OK button. 

b. Press the F5 key, enter "X6" and click the OK button. Then press the F8 key, enter "PAUSE 
BL0" and click the OK button. 

c. Press the F5 key, enter "X7" and click the OK button. Then press the F8 key, enter 
"RSTART BL0" and click the OK button. 

d. Press the F5 key, enter "BL0¥S1" and click the OK button. Then press the F7 key, enter 
"Y80" and click the OK button. 

e. Press the F5 key, enter "BL0¥S3" and click the OK button. Then press the F7 key, enter 
"Y81" and click the OK button. 

f. Press the F5 key, enter "BL1" and click the OK button. Then press the F7 key, enter "Y82" 
and click the OK button. 

After creating the program, press Shift+Alt+F4 to convert all programs. 
 
For details about each SFC control instruction, see 2.7 SFC control instruction. 
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5.1.3 Setting Parameters and CPU Writing 
In addition to the SFC program, we created a ladder program using 5.1.2 Program Creation. To 
write multiple programs to the CPU module, you must set the program's file name and execution 
type (execution condition). 

(1) In the project view, double-click Parameters > R08 CPU > CPU Parameters. 

 

(2) Select Program Settings to set the program name and execution type. Select "Scan" for both 
execution types. For details about the CPU parameters, see the following manuals: 
MELSEC iQ-R CPU module User's Manual (Application) 

 

 

(3) Write a program to the CPU in the same way as in 3.6 Writing an SFC Program to the CPU. 
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5.2 Control of SFC Program by SFC Control Instruction 

5.2.1 Block and step active state monitoring by activation check command 

The execution status (active status) of the SFC program can be treated as a contact point by the 
step activity check command and the block activity check command. 

In 5.1.2 Program Create, the activation check command checks the following: 

 
Step 1 of Block0 turns ON while activated. 

 
Step 3 of Block0 turns ON while activated. 

 
Turns ON while Block1 is active. 

 

In the program we created this time, we used the activation check command in the ladder program 
to practice monitoring. 

If the activation check command is used as the transition condition of the SFC program, 
synchronization between blocks and steps can be established. 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Program in which the transition 
condition is satisfied when step 5 of 
Block1 is activated. 
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5.2.2 Forced termination of block by SFC control instruction 

Forced block termination is a function that executes block end processing to inactivate a block, 
regardless of which step in the block is active. 
Forced block termination is used when work cannot continue because of a machine problem. 
To check whether a block is forcibly terminated: 
 

(1) Start the monitor with the Auto Scroll Monitor. 
(2) To do so: 

a. Turn on X0 and X2 and move the active step to other than the initial step.  
 

 
 

b. When X5 is turned ON, the active step returns to the initial step. 
 

 

  
 
When Block0 is forcibly terminated, the initial step is automatically activated. If a block other than 
Block0 is forcibly terminated, the block is inactive until a start request is issued from another block. 
If Block0 is not forcibly started is set in the SFC setting of the parameter, Block0 is deactivated in 
the same way as other blocks. 
*1 — See 3.3.2 Start Condition Settings. 
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5.2.3 Suspension of blocks by SFC control command (block stop) 

Suspending a block temporarily suspends the processing of that block. 
Use this command to continue starting from the interrupted state after manual operation when work 
is suspended due to machine trouble. 
 
To check whether a block is paused (block stopped): 
 

(1) Start the monitor with the Auto Scroll Monitor. 
(2) To do so: 

a. Turn on X0 and X2 to activate step 3. 
b. Turn on X6 and execute the block pause command. 
c. Check to see if it has been paused. 

i. Indicates whether the OUT command (Y71) is OFF. 
ii. Does the current value of the counter change even if the counter input X3 is 

turned ON/OFF? 
d. When you have confirmed that the command has been paused, turn on X7 to release 

the pause. 
e. Verify that the pause has been released. 

i. Whether the OUT command (Y71) is ON. 
ii. Does the current value of the counter change when the counter input (X3) is 

turned ON/OFF? 
 
When the stop mode bit (Block0: M103, Block1: M203) is turned ON or OFF, the stop timing of the 
block stop request is as follows: 
 
ON: Stops when the transition condition immediately after the step that is active at the time of the 
stop request is satisfied. 
 
OFF: Stopped immediately when a stop request is made 
When the block is stopped, you can select "turn off" or "Leave ON" from the SFC setting of the CPU 
parameter to turn off or hold the coil output. 
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Appendix 1.1: Practical Programming Tasks Using Demo Test 
Equipment 
 

Let's program the exam preparation task 1~3 corresponding to the skill test practical skill test 
electrical equipment assembly (sequence control work) sponsored by Japan Vocational Ability 
Development Association in SFC. 

1.1 Description of equipment 
The system configuration is shown below. 

 

 

 

No. Device Name Quantity 

1 R33B 1 

2 R61P 1 

3 R08CPU 1 

4 RX40C7 1 

5 RY40NT5P 1 

6 FA-T-P01 (Skill Test Equipment) 1 

7 Electric Wire 36 
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1.1.1 Skill Test Equipment 
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1.1.2 Input/Output wiring diagram 
 

 

 

 

 

 

 

 

 

 

  



132 
 

1.2 Programmable controller 

The following describes the specifications of the programmable controller I/O Modules to be used. 

1.2.1 RX40C7 Type DC Input module 
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1.2.2 RY40NT5P Transistor Output module 
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1.3 Wiring 

Route the wires as shown in the wiring diagram below. 

 

 

1.3.1 Precautions 

(1) Do not perform wiring work while the power of the programmable controller and skill test 
equipment is on. 

(2) The Y-terminal of M3.5 is used for the skill test equipment side and the Y-terminal of M3 is 
used for the programmable controller I/O side, so do not wire them incorrectly. 

(3) When wiring 24 VDC, do not use the wrong combination of [+] and [-]. (Equipment 
malfunctions) 

(4) Check wiring thoroughly before turning on the power. 
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1.4 Practical Test 1 

When Manual of [SS0: Manual/Automatic changeover switch] and OFF [SS1: Continuous operation 
selection switch] are selected, 
Write a program that does the following: 

(1) While pushing PB1, the pallet on the conveyor moves to the left. 
(2) While the PB2 is pressed, the pallet on the conveyor moves to the right. 

 
In this case, the following conditions shall be satisfied: 

i. When moving to the left, stop the conveyor when the pallet reaches the left end. 
ii. When moving to the right, stop the conveyor when the pallet reaches the right end. 
iii. Turn on PL2 only when the pallet is on the far left. 
iv. Turn on PL3 only when the pallet is on the far right. 
v. Flashes PL2 at 1-second intervals only when the palette moves to the left. (Lights up for 0.5 

seconds, turns off for 0.5 seconds) 
vi. Flashes PL3 at 1-second intervals only when the palette moves to the right. (Lights up for 

0.5 seconds, turns off for 0.5 seconds) 
vii. If PB1 and PB2 are pressed at the same time, the conveyor is stopped immediately. 
viii. If [SS0: Manual / automatic changeover switch] is selected as [Automatic] or [SS1: 

Continuous operation selection switch] is selected as [On] during operation, the conveyor is 
stopped immediately. 

 
 

 I/O Allocation Table 
 

Bit 
Position 

TB 
Terminal 
Number 

Signal 
Name 

Signal Content 
Bit 
Position 

TB 
Terminal 
Number 

Signal 
Name 

Signal Content 

0 1 LS1 Right end detection limit 
switch 

0 20 RY1 Conveyor left drive relay 

1 2 LS2 Left end detection limit 
switch 

1 21 RY2 Conveyor right drive 
relay 

5 6 PB1 Conveyor Left Row 
Driving Button 

3 23 PL2 On: Left detection lamp 
Blinking: Left driving 
lamp 

6 7 PB2 Conveyor right-row 
drive button 

4 24 PL3 On: Right edge 
detection lamp 
Blinking: Right driving 
lamp 

10 11 SS1 Emergency stop button  
11 12 SS0 Continuous operation 

selection switch 
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1.4.1 Flowchart Example 
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1.5 Practical Test 2 

[Automatic] and [SS1: Continuous Operation Selection] of [SS0: Manual/Automatic Switch] while 
maintaining the function of Exercise 1 
When [OFF] of [Switch] is selected, the following operations (1) to (4) are performed (one cycle). 

(1) When PB1 is pressed, the conveyor is moved to the left and the pallet is moved to the left. 
(2) Stop the conveyor when the pallet reaches the left end. 
(3) 3 seconds after the conveyor stops, the conveyor is moved to the right, and the pallet is 

moved to the right. 
(4) Stop the conveyor when the pallet reaches the right end. 

 
In this case, the following conditions shall be satisfied: 

i. PB1 is valid when the pallet is on the far right. 
ii. Turns on PL1 during cycle operation. 
iii. Turn on PL2 only when the pallet is on the far left. 
iv. Turn on PL3 only when the pallet is on the far right. 
v. Flashes PL2 at 1-second intervals only when the palette moves to the left. (Lights up for 0.5 

seconds, turns off for 0.5 seconds) 
vi. Flashes PL3 at 1-second intervals only when the palette moves to the right. (Lights up for 

0.5 seconds, turns off for 0.5 seconds) 
vii. The conveyor stop time during cycle operation is displayed on DPL1 and DPL2 in 0.1 

second increments while the conveyor is stopped. 
viii. During cycle operation, [SS0: Manual / automatic changeover switch] is set to [Manual] or 

[SS1: Continuous operation selection switch] is set to [On]. 
ix. When selected to and [PB5: Emergency stop button] is pressed, the conveyor is immediately 

stopped and PL1 is turned off. 
 
 
■I/O Allocation Table 

Bit 
Position 

TB 
Terminal 
Number 

Signal 
Name 

Signal Content 
Bit 
Position 

TB 
Terminal 
Number 

Signal 
Name 

Signal Content 

0 1 LS1 Right end detection limit 
switch 

0 20 RY1 Conveyor left drive relay 

1 2 LS2 Left end detection limit 
switch 

1 21 RY2 Conveyor right drive 
relay 

5 6 PB1 Cycle operations start 
switch 
Conveyor Left Row Driving 
Button 

2 22 PL1 Ramp during cycle 
operation 

6 7 PB2 Conveyor right-row drive 
button 

3 23 PL2 On: Left detection lamp 
Blinking: Left driving 
lamp 

9 10 PB5 Emergency stop button 4 24 PL3 On: Right edge detection 
lamp 
Blinking: Right driving 
lamp 

10 11 SS1 Continuous operation 
selection switch 

6 26 DPL 1 

Stop time display 
(0.1 second digits) 

11 12 SS0 Manual and automatic 
switch 

7 27 DPL 1 

 8 28 DPL 1 
9 29 DPL 1 
10 30 DPL 2 

Stop time display 
(1 second digit) 

11 31 DPL 2 
12 32 DPL 2 
13 33 DPL 2 
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 1.5.1 Flowchart Example 
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1.6 Practical Test 3 

[Automatic] and [SS1: Continuous Operation] of [SS0: Manual/Automatic Switch] while maintaining 
the functions of Exercise 1 and Exercise 2 
Create a program that performs the following actions when [ON] is selected in [Roll selection 
switch]. 

(1) The number of continuous operations 1 ~ 9 is specified in the DSW 1. 
(2) After the continuous operation frequency is designated, the continuous operation frequency 

is set by pressing PB2. 
(3) After setting, it is displayed on the DPL1 as the target continuous operation number. 
(4) The operations (1) to (4) in Exercise 2 are continuously operated for a set number of times. 
(5) When the PB3 is pressed during continuous operation, it stops after the end of the cycle 

during operation. 
(6) The number of completed cycles is displayed in DPL2. 

 
In this case, the following conditions shall be satisfied: 

i. PB1 is valid when the pallet is on the far right. 
ii. Turns on PL1 during automatic operation. 
iii. Turn on PL2 only when the pallet is on the far left. 
iv. Turn on PL3 only when the pallet is on the far right. 
v. Flashes PL2 at 1-second intervals only when the palette moves to the left. (Lights up for 0.5 

seconds, turns off for 0.5 seconds) 
vi. Flashes PL3 at 1-second intervals only when the palette moves to the right. (Lights up for 

0.5 seconds, turns off for 0.5 seconds) 
vii. After PB3 is pressed, PL4 flashes at 0.6 second intervals until the end of the cycle. (Lights 

up for 0.3 seconds, turns off for 0.3 seconds) 
viii. The conveyor stop time during cycle operation is displayed on DPL1 and DPL2 in 0.1 

second increments while the conveyor is stopped. 
ix. The target number of continuous operations is displayed on DPL1 and the number of 

completed cycles is displayed on DPL2 except when the conveyor is stopped during cycle 
operation. 

x. If the number of continuous operations is 0, automatic operation is not performed. 
xi. If [SS0: Manual / automatic changeover switch] is selected as [Manual] or [SS1: Continuous 

operation selection switch] is selected as [Off] and [PB5: Emergency stop button] is pressed 
during cycle operation, the conveyor is immediately used. Is stopped and PL1 is turned off. 
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■I/O Allocation Table 

Bit 
Position 

TB 
Terminal 
Number 

Signal 
Name 

Signal Content 
Bit 
Position 

TB 
Terminal 
Number 

Signal 
Name 

Signal Content 

0 1 LS1 
Right end detection limit 
switch 

0 20 RY1 
Conveyor left drive relay 

1 2 LS2 
Left end detection limit 
switch 

1 21 RY2 
Conveyor right drive relay 

5 6 PB1 

Cycle operations start 
switch 
Conveyor Left Row 
Driving Button 

2 22 PL1 

Ramp during cycle 
operation 

6 7 PB2 
Conveyor right-row drive 
button 

3 23 PL2 
On: Left detection lamp 
Blinking: Left driving lamp 

7 8 PB3 
Emergency stop button 

4 24 PL3 
On: Right edge detection 
lamp 
Blinking: Right driving lamp 

9 10 PB5 
Continuous operation 
selection switch 5 25 PL4 

Stop time display 
(0.1 second digits) 

10 11 SS1 
Manual and automatic 
switch 

6 26 
DPL 
1: 20 

stop time display 
(0.1 second digits) 
Stop time display 
(1 second digit) 

11 12 SS0 
Right end detection limit 
switch 

7 27 
DPL 
1: 21 

12 13 
DSW 
1: 20 

Continuous operation 
frequency setting 
digital switch 

8 28 
DPL 
1: 22 

13 14 
DSW 
1: 21 

9 29 
DPL 
1: 23 

14 15 
DSW 
1: 22 

10 30 
DPL 
2: 20 

stop time display 
(1 second digit) 

15 16 
DSW 
1: 23 

11 31 
DPL 
2: 21 

 
12 32 

DPL 
2: 22 

13 33 
DPL 
2: 23 
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1.6.1 Flowchart Example 
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1.7 Examples of answers 
 

No. Data 
Name 

Title START/ 
END 

Transition STOP/ 
RESUME 

Stop mode Continuous 
Transition 

Number of 
Active Steps 

0 Block Mode 
switching 

M100 M101 M102 M103 M104 D100 

 
 

No. Data 
Name 

Title START/ 
END 

Transition STOP/ 
RESUME 

Stop 
mode 

Continuous 
Transition 

Number of 
Active Steps 

1 Block1 Manual 
operation 

M105 M106 M107 M108 M109 D101 

 
 

No. Data 
Name 

Title START/ 
END 

Transition STOP/ 
RESUME 

Stop 
mode 

Continuous 
Transition 

Number of 
Active Steps 

2 Block2 Manual 
operation 

M110 M111 M112 M113 M114 D103 

 
  
  

No. Data 
Name 

Title START/ 
END 

Transition STOP/ 
RESUME 

Stop 
mode 

Continuous 
Transition 

Number of 
Active Steps 

3 Block3 Manual 
operation 

M115 M116 M117 M118 M119 D104 

 

  

 

  

 

  

 

 

 

 

 

 

 

 

 

 

 

  



143 
 

 

1.8 SFC Program for Emergency Stop 
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